[Support] kizaing - Kavita

Recommended Posts

Application:  Kavita

Website: https://www.kavitareader.com/

Dockerhub: https://hub.docker.com/r/kizaing/kavita

Github: https://github.com/Kareadita/Kavita

Wiki: https://wiki.kavitareader.com/

Discord Support Channel: https://discord.gg/b52wT37kt7


Kavita is a self hosted eBook/Comic/Manga reader with a beautiful user friendly reading interface. It currently has support for the following formats: 


Manga/Comics: ZIP, RAR, CBR, CBZ, CB7, CBT, TAR.GZ, 7ZIP/7Z

Books: EPUB2, EPUB3, PDF

Raw Images: JPG/JPEG, PNG


Running Kavita is fairly straight forward, run the following command and be sure to map your eBook/Comic libraries into the container.


docker run --name kavita -p 5000:5000 \
    -v /your/books/directory:/library \
    -v /kavita/data/directory:/kavita/data \
    --restart unless-stopped \
    -d kizaing/kavita:latest


If you have any questions or concerns, feel free to either comment in this support thread, or check out our Discord, the developers are very active and helpful!

Edited by Kizaing
Added hyperlinks
  • Thanks 1
Link to comment

Hey thanks for trying it out! There is not currently a plugin planned, but I can certainly pass that off to the developer of the app, and not sure if it's relevant, but OPDS support is planned if Tachiyomi supports that


Edit: I have been informed that a plugin is in the pipeline at some point, but most likely closer to a 1.0 release :)

Edit 2: There is now a Tachiyomi extension! At the time of writing it is just waiting to be merged into their extension repo, but it will be on there very soon 

Edited by Kizaing
Link to comment
  • 5 months later...
On 2/4/2022 at 6:40 AM, ku8475 said:

I might be an idiot, but is there a way to use swag to make my website point to this?

open up Notepad or Notepad++ and paste in 


server {
    listen 443 ssl;
    listen [::]:443 ssl;
    # Change Server_name to your subdomain
    server_name kavita.*;

    include /config/nginx/ssl.conf;

    client_max_body_size 0;

    # enable for ldap auth, fill in ldap details in ldap.conf
    #include /config/nginx/ldap.conf;

    # enable for Authelia
    #include /config/nginx/authelia-server.conf;

    location / {

  #include /config/nginx/authelia-location.conf;

    include /config/nginx/proxy.conf;

    set $upstream_app Kavita;
        set $upstream_port 5000;
        set $upstream_proto http;
        proxy_pass $upstream_proto://$upstream_app:$upstream_port;


Do "Save As"

name it "kavita.subdomain.conf"

select "Save as Type" All Files

this will make it a .conf file

move this to your Appdata/swag/nginx/proxy-confs/


this is only for a Subdomain not a Subfolder. 

also attached a copy if ya just wanna use that.


  • Like 1
Link to comment
  • 1 month later...
On 8/6/2021 at 12:56 AM, anima said:

looks great right now i am using komga, is there a https://tachiyomi.org plugin planed ?

There is one available now. :)


What's everyone using to tag their manga? Because the application doesn't (deliberately) make any use of folder structure which whilst maybe useful for it to not depend on it is a big drawback if you don't really have a nice way to tag your manga.


I know there are tools like manga-tagger, but they are Windows-GUI-only and boy does it want a LOT of dependencies for a end-user oriented application.


Set up a VM only for FMD2 and it, but manga-tagger refuses to function.


Apparently there's a docker-template for manga-tagger of a fork that doesn't rely on FMD2, but I'm hesitant to try it out.

  • Thanks 1
Link to comment
  • 3 months later...
On 7/2/2022 at 8:06 AM, Ikthayt said:

How would I get the Kavita-Email container to get pulled with this one?






I'd like to use my own SMTP email.  I don't know that I understand how to install and run this within this container and have it persist through updates.  Any suggestions or is there a separate unraid app for this?


I can set up a separate app for it, I'll get to work on that soon :)

  • Like 1
Link to comment
5 hours ago, Yellow NL said:

Hia Kizaing, thanks for this awesome work. 

I am trying to setup the new email container for use with a Gmail account. 

But i can't get this to work. 

Also the standard kavita mail never worked for me, always bringing back a 400 error. 



There is a bit of nuance to it, it's the way the Kavita developer set up the email app. So for gmail you'd use the following config:

           - SMTP_HOST=smtp.gmail.com
           - SMTP_PORT=587
           - SMTP_USER=<your gmail address>
           - SMTP_PASS=<google password>
           - SEND_ADDR=<your gmail address>
           - DISP_NAME=Kavita


Then in Kavita itself, under Admin Settings -> Email

Set the url to be http://<host-ip>:5003


Sometimes there is a bug where the email relay doesn't work, so if that still doesn't work try making sure you're using the latest stable release, and if that still doesn't work join us on the Discord and one of the devs can help troubleshoot it for you :) Hope that helps!

Link to comment

Well Kavita cannot reacht the mail docker. 

in the logg the mail docker says this :


info: Microsoft.Hosting.Lifetime[14]
      Now listening on: http://[::]:5003


So i think there is something wrong with the hosting of the mail docker? 


Also, i had the Kavita app on my custom docker network. 

If i put it on "host" then the standard Kavita mail works. 

Link to comment
  • 4 weeks later...

Hey! Just installed Kavita and it looks promising so far! And i've tried quite a few the last few days 😅


Only when inviting other people over, it doesn't work but i've read that was to be expected.

So i opened the log trying to complete the invite myself.

But when entering a name and password (can't change email at that point) i get:



The Email does not match the registered email.


Any idea what i'm doing wrong here?



Edit: Made my server accessible from outside, that solved it for me at least. Addicted to filling up Kavita now with all my old comics!

Edited by Exanimo
Link to comment
  • 1 month later...

For those that try to use the KavitaEmail from the community apps there is an issue with the template where the 'key' of each environment variables is not set. So edit each variable and set the Key the same as the Name (e.g. Name: SMTP_HOST, Key: SMTP_HOST).


Furthermore, if you are having Kavita and KavitaEmail on the same docker network (e.g. your reverse proxy network), simply set the Email Service Url in the Kavita settings to `http://kavitaemail:5003` (using the docker network domain name).

Edited by Ocgineer
  • Like 1
Link to comment
  • 1 month later...

Don't know if anyone else is experiencing this but im finding that the latest version of Kavita ( is causing my server to spike to 80% cpu usage by just the container being active.

I don't know why this is happening but it is consistently happening and i can stop the container and see my cpu usage drop straight away.

  • Upvote 1
Link to comment

Same for me, but cpu up to 100%. Useless 😢


On 10/29/2022 at 7:39 PM, Joeh said:

Don't know if anyone else is experiencing this but im finding that the latest version of Kavita ( is causing my server to spike to 80% cpu usage by just the container being active.

I don't know why this is happening but it is consistently happening and i can stop the container and see my cpu usage drop straight away.


Link to comment
On 11/1/2022 at 5:26 AM, Neohering said:

Same for me, cpu up to 95 - 100%.


Btw. Kavita + Kaizoku is ❤️


EDIT:// after a new setup it looks fine now 


Same I just installed and It Spike my CPU to 90% just running. I have limited to 6 Process core to keep my system from crash but any idea what is happening ? image.thumb.png.3a70e531d807047d0958fd85ba14052f.png

Link to comment

A fresh install of Kavita is not working for me.  I'm on unraid 6.11.1 and Kavita version is

The UI works and I can change settings and add libraries but no books appear.  I see this in the logs on startup which I'm guessing is the root of the problem:


Microsoft.Data.Sqlite.SqliteException (0x80004005): SQLite Error 1: 'no such table: ServerSetting'.


I tried deleting the config folder and starting over but it ends with the same result.

Link to comment
  • 2 months later...
On 8/3/2021 at 7:34 PM, Kizaing said:


If you have any questions or concerns, feel free to either comment in this support thread

Good day to you.

I'm new with unraid and installed the docker. 


I understood anything wrong.

Is the script also required when the docker will installed via App Center?


I installed it via App Center and set the folders via edit Docker. WebGui works fine and I see my Folder Library in the Web. I created a Library but scanning don't found anything.


Could you please try to help


Thanks a lot




Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.