How do I stop a file copy that is taking along time

Recommended Posts

Radarr initiated a file copy to my array and it has been going on for over 12 hours.  I would like to cancel the copy and try to figure out what's going on.


I tried looking under processes under tools, but I don;t recognoze anything as the copy.  How can I interrupt this copy?

Edited by RockDawg
Link to comment

How ironic... a power outage solved my 'how to stop the file copy' issue.  My server is connected to a UPS that has always provided a graceful shutdown.  This time it started doing a parity check upon restart.  I am assuming that's because the file operation prevented a graceful shutdown?  I really wish Unraid could force stop things like that and allow the rest of the system to shutdown gracefully.


Anyway, it looks like a borked drive.  I tried a few times to run a benchmark in DiskSpeed on the drive in question and it shows slower than expected speeds and then hangs at 90%.  I tried to run a short SMART test in Unraid, and it too hangs at 90%


I also ran hdparm on the drive and speeds are anemic (the drive is a HGST Ultrastar He12):


root@Anton:~# for ((i=0;i<5;i++)) do hdparm -tT /dev/sdj; done

 Timing cached reads:   9138 MB in  2.00 seconds = 4570.61 MB/sec
 Timing buffered disk reads:  54 MB in  3.23 seconds =  16.73 MB/sec

 Timing cached reads:   8934 MB in  2.00 seconds = 4468.75 MB/sec
 Timing buffered disk reads:  78 MB in  3.10 seconds =  25.15 MB/sec

 Timing cached reads:   8296 MB in  2.00 seconds = 4149.87 MB/sec
 Timing buffered disk reads:  66 MB in  4.23 seconds =  15.62 MB/sec

 Timing cached reads:   8346 MB in  2.00 seconds = 4175.11 MB/sec
 Timing buffered disk reads:  84 MB in  3.67 seconds =  22.91 MB/sec

 Timing cached reads:   9542 MB in  2.00 seconds = 4773.07 MB/sec
 Timing buffered disk reads: 150 MB in  3.30 seconds =  45.41 MB/sec


Edited by RockDawg
Link to comment

I am really stumped here.  All the sudden my drive started measuring fine.  So I benchmarked all my drives and they all appear normal.  Started playing around with Radarr trying to figure out why it won't import and noticing disk 4 and parity both having constant activity in the few hundred KB/s to a couple MB/s range.  But both reading the same at the same time.  Can't figure out why so I decide to stop the array.  It hangs at "syncing file systems".  After waiting a while I do a hard reset.  Upon reboot disk4 has changed again.  Radarr automatically starts importing the movie and it's moving along at a decent speed but then drops to super slow speeds.  Info in Main shows disk4 and parity with about 2MB/s read/write speeds.


Diagnostics attached.  Any ideas would be greatly appreciated.

Edited by RockDawg
Link to comment
6 hours ago, RockDawg said:

Alo noticed my drives are rearranged after the power outage.  The problem drive was disk 4 before, now it is disk8.  sdj both times.  

The serial number is the only thing that matters. I assume you don't mean the actual drive assignments changed.

Link to comment

After reboot, disk 4 changed from my 12TB drive to my 8TB drive.  I didn't pay attention to the order of the rest to know if any others changed.  Aside from that, I think I fixed my other issues.  Things kept getting worse and many of my Docker containers starting running really slow and ultimately the Docker service wouldn't even start.  I finally deleted my docker.img and rebuilt it and everything is running normally again.  Not sure what happened, but that seems to have worked.


I'll try rebooting tomorrow and check if the drive assignments stay the same since that has to be unrelated to Docker.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.