System hangs while loading bzimage

Recommended Posts

I've been trying to test unRAID Basic on an ASUS MB with a P4 CPU to make sure that I can boot from the USB.  It does boot and unRAID loads bzroot, but then the system seems to hang while loading bzimage.  After displayong several rows of dots, the load stops and nothing else happens.  I've left it for several hours and it's stuck at the same point.


Is the load bumping into some hardware issue?


Many thanks!



Link to comment
  • 2 months later...
  • 4 months later...

Same story for me.  :(


4.3.b6 hangs at the same place everytime; somewhere at or near the end of loading the rootfs.  No hardware changes, no BIOS changes, same USB key, reformat, re-syslinux, re-load with 4.2.4, boots to login prompt and runs fine.  Repeat procedure going back to 4.3.b6? ...hang in the same place.  Put 4.3.b6 USB key into ASUS A7N8X-E Deluxe, boots to login prompt.

Link to comment

1. The "-ma" syslinux option will help if the USB won't boot - meaning you never get to the boot menu where you can select unRAID or the memtest.  If you are getting to that screen, "-ma" won't help.


2. If you are having issues decompressing one of the "bz" files, you might try lowering the speed of the USB (from hi speed to full speed or some such).  The problem decompressing may be an issue with the USB speed.


3. If you are getting past the decompressing, and are hanging during boot, it MAY be a USB speed issue (#2), but that is not likely.  It is more likely that the OS is having some issue with your MB or addon cards.  Make sure you go into the BIOS and disable sound and other features that you will not use.  If it continues, take a digital picture of your screen at the hang point and post it here.  Post the specifics of your hardware.  There are folks on the forum that may be able to be specific about what unRAID is trying to do at that point in time in the boot process and offer suggestions.


Have you verified that your MB is compatable?

Link to comment

Thanks for the suggestions!  I tried them all but none worked.  :(


I swapped USB flash keys, same problem, so that tells me the keys are prepared

properly (HP format tool, -ma, fat32, etc)




#1 ASUS A7N8X-E Deluxe (nForce2), 1GB -- both 4.2.4 and 4.3b6 work fine.

#2 ASUS P5N32-SLI Deluxe (nForce590), 2GB -- 4.2.4 works fine, 4.3b6 hang loading bzroot


Counting dots, it doesn't look like syslinux competes the uncompress of bzroot and it

hangs in the same spot everytime.  What I'm unable to determine is if the hang is in

syslinux or after jumping into the early kernel init.  I wish I had access to an x86 hardware


Link to comment

With my nForce570 and 4.3b6, I found I had to add noapic to the append line of syslinux.cfg.  I also needed the noapic with 4.1, but not 4.2, which corresponds with what you are seeing.  I don't know why.  My symptoms were a little different, in that I could see some of the early console messages until 'kernel panic' occurred, so this may not help you.

Link to comment

Since 4.3 was released today, I decided to give it a shot....  same result: hangs while/after loading bzroot.


For some strange reason, I decided to boot the kernel without a rootfs.  Hit TAB in syslinux, removed initrd=bzroot from the kernel cmdline.  BOOTS!  This verifies kernel boots fine on my metal, even without any of: noapic, nolapic, apic=off.


At this point I'm convinced it's the rootfs image or syslinux itself.  After about an hour of rolling my own initrd image with no progress, I decided to check if there's a newer syslinux at


I grabbed pulled out syslinux.exe, ran syslinux -ma d: on my 4.3 stick.  SUCCESS!

Link to comment
  • 2 weeks later...
  • 2 years later...

Hello all,


I purchased the parts for an unraid server a while back and finally had the time to put them together but now I am running into a slight problem.  I set the BIOS to boot from USB, I turned off all the other HDD's for booting, I dumbed down the video memory so it uses as little as possible, and I get stuck on the screen in the attached picture.  It gets to the part where it asks me if i want to do a memtest or boot unraid and i select unraid and then get the attached screen.


Parts used

Case : NORCO RPC-4220

MoBo :  SUPERMICRO MBD-C2SEE-O LGA 775 Intel G43 ATX Intel Motherboard

OS : purchased the usb pre installed OS from Lime Tech

CPU : Intel Celeron 430 Conroe-L 1.8GHz 512KB L2 Cache LGA 775 35W Single-Core

RAM : Kingston 2GB 240-Pin DDR3 SDRAM DDR3 1066 (PC3 8500) Desktop Memory Model KVR1066D3N7/2G


HDD'sx4 : SAMSUNG Spinpoint F4 HD204UI 2TB 5400 RPM SATA 3.0Gb/s 3.5" Internal Hard Drive -Bare Drive

controler cards x2 : SuperMicro AOC-SASLP-MV8

Cablex2 : NORCO C-SFF8087-D SFF-8087 to SFF-8087 Internal Multilane SAS Cable

cable : 3Ware CBL-SFF8087OCF-05M SFF-8087 to Discrete Forward Breakout Cable


any information would be greatly appreciated.


PS. I also posted in General support but then found this page and #3 sounded like what is happpening to me, I tried slower usb but that did not help :(


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.