Jump to content

Can't get my custom docker container to run (SOLVED)


bukweet

Recommended Posts

I wanted to post this is in the Docker Containers forum but it looked like that is more aimed at Community Apps? Let me know if this is in the wrong place.

 

Anyhow, I've got me this docker image that runs a python app. It works just fine on my local machine, but when I pull it down to my unraid server I can't get it to run.

 

Here is the log that the container spits out:

 

WARNING: The requested image's platform (linux/arm64/v8) does not match the detected host platform (linux/amd64) and no specific platform was requested
standard_init_linux.go:219: exec user process caused: exec format error

 

I'm using the official python docker hub image for the base containers. In trying to troubleshoot I've rebuilt with a few different ones: rc-alpine3.13, alpine3.13, and am currently using python:3

 

I've gotten the same error message with all base images.

 

Here is the current Dockerfile

 

FROM python:3

WORKDIR /cord

COPY requirements.txt requirements.txt

RUN apt-get update

RUN apt-get install libffi-dev -y

RUN apt-get install build-essential -y

RUN apt-get install ffmpeg -y

RUN pip3 install -r requirements.txt

COPY . .

CMD ["python3","bot.py"]

 

I'm all out of google searches and any help is appreciated, thanks!

 

Edited by bukweet
solved
Link to comment
10 minutes ago, Squid said:

Unraid does not support running ARM applications.  Most applications if it supports ARM would also support x86 (look at the available tags on dockerHub)

 

Yeah, I was kind of picking that up from the linux/arm64/v8 bit of the error message, and started trying different tags because of it.

 

For example I've tried this one: docker pull python:alpine3.13 and it gets me to the same error. From what I can tell, and please tell me if I'm wrong, this image is for amd64, yes?

 

 

Link to comment

That image has amd and arm variants (and 386) as a shared tag (read the Description page of the docker image you're looking at and it'll give you a link to explain what a shared tag is). As the system isn't detecting/selecting the correct architecture automagically, you need to specify a "simple tag". So, read lower on that same page and it will give you links.

 

Which brings me back to...

 

Try:

FROM amd64/python:3

 

Link to comment
  • bukweet changed the title to Can't get my custom docker container to run (SOLVED)

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...