Swapped flash drive to a different USB port and now it won't boot

Recommended Posts

I'm running unRAID Pro version 6.10.0-rc1.  My system was running fine before I removed the USB flash drive to access a couple of eSATA ports located right below it on the rear panel to attach some cables.  I moved it so I wouldn't take the chance of damaging the flash drive.  I relocated it to another USB port on the rear panel and then booted up into the BIOS to make sure it was still configured as the first boot device.  Now it keeps telling me that I need to insert a proper boot device.  I moved the flash drive back to the original USB slot and checked to make sure it was still configured as the first boot device but it still won't boot.  I can see the flash drive internal LED flash when the system first starts up so it's being read.  I've been using the same flash drive ever since I first purchased unRAID back in February of 2008 and it has never failed to boot before.  I don't know if something somehow got corrupted on the flash drive that is preventing it from booting or what. Unfortunately, I have been extremely lax in making backups of the flash drive so the latest one I have is back in 2015.  Here's a screenshot of the files contained on the current flash drive:  I am unable to provide a diagnostics log since it won't boot.



Link to comment

Make a copy/backup of the current contents of the flash drive.  If no errors during the copy are reported, then run chkdsk on it.  If errors are found, you have your answer, the flash drive is corrupted!   (If the files in the /config folder/directory are OK, recovery is simple-- and most likely they are.)


If @Squid's suggestion does not work at this point, connect up a monitor and watch the boot process.  Where it hangs provides a lot of clues as to what to try next.

Link to comment
1 minute ago, captain_video said:

Tried that with no luck.  Can I just download unRAID 6.9.2 and overwrite the files on the flash drive?  I'm wondering if this is a glitch in 6.10.1-rc.


(Make the backup first!!!!!!)  This is one method that often works.   If you do this copy over just bz8 files first. 


I doubt if it is a problem that 6.10.0-rc1 caused.  My guess would be that the drive was pulled while it still had files open...

Link to comment

I made a backup copy of the contents previously and it copied with no problems.  I ran the make_bootable.bat script on the flash drive connected to my Windows 10 PC and it still would not boot.  I just ran chkdsk.exe on the flash drive and it reported no errors.  The server was shut down when I pulled the USB drive.  I never disconnect anything while it's still powered up, except the ethernet cable.


The system goes through the initial check of the HBA controllers and lists all of the drives attached.  It cycles back to the initial Asus splash screen and blinks once or twice and then tells me to reboot and select the proper boot device.  I've gone back into the UEFI setup screen numerous times and made sure the Sandisk flash drive is configured as the first boot device and it still won't boot.


The system booted into 6.10.1-rc1 with no problems after updating the OS.  I had been having issues with my Intel PCIe NIC and I had removed the flash drive to avoid damaging it.  I moved it to another USB port and then tried to boot the system back up.  That's when the problem started.  It's got me completely stumped.


So I can just copy the 6.9.2 files over from the downloaded zip file, but just copy the bz* files and leave everything else as is?


Link to comment

From your Description of the boot process, it is not getting that far.  I would copy over the /syslinux folder and run the make_bootable script again.  (Remember to do this as Administrator!)


IF that doesn't work, you have two choices.


1---  Start with a new flash drive and install the version you want to use.  See if that drive will boot.  If it does, you can copy the /config folder and overwrite everything on that folder.  That should have your system running the same as before all of this started.  You will be prompted to update your .key file so that it is registered to the new drive.  (this is an automatic process and should only take a few minutes...)


2--  Format the present drive and install whatever version you want on it.  ( I would check that it now boots...)  And copy the /config folder onto it. 


With choice 2, you are losing a secondary backup of the current configuration but only you can determine your level of risk tolerance associated with that.

Link to comment

Success!  I still couldn't get the system to boot after making the above changes.  I never got around to trying options 1 or 2 from Frank1940's suggestions.  I got back into the UEFI BIOS settings and I drilled down until I discovered that the boot order showed the USB drive as the 15th device in the boot order even though I had specified it as the first boot device elsewhere in the settings.  Once I changed it so the Sandisk flash drive was the first device in the boot order it booted clean and I am able to access the server via the web GUI on my PC.  Thanks to all for your help and suggestions.


I guess when I swapped the flash drive to a different USB port it changed the boot order.  The option to set that was buried in one of those options that made you scroll down in the screen to find it.

Link to comment
3 hours ago, captain_video said:

when I swapped the flash drive to a different USB port it changed the boot order.

BIOS often tries to "help" like that. Now that you know you can check if it happens again.

3 hours ago, captain_video said:

showed the USB drive as the 15th device in the boot order

No point in having anything else in the boot order.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.