Jump to content

Unraid 6.9.2 array not defined UPDATED (not solved)

Recommended Posts

Lately, after the server has been up for a while, I log in and see that I am getting an "array not defined" error along the bottom.  Obviously, the drives are not showing, and dockers are not showing either.  I try to download diag info when it happens, but can't.  Attaching diags from after a reset.  Recently, I have rearranged my media folder and cleaned out TV shows.  I mention this because I am downloading quite a bit through sonarr and I am converting to HEVC utilizing Unmanic.  I have a GPU that is working pretty hard to convert to HEVC, but nothing is over heating, etc.  Help or direction would be appreciated.kashmir-diagnostics-20210904-1309.zip

Edited by ZosoPage1963
server did it again.
Link to comment

thanks for the reply.  I have had the flash drive in the same usb port for 3 years.   I stopped downloading and converting using unmanic at the same time, and the problem has gone away.  I just wonder if the combination of my cache drive filling up, coupled with the work that unmanic was doing, just made the array go wonky.  Will mark this as solved but in case someone has the same problem in the future, what caused this to happen was never really found.

Link to comment
  • ZosoPage1963 changed the title to Unraid 6.9.2 array not defined UPDATED (not solved)

server is currently experiencing this issue.


on the bottom, Array Started /Array undefined is flashing back and forth.


On the "Main" Tab, there is this message:

Warning: Invalid argument supplied for foreach() in /usr/local/emhttp/plugins/dynamix/include/DefaultPageLayout.php(522) : eval()'d code on line 19


On the user shares tab, there is this message:


Warning: syntax error, unexpected end of file, expecting TC_DOLLAR_CURLY or TC_QUOTED_STRING or '"' in state/shares.ini on line 271 in /usr/local/emhttp/plugins/dynamix/include/ShareList.php on line 21


its very weird, because I am using a VM on this server to write this.  The VM is on my cache drive.  Since there are no drives. 


Is there any command i can run in terminal  that will grab some info?

Link to comment
18 minutes ago, ZosoPage1963 said:

syslog.txt to show multiple browsers open

You do have "wrong csrf_token", which often indicates that.


But you have even more "uninitialized csrf_token", which suggests you have filled rootfs.


In fact, full rootfs is a very likely cause of all your problems, since it basically prevents the OS (which is in rootfs) from working with its own files.


One possible way to fill rootfs is a docker mapping to a host path that isn't actual storage.

Link to comment

went through all dockers and host paths all point to somewhere within /mnt/user/  which to my understanding, would be storage.  I did remove one docker container, Unmanic, to see if maybe I had something set up incorrect there.  I am using /tmp to transcode in Plex, but I think I saw somewhere that is where we want to transcode from.  Will update again in a week or so unless this happens again sooner.  Thank you again for the suggestions as I am quite lost on this.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...