Intel 12th generation Alder Lake / Hybrid CPU


Recommended Posts

3 hours ago, correctomundo said:

Does anyone have an idea if we can expect Plex support for HDR/Tone Mapping for Alder Lake iGPU's anytime soon?

Noone can answer that, but obviously Plex is going to prioritize getting their software fully functional on current hardware, so probably.  Soon (TM)

  • Haha 2
Link to comment
3 hours ago, correctomundo said:

Does anyone have an idea if we can expect Plex support for HDR/Tone Mapping for Alder Lake iGPU's anytime soon?

Nope. But you might be able to keep track of any updates here. Chuck hasn't posted recently, but I would expect him to either update this thread or close it and create a new one with Alder Lake updates.

 

https://forums.plex.tv/t/pms-packaging-07-2022-update-forum-preview-testing/799912

Link to comment

new to alder lake CPU. i upgraded from i5-8400 to 12600k and have had a horrible time getting my system back up and running. im a noob so ive made some mistakes. from the moment i started the server i had issues with docker containers hanging up and not shutting down mainly nzbget. it would hang up and eventually bring the whole system down . i even went as far as installing all new docker containers and at least my whole server is still running but i ran into same issues with nzbget where it just wont shut down and i have a cpu core 4 pinned to 100 since this. only way to stop it would be to reset whole server . 

Link to comment
10 minutes ago, qnzkrew said:

new to alder lake CPU. i upgraded from i5-8400 to 12600k and have had a horrible time getting my system back up and running. im a noob so ive made some mistakes. from the moment i started the server i had issues with docker containers hanging up and not shutting down mainly nzbget. it would hang up and eventually bring the whole system down . i even went as far as installing all new docker containers and at least my whole server is still running but i ran into same issues with nzbget where it just wont shut down and i have a cpu core 4 pinned to 100 since this. only way to stop it would be to reset whole server . 

Might help if you posted Diagnostics ;-)  Tools > Diagnostics  I had a load of issues initially, but now I'm running a dozen docker images, hardware transcoding on Plex (still working on getting QSV on Handbrake to work correctly), but nothing is causing a hard lockup anymore.  At one point my RAM was the issue, and then after I got that sorted I had to clear out my docker.img and have it manually re-download/recreate.

Link to comment
1 hour ago, NightOps said:

Might help if you posted Diagnostics ;-)  Tools > Diagnostics  I had a load of issues initially, but now I'm running a dozen docker images, hardware transcoding on Plex (still working on getting QSV on Handbrake to work correctly), but nothing is causing a hard lockup anymore.  At one point my RAM was the issue, and then after I got that sorted I had to clear out my docker.img and have it manually re-download/recreate.

im sorry but which files inside the diagnostic folder would help narrow down the issue . ive included the whole zip folder . thanks in advance 

tower-diagnostics-20220906-1649.zip

Link to comment
14 minutes ago, qnzkrew said:

im sorry but which files inside the diagnostic folder would help narrow down the issue . ive included the whole zip folder . thanks in advance 

tower-diagnostics-20220906-1649.zip 135.48 kB · 0 downloads

Typically just sending the full ZIP file is best.  Also, for specific docker issues, make sure that you post in the author's forum page.  If you are using Linuxserver.io's NZBGet, then you can find it here: 

 

I can't be certain, I've not encountered the same issue (using SABNzbD), but I am seeing BTRFS errors/warnings in your syslog:

Sep  6 13:58:14 Tower kernel: BTRFS warning (device nvme1n1p1): csum failed root 5 ino 92185 off 335380480 csum 0x90b48b64 expected csum 0xed4418db mirror 1
Sep  6 13:58:14 Tower kernel: BTRFS error (device nvme1n1p1): bdev /dev/nvme1n1p1 errs: wr 0, rd 0, flush 0, corrupt 2, gen 0

 

Other forums indicate deleting/recreating your docker.img which is pretty simply:

  • Login to your system from the unRAID webGui (http://tower or http://tower.local from Mac by default).
  • Navigate to the Docker tab.
  • Stop the Docker service if it is not already.
  • Click the checkbox next to the Docker image that says Delete Image File.
  • Click the Delete button after clicking the checkbox to delete the image (this may take some time depending on the size of your image).
  • After the file has been deleted, you can simply re-enable the Docker service and the image will be created in the same storage location with the same name.

Once you've done that, you may also want to delete your NZBGet docker and completely wipe the folder in appdata for it to clear all settings, then rebuild it.

 

If you've already done this, you may want to install the "Fix Common Problems" app, see if it identifies any issues, and resolve as appropriate.

 

Again, I'm still a bit of a n00b, but just some steps I've done to resolve issues with my initial setup.  If you've tried all these and aren't sure where to go next, post in the forum I linked above.

Edited by NightOps
Link to comment
13 minutes ago, NightOps said:

Typically just sending the full ZIP file is best.  Also, for specific docker issues, make sure that you post in the author's forum page.  If you are using Linuxserver.io's NZBGet, then you can find it here: 

 

I can't be certain, I've not encountered the same issue (using SABNzbD), but I am seeing BTRFS errors/warnings in your syslog:

Sep  6 13:58:14 Tower kernel: BTRFS warning (device nvme1n1p1): csum failed root 5 ino 92185 off 335380480 csum 0x90b48b64 expected csum 0xed4418db mirror 1
Sep  6 13:58:14 Tower kernel: BTRFS error (device nvme1n1p1): bdev /dev/nvme1n1p1 errs: wr 0, rd 0, flush 0, corrupt 2, gen 0

 

Other forums indicate deleting/recreating your docker.img which is pretty simply:

  • Login to your system from the unRAID webGui (http://tower or http://tower.local from Mac by default).
  • Navigate to the Docker tab.
  • Stop the Docker service if it is not already.
  • Click the checkbox next to the Docker image that says Delete Image File.
  • Click the Delete button after clicking the checkbox to delete the image (this may take some time depending on the size of your image).
  • After the file has been deleted, you can simply re-enable the Docker service and the image will be created in the same storage location with the same name.

Once you've done that, you may also want to delete your NZBGet docker and completely wipe the folder in appdata for it to clear all settings, then rebuild it.

 

If you've already done this, you may want to install the "Fix Common Problems" app, see if it identifies any issues, and resolve as appropriate.

 

Again, I'm still a bit of a n00b, but just some steps I've done to resolve issues with my initial setup.  If you've tried all these and aren't sure where to go next, post in the forum I linked above.

 okay i will try this , i think my docker image might have been messed up when the cache drive got messed up, ill try and check thanks 

Link to comment
10 hours ago, qnzkrew said:

im sorry but which files inside the diagnostic folder would help narrow down the issue . ive included the whole zip folder . thanks in advance

Btrfs is detecting data corruption, start by running memtest.

  • Like 1
Link to comment

i-5 12600k

 

okay so i have the plexpass docker container and added: plexpass  , ive set plex to beta and restarted the container. i followed the guide for the gpu transcoing . ive installed the intel gpu top driver and i cant seem to get hardware transcoding. i can console intel gpu top and see the gpu but i dont have it as a dropdown menu in the GPU statistics plug in like i do my nvidia gpu . is there any troubleshooting i can do . thanks in advance 

Link to comment
4 hours ago, qnzkrew said:

okay so i have the plexpass docker container and added: plexpass  , ive set plex to beta and restarted the container. i followed the guide for the gpu transcoing . ive installed the intel gpu top driver and i cant seem to get hardware transcoding. i can console intel gpu top and see the gpu but i dont have it as a dropdown menu in the GPU statistics plug in like i do my nvidia gpu . is there any troubleshooting i can do . thanks in advance 

Which container are you using? If not using the official one I would strongly recommend that you use the official one since third party containers gave me recently a few issues with hardware transcoding.

 

Also make sure that you are on Unraid 6.11.0-rc4.

Link to comment
2 hours ago, ich777 said:

Which container are you using? If not using the official one I would strongly recommend that you use the official one since third party containers gave me recently a few issues with hardware transcoding.

 

Also make sure that you are on Unraid 6.11.0-rc4.

im on rc4 and im using plexinc/pms-docker:plexpass. and i have se it at beta . i had to physically remove the nvidia gpu to at least have alder lake gpu show up in statistics plugin. once i choose it in plug in i dont see any action it shows zero watts even though when i console inteltop i can see some watts used. before i removed the nvidia gpu i tried to set all the console comands a few page back which had me enter a set of commands to save something like chmod becuase one of the users had issues and was instructed to ALSO do that. now im not sure if that did anything bad while i was trying to fix it . when i was trying those commands it was becuase i could not get igpu to show up on gpu statistics 

Link to comment
40 minutes ago, qnzkrew said:

physically remove the nvidia gpu to at least have alder lake gpu show up in statistics plugin

Is a monitor connected to the iGPU? It is often the case that even if you enable the iGPU in the BIOS and have a dGPU installed that it doesn't show up, also the case on my 10th gen motherboard. To solve this connect a display to the iGPU or even easier install a HDMI Dummy Plug to the iGPU.

 

45 minutes ago, qnzkrew said:

plexinc/pms-docker:plexpass

It should also be enough to install: plexinc/pms-docker

 

From what I know the Alder Lake iGPUs should now work fine with a recent version from the official Plex container.

Link to comment
9 hours ago, qnzkrew said:

i-5 12600k

 

okay so i have the plexpass docker container and added: plexpass  , ive set plex to beta and restarted the container. i followed the guide for the gpu transcoing . ive installed the intel gpu top driver and i cant seem to get hardware transcoding. i can console intel gpu top and see the gpu but i dont have it as a dropdown menu in the GPU statistics plug in like i do my nvidia gpu . is there any troubleshooting i can do . thanks in advance 

I see no mention if you adding /dev/dri. Did you?

  • Like 1
Link to comment

okay now i habe plex transcoding but if i can bother you fine gentlemen one last time . i had plex crash but it also took down the VM so im thinking i have an issue with the two new NVME drives i have as cache which im also using to transcode and hole my VM .. i will post full logs but this is what i saw. just asking how i can go about diagnosing this and fixing it. two brand new nvme 1 tb each i guess they go in as raid 1

 

 

Sep  9 16:42:51 Tower kernel: BTRFS error (device nvme1n1p1): block=520864874496 write time tree block corruption detected
Sep  9 16:42:51 Tower kernel: BTRFS: error (device nvme1n1p1) in btrfs_commit_transaction:2418: errno=-5 IO failure (Error while writing out transaction)
Sep  9 16:42:51 Tower kernel: BTRFS info (device nvme1n1p1: state E): forced readonly
Sep  9 16:42:51 Tower kernel: BTRFS warning (device nvme1n1p1: state E): Skipping commit of aborted transaction.
Sep  9 16:42:51 Tower kernel: BTRFS: error (device nvme1n1p1: state EA) in cleanup_transaction:1982: errno=-5 IO failure
Sep  9 16:42:52 Tower kernel: I/O error, dev loop2, sector 892640 op 0x1:(WRITE) flags 0x1800 phys_seg 4 prio class 0
Sep  9 16:42:52 Tower kernel: BTRFS error (device loop2): bdev /dev/loop2 errs: wr 1, rd 0, flush 0, corrupt 0, gen 0
Sep  9 16:42:52 Tower kernel: I/O error, dev loop2, sector 368352 op 0x1:(WRITE) flags 0x1800 phys_seg 4 prio class 0
Sep  9 16:42:52 Tower kernel: BTRFS error (device loop2): bdev /dev/loop2 errs: wr 2, rd 0, flush 0, corrupt 0, gen 0
Sep  9 16:42:52 Tower kernel: I/O error, dev loop2, sector 892672 op 0x1:(WRITE) flags 0x1800 phys_seg 4 prio class 0
Sep  9 16:42:52 Tower kernel: BTRFS error (device loop2): bdev /dev/loop2 errs: wr 3, rd 0, flush 0, corrupt 0, gen 0
Sep  9 16:42:52 Tower kernel: I/O error, dev loop2, sector 368384 op 0x1:(WRITE) flags 0x1800 phys_seg 4 prio class 0
Sep  9 16:42:52 Tower kernel: BTRFS error (device loop2): bdev /dev/loop2 errs: wr 4, rd 0, flush 0, corrupt 0, gen 0
Sep  9 16:42:52 Tower kernel: I/O error, dev loop2, sector 368000 op 0x1:(WRITE) flags 0x1800 phys_seg 33 prio class 0
Sep  9 16:42:52 Tower kernel: BTRFS error (device loop2): bdev /dev/loop2 errs: wr 5, rd 0, flush 0, corrupt 0, gen 0
Sep  9 16:42:52 Tower kernel: I/O error, dev loop2, sector 892288 op 0x1:(WRITE) flags 0x1800 phys_seg 33 prio class 0
Sep  9 16:42:52 Tower kernel: BTRFS error (device loop2): bdev /dev/loop2 errs: wr 6, rd 0, flush 0, corrupt 0, gen 0
Sep  9 16:42:52 Tower kernel: I/O error, dev loop2, sector 368416 op 0x1:(WRITE) flags 0x1800 phys_seg 58 prio class 0
Sep  9 16:42:52 Tower kernel: BTRFS error (device loop2): bdev /dev/loop2 errs: wr 7, rd 0, flush 0, corrupt 0, gen 0
Sep  9 16:42:52 Tower kernel: I/O error, dev loop2, sector 892704 op 0x1:(WRITE) flags 0x1800 phys_seg 58 prio class 0
Sep  9 16:42:52 Tower kernel: BTRFS error (device loop2): bdev /dev/loop2 errs: wr 8, rd 0, flush 0, corrupt 0, gen 0
Sep  9 16:42:52 Tower kernel: BTRFS: error (device loop2) in btrfs_commit_transaction:2418: errno=-5 IO failure (Error while writing out transaction)
Sep  9 16:42:52 Tower kernel: BTRFS info (device loop2: state E): forced readonly
Sep  9 16:42:52 Tower kernel: BTRFS warning (device loop2: state E): Skipping commit of aborted transaction.
Sep  9 16:42:52 Tower kernel: BTRFS: error (device loop2: state EA) in cleanup_transaction:1982: errno=-5 IO failure
Sep  9 16:42:52 Tower kernel: I/O error, dev loop2, sector 39016 op 0x1:(WRITE) flags 0x800 phys_seg 2 prio class 0
Sep  9 16:42:52 Tower kernel: BTRFS error (device loop2: state EA): bdev /dev/loop2 errs: wr 9, rd 0, flush 0, corrupt 0, gen 0
Sep  9 16:42:58 Tower kernel: I/O error, dev loop2, sector 26624 op 0x1:(WRITE) flags 0x100000 phys_seg 1 prio class 0
Sep  9 16:42:58 Tower kernel: BTRFS error (device loop2: state EA): bdev /dev/loop2 errs: wr 10, rd 0, flush 0, corrupt 0, gen 0
Sep  9 16:42:58 Tower kernel: I/O error, dev loop2, sector 39016 op 0x1:(WRITE) flags 0x100000 phys_seg 8 prio class 0
Sep  9 16:42:58 Tower kernel: BTRFS error (device loop2: state EA): bdev /dev/loop2 errs: wr 11, rd 0, flush 0, corrupt 0, gen 0
Sep  9 16:42:58 Tower kernel: I/O error, dev loop2, sector 39136 op 0x1:(WRITE) flags 0x100000 phys_seg 45 prio class 0
Sep  9 16:42:58 Tower kernel: BTRFS error (device loop2: state EA): bdev /dev/loop2 errs: wr 12, rd 0, flush 0, corrupt 0, gen 0
Sep  9 16:42:58 Tower kernel: I/O error, dev loop2, sector 29256 op 0x1:(WRITE) flags 0x100000 phys_seg 15 prio class 0
Sep  9 16:42:58 Tower kernel: BTRFS error (device loop2: state EA): bdev /dev/loop2 errs: wr 13, rd 0, flush 0, corrupt 0, gen 0
Sep  9 16:42:58 Tower kernel: I/O error, dev loop2, sector 1124552 op 0x1:(WRITE) flags 0x104000 phys_seg 128 prio class 0
Sep  9 16:42:58 Tower kernel: I/O error, dev loop2, sector 1125584 op 0x1:(WRITE) flags 0x100000 phys_seg 51 prio class 0
Sep  9 16:42:58 Tower kernel: BTRFS error (device loop2: state EA): bdev /dev/loop2 errs: wr 14, rd 0, flush 0, corrupt 0, gen 0
Sep  9 16:42:58 Tower kernel: I/O error, dev loop2, sector 29376 op 0x1:(WRITE) flags 0x100000 phys_seg 42 prio class 0
Sep  9 16:42:58 Tower kernel: BTRFS error (device loop2: state EA): bdev /dev/loop2 errs: wr 15, rd 0, flush 0, corrupt 0, gen 0
Sep  9 16:42:58 Tower kernel: I/O error, dev loop2, sector 1126000 op 0x1:(WRITE) flags 0x104000 phys_seg 128 prio class 0
Sep  9 16:42:58 Tower kernel: I/O error, dev loop2, sector 1127024 op 0x1:(WRITE) flags 0x100000 phys_seg 33 prio class 0
Sep  9 16:42:58 Tower kernel: BTRFS error (device loop2: state EA): bdev /dev/loop2 errs: wr 16, rd 0, flush 0, corrupt 0, gen 0
Sep  9 16:42:58 Tower kernel: I/O error, dev loop2, sector 40992 op 0x1:(WRITE) flags 0x100000 phys_seg 95 prio class 0
Sep  9 16:42:58 Tower kernel: BTRFS error (device loop2: state EA): bdev /dev/loop2 errs: wr 17, rd 0, flush 0, corrupt 0, gen 0
Sep  9 16:42:58 Tower kernel: BTRFS error (device loop2: state EA): bdev /dev/loop2 errs: wr 18, rd 0, flush 0, corrupt 0, gen 0
Sep  9 17:01:14 Tower  crond[1330]: exit status 1 from user root /usr/local/sbin/mover &> /dev/null

tower-diagnostics-20220909-1804.zip

Link to comment
8 hours ago, qnzkrew said:

i have an issue with the two new NVME drives i have as cache which im also using to transcode and hole my VM .. i will post full logs but this is what i saw. just asking how i can go about diagnosing this and fixing it. two brand new nvme 1 tb each i guess they go in as raid 1

This has nothing to do with the current topic.

It would be best not to pollute or derail this thread.

 

Please create a new thread in general support https://forums.unraid.net/forum/55-general-support/

Add as much details on your pool problems as you know as well as your diagnostics.

Link to comment
10 hours ago, talwen said:

I have read all of the pages, but do not understand what exactly is needed to make it work.

 

Is there a comprehensive how to for 12th gen and plex transcode

Yes. Use the latest version of Unraid and follow the multiple guides for setting up Plex transcoding. There's no special sauce here.

Link to comment
On 9/15/2022 at 9:25 AM, flyize said:

Yes. Use the latest version of Unraid and follow the multiple guides for setting up Plex transcoding. There's no special sauce here.

 

So to be clear, all compatibility issues around 12th gen CPU's are resolved with the latest version of Unraid?

To get the latest version, you would go to Tools->UpdateOS and then select "Next" instead of "stable"?

Will be building out a new system and was planning on a i3-12100, and its confusing to read through all the threads of issues with iGPU because of the quick development in unraid OS. Just trying to make sure itll be a drama free process, or if special attention is needed anywhere, that i know what to expect.

Link to comment
5 hours ago, TurboStreetCar said:

 

So to be clear, all compatibility issues around 12th gen CPU's are resolved with the latest version of Unraid?

Tone mapping is still missing.  I still have it enabled.  For my setup, it will use the CPU to tone map HDR content and the iGPU for the rest.

 

Quote

To get the latest version, you would go to Tools->UpdateOS and then select "Next" instead of "stable"?

 

Correct.  Run the upgrade compatibility check first.

 

Quote

Will be building out a new system and was planning on a i3-12100, and its confusing to read through all the threads of issues with iGPU because of the quick development in unraid OS. Just trying to make sure itll be a drama free process, or if special attention is needed anywhere, that i know what to expect.

I agree; no need to make it unnecessarily mysterious. 

  • UNRAID:  install intel GPU TOP and GPU statistics.  GPU stats will show up on the dashboard page, click on the gears and chose intel.
  • PLEX container:  Add "--device=/dev/dri:/dev/dri" to the extra parameters section if you're using the linuxserver plex container. 

Test out some items that regularly transcode.  You will see (hw) on the plex dashboard and GPU activity on the dashboard.

  • Like 4
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.