Jump to content

Custom networks no longer working after 6.9.1

Recommended Posts

Does anyone have a way to fix my containers not being able to use custom network any longer after upgrading? It started with 6.9 but still isnt fixed for me in 6.10.


I just get "No such container" error if I click start on anything that uses a a custom network And the error when applying custom network while editing the container is "docker: Error response from daemon: network Mynet not found. The command failed."


I had custom networks working for over a year now after following spaceinvaderones video and just cannot figure out what happened or how to fix it. 


Link to comment
33 minutes ago, Squid said:

Have you tried recreating the Mynet network?

I tried making another one and using that and I got the same error. Would it be be better to recreate the original or would this accomplish the same thing?


The networks show up correctly from the dropdown in edit container. and when I list the networks in terminal they show up as what appears to me to be correct


# docker network inspect Liquidnet
        "Name": "Liquidnet",
        "Id": "edited out",
        "Created": "2021-07-17T17:10:47.916206832-04:00",
        "Scope": "local",
        "Driver": "bridge",
        "EnableIPv6": false,
        "IPAM": {
            "Driver": "default",
            "Options": {},
            "Config": [
                    "Subnet": "",
                    "Gateway": ""
        "Internal": false,
        "Attachable": false,
        "Ingress": false,
        "ConfigFrom": {
            "Network": ""
        "ConfigOnly": false,
        "Containers": {},
        "Options": {},
        "Labels": {}


Thank you for such a quick reply as always

Edited by Liquidbings
Link to comment

Ok so after some more investigating on my end I tried making another liquidnet with all lowercase and reinstalling the swag container started getting a different error this time around. 


"Docker: Error response from daemon: driver failed programming external connectivity on endpoint swag (642dd79e56b00d7ad807afeff98f2501afb16cdebe19a2666ed63a74bb2dbe11): Error starting userland proxy: listen tcp4 bind: address already in use."


So I did a netstat lookup on 80 and it shows nginx and nginx workers on there. I wasn't sure if this something that may be causing an issue or is it something I'm unfamiliar with and normal?

Link to comment
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...