Old usb key on new hardware, it doesn't want to boot


Recommended Posts



I upgraded my hardware configuration from an Asus B85M-G / i5-4440 to an MSI B560M Pro / i5-10400.


I just plugged the old usb key to an USB port on the motherboard. Selected manual boot but when I choose the USB key, display blink and returns to the select usb key. I also tried to put on BIOS only USB key on boot, it doesn't work, it boot on BIOS like the usb key was "broken".




Update :


- I tried with a Windows 10 USB stick, it worked.

- I tried to switch UEFI bios to CSM, BIOS don't boot

- I re-flashed a new USB stick with "Allow UEFI boot" enable, don't work.

Edited by Alex.b
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.