Installing docker cli plugins (specifically docker-compose v2)


Recommended Posts

Docker Compose v2 is now primarily a plugin for docker instead of a standalone application. The directions on compose's github are as follows:
 

Quote

 

Copy the relevant binary for your OS under $HOME/.docker/cli-plugins/docker-compose

Or copy it into one of these folders for installing it system-wide:

  • /usr/local/lib/docker/cli-plugins OR /usr/local/libexec/docker/cli-plugins
  • /usr/lib/docker/cli-plugins OR /usr/libexec/docker/cli-plugins

(might require to make the downloaded file executable with chmod +x)

 

 

How would I do this in unraid? None of these locations exist in unraid. I see a "plugins" folder in my docker folder but putting docker-compose there and then chmod +x does nothing (I also tried the "plugins/storage" folder and the "plugins/storage/ingest" folder). I also tried creating the "cli-plugins" folder in $HOME/.docker (which is linked to /boot/config/plugins/dockerMan/), but that didn't work either.

Edited by hasown
Link to comment
  • hasown changed the title to Installing docker cli plugins (specifically docker-compose v2)

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.