Jump to content

Brand new vanilla setup - no internet access from unraid


Recommended Posts

Hello everyone,

 

My first time Unraid user, just purchased a new pc to build a brand new spanking nas.

Everything went just fine until I tried to start installing the CA plugin, it is only then that I realized that Unraid had no access to internet.

 

It sees my local network no problem, it can ping the Google DNS (8.8.8.8, etc.) but it cannot ping www.google.com or anything else.

 

I have 2 NIC on the setup, one embedded on the motherboard and one Intel X540-T1 10GbE. At first I thought that I might have screwed up the configuration with the 2 NIC so I took out the Intel and plugged the onboard one. No luck, still exact same issue.

 

The I installed a brand new unraid from a new USB key with a trial license (on the main one, I purchased the pro) with only the onboard card to make sure I had the most vanilla install as possible. Still no luck, exact same behavior. So it seems, it is not any sort of configuration that I have done and possibly not my hardware.

 

My local network is extremely simple:

- 1 single router (Google Wifi Mesh), local subnet is 192.168.86.XX

- have a bunch of Google Wifi Mesh as repeater throughout the house - all cabled directly to the main router, so everything is 192.168.86.XX

- unraid IP addresses are DHCP reserved based on the MAC Address of each NIC. Onboard: 192.168.86.102 & Intel: 192.168.86.101. Both work fine and get the right IP address depending on which card I cable.

 

Then I thought maybe there was some sort of config the Wifi Router preventing Unraid from accessing outside or something, but none of the devices that I have plugged in or wified in needed any configuration whatsoever.

 

I am completely at a loss... I have no idea what to try next... I am by no mean a network expert, but I am also decently knowledgable.

 

Any help would be appreciated.

 

Thx,

 

Alex

Link to comment

Ok the weirdest thing happened this morning... 

I have changed 0 configuration settings, changed nothing on the router side either... and somehow magically, the unraid system can now ping google...

 

You can see below, I was sshed into unraid, I pinged www.google.com last night - nothing, and tried the command again this morning and now it works !?!

 

image.png.1064fc3639edaad19b4e7ca597ccc99d.png

Link to comment
3 hours ago, citizengray said:

Right, but why would only unraid be impacted !? I have a slew of other devices that I had no problem connecting... including an old QNAP Nas that was doing it's thing without issue.

Or DNS issues ? Is Unraid using different DNSs than the other systems ?

I read that the facebook ecosystem failure that happened yesterday had a huge increase on DNS activity for most suppliers.

Link to comment

No I don't think that is a DNS issue.

 

1. I noticed the issue over the week end (Sunday evening - there was no facebook issue at this point)

2. My router has Google DNS setup as default and propagate them automatically via DHCP to all devices.

3. I was able to ping the DNS (8.8.8.8) from the unraid console, yet I still had no internet access

Link to comment

It is definitely not a DNS issue... as soon as I finished the parity build, I rebooted unraid, and boom upon restart, no access to internet again.

Unraid has been up for 15 hours now, and still no access. No other devices has any issues on my network.

Starting to regret buying the pro license... how can this be ?

Link to comment
On 10/4/2021 at 8:19 AM, citizengray said:

Everything went just fine until I tried to start installing the CA plugin, it is only then that I realized that Unraid had no access to internet

According to your diagnostics file (and the network config screenshot) you have NIC bonding enabled.  It is probably a good idea to get a single unbonded NIC working as a first step.  NIC bonding with certain NICs has been known to cause connectivity issues in the past.  No guarantee this is the problem but it won't hurt to disable bonding.

Link to comment

And boom it happened again... not touching a single thing.

Array has now been up for 1 day, 14 hours, 57 minutes and this morning I have "found" internet access again...

 

root@unraid:~# ping www.google.com
^C
root@unraid:~# ping www.google.com
PING www.google.com (142.250.69.228) 56(84) bytes of data.
64 bytes from den08s05-in-f4.1e100.net (142.250.69.228): icmp_seq=1 ttl=115 time=12.6 ms
64 bytes from den08s05-in-f4.1e100.net (142.250.69.228): icmp_seq=2 ttl=115 time=12.7 ms
64 bytes from den08s05-in-f4.1e100.net (142.250.69.228): icmp_seq=3 ttl=115 time=12.5 ms
64 bytes from den08s05-in-f4.1e100.net (142.250.69.228): icmp_seq=4 ttl=115 time=12.9 ms
^C
--- www.google.com ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 12.508/12.684/12.867/0.134 ms

 

 

This is so weird...

Link to comment

I just had troubles with three NICs bonded, two on motherboard: 1G is eth0, 2.5G is eth1 and 10G card eth2. The default configuration seems to want to use eth0 as primary and others as backup. I'm not sure if i saw just UI issue or real, but after trying to swap eth0 <-> eth2 in interface rules all cards showed same MAC. The 10G card (which was now eth0) didn't work after the swap.

 

I ended up disabling in BIOS the motherboard NICs, and using just the 10G card. Now it works.

Link to comment
  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...