Appdata on all my disks

Recommended Posts

  • Replies 124
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Actually not. It is still broken... No folder from the pool disk shows up under user shares.


Upon restart, Unraid recreated an appdata folder on a different drive and that's why I thought it solved it.


It seems there are a few issues now:


* Folders on my pool disk do not show up under user share


* After re-adding a docker, all settings have been lost


Any thoughts. I am attaching yet another diagnostics log, just in case.

Link to comment

It's difficult to make much sense of the shares folder in your diagnostics, because you have a lot of .cfg files that probably don't correspond to any user share. Perhaps you accidentally created some of those shares at some time.


Plus, since it appears that user shares are broken, many if not all of them say they don't exist. I haven't checked them all since there are 149 of them.


Take a look at the config/shares folder on your flash drive and you will see what I mean.


Another thing I noticed is that you seem to be sharing disks on the network. I don't recommend that and it is usually not necessary, though it might be useful for some things if you don't know how to work with files directly on the server instead of over the network. Just be sure you know not to work with disk and user shares at the same time.


Link to comment



I only have around 20 user shares (maybe even less). No idea why it shows 100+.

I know the risk of showing both disk and user shares, so don’t copy among them. I like both as i do some manual clean-up copying things from one disk to another disk. I do this within a windows vm. The user share is needed for my radarr and plex dockers as library folders.


User shares seem to work on all array disks, but not from the “pool device”. I’m still confused that i have a cache device with no disk allocated to it. And you can see from the screenshots above that cache is still somehow used by unraid.


Any idea how to fix my unraid again? It’s now really broken as my dockers don’t work.

Link to comment

Why did you remove cache? I thought the idea was to add another pool for docker/VM. If you only want one pool it might as well be "cache".


On 10/6/2021 at 10:08 AM, trurl said:

I have a "cache" pool for caching user share writes, and a "fast" pool for fast access of files for docker and other things. I have my appdata, domains, and system shares on the fast pool, and set to stay on the fast pool. That way dockers/VMs perform better and don't keep array disks spinning, since these files are always open.



Link to comment

What's the difference between "cache" and "pool"? Why do both exist?

You suggesting that I now eliminate the pool device and add the same disk as pool?


I removed it because I thought UD is a better / cleaner solution. Also didn't like it being called "cache", which implied something that I was not using it for.

Link to comment
1 hour ago, steve1977 said:

I removed the pool device and added the disk as cache disk. Still facing issues. Maybe some bug? See below screenshot referring to the pool device although it was removed:



Did you remember to change the 'appdata' share settings to no longer refer to 'Pool'? 


Note that t is quite valid with the 'Prefer' setting to refer to a non-existent pool that you might later add to the system. 

Link to comment
24 minutes ago, steve1977 said:

Yes, it points to cache, but shows pool in the overview. If you check one of my earlier posts with screenshots, there was the same inconsistency. Setting is XXX, but overview says YYY. Maybe a bug?


Well the last Diagnostics you posted had it set to pool?


maybe you should delete all the superfluous .cfg files on the flash drive in the config/shares folder that refer to Shares you do not/no longer have and then post new Diagnostics so we can check this out.

Link to comment

Maybe one interesting observation that can help point to the issue. When I select a usershare (e.g., Movies) and go to the settings. I can select a drop-down menu called "included disks". This allows me to select/unselect all disks that are part of the array. It does not allow me to select the cache disk. Are you sure that folders on the cache disk can be included in a user share?

Link to comment
On 10/16/2021 at 6:39 AM, steve1977 said:

See below from global sharing setting. Cache / pool disk doesn't show up in the list. Are you sure that cache/pool disks can be part of user shares?




All pool devices are automatically part of User Shares if the top level folder relating to that share exists on a pool so no idea why they should not show up for you.  You can only limit array devices as to whether they can be part of the User Share sub-system. 


It might be worth toggling the setting for User Shares off, apply it and then change it back to Yes.  It should make no difference but can do no harm to try.

Link to comment

What you mean by "if the top level folder relating to that share exists on a pool"? I only tried with one pool device (called test). The folder called "appdata" only exists on this pool device.


Let me try to toggle on and off. It is really odd that it doesn't work.


Shall I delete all cfg files from the flash disk. Will it remap existing user shares from the array upon restart?


Thanks again. Would really love to get this working. It's a huge benefit to have pool devices being user shares.

Link to comment
1 hour ago, steve1977 said:

Shall I delete all cfg files from the flash disk. Will it remap existing user shares from the array upon restart

You could do that, although not sure it would help.    Unraid would then automatically create a User Share for each top level folder on any drive, and this share would have default Settings (so you would need to check they were what you want).

Link to comment
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.