Faulty drives in array


harisarslanovic

Recommended Posts

Hey guys,

 

I am new to unraid and just started my first server in the past few years but i have had some help setting it up.

I recently re built my server with some hardware upgrades and such. I encountered the first hard drive having a problem a year ago but i just disabled it from the array. A few weeks ago another drive started to show sector 7 problem and errors on it. So i went bought 2x 4tb drives to replace both faulty ones. I installed 1x drive first pre cleared and put into the array and let it do a data rebuild. Then once that was done i wanted to remove the sector 7 drive , so i stopped the array, unassigned the drive shut down and boot up again with the new drive in place but it wouldnt let me start the array keeps saying missing disks, so i did the same thing again but this time plugged in the drive with sector 7 errors. It started to do its data re built but this time its going at like 500kbs-2mbs speed so it will take 20-40 days to complete. 

Also it takes 5 mins or longer to do a restart and  stop/starting the array takes some time as well.

 

I am aware that i shouldnt of ignored the first drive failing for that long and that i should of replaced it sooner. But this is where i am at and i am not sure what to do at this point, i am considering do a clean format on all drives but how would i do that?

 

Link to comment
7 hours ago, harisarslanovic said:

shouldnt of ignored the first drive

Probably other things you "shouldn't of". Do you still have the original drive? Maybe nothing wrong with any drives, but we can't tell without diagnostics.

 

7 hours ago, harisarslanovic said:

considering do a clean format on all drives

Why would you even consider that? What do you think it would accomplish?

Link to comment

Nothing obvious in diagnostics except

05:00.0 SATA controller [0106]: Marvell Technology Group Ltd. 88SE9172 SATA 6Gb/s Controller [1b4b:9172] (rev 11)
06:00.0 SATA controller [0106]: Marvell Technology Group Ltd. 88SE9172 SATA 6Gb/s Controller [1b4b:9172] (rev 11)
07:00.0 SATA controller [0106]: Marvell Technology Group Ltd. 88SE9172 SATA 6Gb/s Controller [1b4b:9172] (rev 11)

Marvell controllers are NOT recommended.

 

Are there Errors in the Errors column for any array disk on the Main page? Do any of your disks have SMART warnings on the Dashboard page?

Link to comment
12 hours ago, harisarslanovic said:

at this point because the parity wants to be rebuilt and the slow speeds , i dont really care i have fibre 1.5gb its not like it will take long to re download, 

How would i do full format on all drives and resetup everything as new. I will add a bigger 2nd parity drive if i go down this road that way i am setup for future upgrades.

Starting over won't fix the problems causing your slow speeds.

Link to comment

Those speed graphs show the problem, maybe a SAS2LP issue with v6.9? Strange that I don't remember seeing anyone else complaining, and despite those controllers not being recommended I suspect there are still a few in use, could also be other hardware issue with the newer kernel, not controller related.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.