SOLVED: Cannot Delete or Modify Files in a Share created by Docker Container ex: resilio-sync, deemix, etc.

Recommended Posts

When I go to delete or modify a files that are in a share and those files were created by docker container I cant delete or modify them with my user that has read/write access to that share.


The error I get is:
"You need permission to perform this action


You require permission from UNRAIDSERVERNAME \ nobody to make changes to this file"

From my under standing this is because by default the docker containers save using the root user. Since I am using "user1" via SMB on Windows 10 I dont have permission for these files. From reading I may be able to use "Docker Safe New Perms" to resolve this issue for files currently. However I want to make it so that all future files saved by the docker can be accessed by "user1" or any other user that has privileged via SMB on Windows 10 machines. From my searches I have yet to find a way to do that. I think this is controlled by the docker containers PUID and PGID settings but this is where im looking for some additional help.

Yes I have already deleted my windows credentials and manually created them. My unraid user is different from my windows user so there is no conflict there. I also have no folders public or secure so the windows machines cant browse the network device with lower permissions.

To clarify the issues are only with files created by docker containers. I can read the files. I can not modify or delete these files.



Thanks in advance for the help. I'm still new to unraid, linux, docker, etc.

Edited by TheProfosist
issed has been solved-resolved
Link to comment
25 minutes ago, JorgeB said:

Do it using the console instead.


These are docker containers that I will be using for the foreseeable it would be quite annoying to have to use the console everytime I wanted to delete or modify a file that was created by them.


for reference resilio sync is a sync program can sync literally anything. Maybe its syncing a project im working on with other people where i would need to be able to manipulate the files. Deemix is a music downloader. Would be nice to me able to move the files when they are done as they are already on the correct share, not copy open up console, manually delete the files.


What your suggesting is would be equivalent to opening terminal on your android phone everytime you want to delete and extra picture that you took and dont need anymore.

Link to comment
14 hours ago, itimpi said:

You will have to find out what needs doing in the Resilio docker to get the permissions set correctly in the first place.  Do not use it myself so no idea what is required.


The reason why I put this in general was because it seems to apply to all docker containers. General web search shows results for deemix and may others. Should I have put this under docker support instead?


So lets go back a bit. You mention setting permissions correctly for Resilio Sync which also should apply to deemix. How do I set permissions for a docker container. Also what would I want to set them to and why. From my research this relates to the PUID and PGID. I do not know for sure these are the correct values that need to be modified.

Edited by TheProfosist
Link to comment
1 hour ago, TheProfosist said:

How do I set permissions for a docker container.

Depends on which container, each one must be handled individually, as they are programmed as individual pieces.

1 hour ago, TheProfosist said:

it seems to apply to all docker containers.

But not universally. Think of a container as a stripped down VM that shares resources more effectively. It's still uniquely programmed.


That's why you need to look and ask in the support threads for each container that is having an issue, as the solution is specific to that implementation.


You can have multiple implementations of an app, take for instance plex, there are several different containers, some arch based, some ubuntu based, possibly others, each has the plex app but the container's base OS is different, also how it interacts with the host can be different.

Link to comment

resolved I needed to set umask for the docker. by default it is set to 0022 but unraid which is just root for delete/modify. 0002 worked for me some say to just use 0000 but I read that is more insecure

an example of the dialog is in a previous resilio sync post


A post explaining umask options


also got some help from this basic docker guide




Looks like in the past people would set PUID and PGID to 1000 so that may be another way to go about it.

Link to comment
  • TheProfosist changed the title to SOLVED: Cannot Delete or Modify Files in a Share created by Docker Container ex: resilio-sync, deemix, etc.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.