Upgraded to v6.9.2 and Parity Check is Super Slow


Recommended Posts

Yesterday, I upgraded from 6.8.3 to 6.9.2.  At some point last night, my server went offline (crashed?).  I restarted it manually and upon restart the parity check began.  The parity check started off smoothly (~130MB/s), but soon slowed to a crawl (5.7MB/s - and dropping).  I have stopped all of my dockers and VMs. 

 

I've attached the diagnostics

 

Note - I have a 30TB array (10 x 3TB + 2 x 3TB for parity).  It usually takes me about 8 hours to complete a parity check.

renfrewnas-diagnostics-20211014-1026.zip

Link to comment

Are there any errors in the Errors column on Main for any array disks? Do any of your disks have SMART warnings on the Dashboard page?

 

Oct 14 10:17:02 RENFREWNAS kernel: BUG: unable to handle page fault for address: 0000000000200014
Oct 14 10:17:02 RENFREWNAS kernel: #PF: supervisor read access in kernel mode
Oct 14 10:17:02 RENFREWNAS kernel: #PF: error_code(0x0000) - not-present page
Oct 14 10:17:02 RENFREWNAS kernel: PGD 0 P4D 0 
Oct 14 10:17:02 RENFREWNAS kernel: Oops: 0000 [#1] SMP PTI

Have you done memtest?

 

Setup syslog server so you can get syslog if it crashes again.

Link to comment
Oct 14 10:17:02 RENFREWNAS kernel: Modules linked in: macvlan xt_CHECKSUM ipt_REJECT nf_reject_ipv4 ip6table_mangle ip6table_nat iptable_mangle nf_tables vhost_net tun vhost vhost_iotlb tap xt_nat xt_tcpudp veth xt_conntrack xt_MASQUERADE nf_conntrack_netlink nfnetlink xt_addrtype iptable_nat nf_nat nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 br_netfilter xfs md_mod i915 iosf_mbi i2c_algo_bit drm_kms_helper drm intel_gtt agpgart syscopyarea sysfillrect sysimgblt fb_sys_fops ip6table_filter ip6_tables iptable_filter ip_tables x_tables bonding x86_pkg_temp_thermal intel_powerclamp coretemp kvm_intel kvm crct10dif_pclmul crc32_pclmul crc32c_intel ghash_clmulni_intel aesni_intel crypto_simd cryptd glue_helper rapl r8169 ath3k i2c_i801 intel_cstate btusb dell_smm_hwmon ahci i2c_smbus btrtl intel_uncore btbcm i2c_core btintel libahci bluetooth realtek mpt3sas ecdh_generic ecc video fan raid_class backlight scsi_transport_sas thermal button

 

Link to comment
4 minutes ago, trurl said:

Are there any errors in the Errors column on Main for any array disks? Do any of your disks have SMART warnings on the Dashboard page?

 

Oct 14 10:17:02 RENFREWNAS kernel: BUG: unable to handle page fault for address: 0000000000200014
Oct 14 10:17:02 RENFREWNAS kernel: #PF: supervisor read access in kernel mode
Oct 14 10:17:02 RENFREWNAS kernel: #PF: error_code(0x0000) - not-present page
Oct 14 10:17:02 RENFREWNAS kernel: PGD 0 P4D 0 
Oct 14 10:17:02 RENFREWNAS kernel: Oops: 0000 [#1] SMP PTI

Have you done memtest?

 

Setup syslog server so you can get syslog if it crashes again.

There are no errors on the Main page for any of my disks.  No SMART warnings in the dashboard either.  I have not run a memtest.

 

I just setup the syslog server (to flash) and will monitor if a crash occurs again.

Link to comment
2 minutes ago, JorgeB said:

The Unraid driver is crashing, this happens with some hardware, don't no the reason or a solution, you can try v6.10-rc, it might not happen with the newer kernel.

This was what I was afraid of...

 

Can I roll back to 6.8.3?  Edit - I'm restoring back to 6.8.3 now...

Edited by perfect
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.