Unable to Replace Key using Myservers plugin

Recommended Posts

After two moves, I was finally able to boot my server again. Turns out my flash drive died/corrupted. Was able to successfully pull my flash backup down from the tool and get the server booted up (all though all my plugins were in an error state, manually reinstalled community apps from the file on the err folder then pulled the latest myservers plugin). Once I had the plugin I tried to replace my key, it initially errored out due to multiple keys on my flash drive, which I would have expected. I then removed the extra keys and attempted to replace my Plus License key as it no longer matched. After hitting replace key, the myservers popup briefly flashed the logon window as if I wasn't logged in, then returned to purchase/replace key. Tried in both chrome and edge. Unraid 6.9.0 and myserver 2021.10.12.1921. I moved my key from /config so I now had no valid key on the server. Now hitting replace key takes me to an actual log on attempt, which then took me to a page that says key couldn't be replaced and to contact support. I've sent an email to support to get a replacement, but it seems like the logic for replacing a key with an invalid key is causing some sort of loop. I would have expected to get the same sort of error/contact support message when replacing a mismatched key instead of the window looping repeatedly on purchase/replace key.


Has anyone seen this or is it just a bug? Does the plugin have any logs I can provide to help see why it was looping?




Link to comment

Apologies for the bug in the pop-up. Thank you for the thoroughness. I was able to replicate the bug and just deployed a fix.


Please try the Replace Key option from the user profile again.


edit: another user that contacted us through email support regarding the same bug was able to successfully replace 👍

Link to comment