Corsair Commander Pro


mikeyosm

Recommended Posts

Hi

 

Running 6.9.2 and connected my Corsair Commander Pro to a USB port to see if I can get fan control working under UNRAID/Linux.

According to the following articles

https://blog.ktz.me/a-usb-fan-controller-that-now-works-under-linux/

https://www.phoronix.com/scan.php?page=news_item&px=Corsair-Commander-Pro-Linux-5.9

 

the CPro should be detected under Linux kernel 5.9+ but unfortunately it's not being detected in UNRAID.

Running sensors-detect does not list the commander pro at all so not sure if the driver is loaded or indeed even added to the kernel.

The Commander Pro is available for passthrough to a VM and shows up in my USB list so it's defo working OK.

 

Is there any way I can check if the driver named (corsair-cpro) is available in 6.9.2 UNRAID kernel and if not is it available in 6.10 RC1? 

 

Thank you for your help.

 

EDIT: lspro shows the driver exists but is not in use.

 

corsair_cpro           16384  0

Edited by mikeyosm
Link to comment
  • 3 weeks later...
18 hours ago, KnottySean said:

Did you get this figured out? I too would like to get this working fully. 

 

I have been running a windows 10 vm to handle the fans/AIO, it would be great to not have to.

 

18 hours ago, KnottySean said:

Did you get this figured out? I too would like to get this working fully. 

 

I have been running a windows 10 vm to handle the fans/AIO, it would be great to not have to.

 

So it turns out that the fans are visible to UNRAID/Linux and appear in the UNRAID dashboard. I haven't installed the dynamix fan control plugin as I dont need to control the speed of the fans. The trick is to not tick the fans in the dynamix sys temp settings, that's when things get messy.

Link to comment

+1 i am in the same situation.

my gigabyte X570 AORUS master is lacking support for the fan and temp sensors in unraid and I am looking for a solution to control them in the unraid ui. 

 

Can you try and see if you can control them with the plugin and report back? 

 

 

Link to comment

So, in the Dynamix Fan Auto Control plugin lists the fans attached to the CCP.  When I select one, and hit Detect on the PWM Fan entry, it returns the following:

 

<br /><b>Warning</b>:  file_get_contents(/sys/devices/pci0000:00/0000:00:01.2/0000:02:00.0/0000:03:08.0/0000:06:00.3/usb3/3-2/3-2:1.0/0003:1B1C:0C10.0001/hwmon/hwmon2/pwm2_enable): failed to open stream: No such file or directory in <b>/usr/local/emhttp/plugins/dynamix.system.autofan/include/SystemFan.php</b> on line <b>40</b><br /><br /><b>Warning</b>:  file_put_contents(/sys/devices/pci0000:00/0000:00:01.2/0000:02:00.0/0000:03:08.0/0000:06:00.3/usb3/3-2/3-2:1.0/0003:1B1C:0C10.0001/hwmon/hwmon2/pwm2_enable): failed to open stream: Permission denied in <b>/usr/local/emhttp/plugins/dynamix.system.autofan/include/SystemFan.php</b> on line <b>42</b><br /><br /><b>Warning</b>:  file_put_contents(/sys/devices/pci0000:00/0000:00:01.2/0000:02:00.0/0000:03:08.0/0000:06:00.3/usb3/3-2/3-2:1.0/0003:1B1C:0C10.0001/hwmon/hwmon2/pwm2_enable): failed to open stream: Permission denied in <b>/usr/local/emhttp/plugins/dynamix.system.autofan/include/SystemFan.php</b> on line <b>50</b><br />/sys/devices/platform/nct6775.656/hwmon/hwmon4/fan6_input

 

 

unraid_dynamix_fan_speed_CCP2.png

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.