6.10RC1-2 Kills my Nvidia Primary GPU Passthrough

Recommended Posts

On 3/13/2022 at 7:56 AM, CodingMicrobe said:

@bigbangus wondering if you've had any progress on this issue? I upgrades from 6.9.2 to 6.10-rc3 yesterday and while everything else works fine, suddenly my GTX 760 GPU which is being used for my Windows 10 VM is throwing error 43, and VM is stuck at 800x600 resolution. I tried reinstalling Nvidia drivers (v470), which now officially support virtualization, without any success. Also made a brand new Windows 10 VM, same issue.


So my solution here was to upgrade to the new driver from Nvidia that allows virtualization:


Link to comment
  • 4 months later...

Did you mean these addational strings in the XML-File of the VM like this?


<vendor_id state='on' value='0123456789AB'/>
      <hidden state='on'/>
    <ioapic driver='kvm'/>


I tried these from begin on, but it's not effecting in any way. Windows let me install the Nvidia-Drivers which are resulting in a seemingly working device (according to the device manager), unfortunately without appearance of the GPU in the task manager or any output/signal on a physical display. After a restart of the VM the code/error 43 appears again. In a Ubuntu-VM, the output/signal on a physical display (and sound) works in the first place.


All what I tried / did:

  • enabled HVM and IOMMU in the BIOS
  • the changes in the XML-File above
  • booted Unraid 6.10.3 in legacy mode
  • tried diffrent machine- and BIOS-types of the VM
  • appended "vfio-pci.ids=10de:1187,10de:0e0a" or bind the two Nvidia-devices to VFIO at boot
  • in VM manager: changed "PCIe ACS override" to "Both" and "VFIO allow unsafe interrupts" to "Yes"
  • changed the "multifunction='on'"-Stuff in the XML-File from Spaceinvader One
  • dumped and modified my own vBIOS-ROM with GPU-Z and removed the header OR used the script from Spaceinvader One and linked it in the XML-File

I have a AMD Ryzen 5 3600 in a ASRock B550M Pro4 and the MSI GTX 760 TF as single GPU in the first PCIe-Slot (other slots are not possible to use).




Should I start a new thread or can we discuss it here? I look forward to helpful replies. Thanks for reading and in advance!


Best regards

Link to comment
  • 4 weeks later...


On 2/25/2022 at 1:00 AM, RiDDiX said:
      <relaxed state='on'/>
      <vapic state='on'/>
      <spinlocks state='on' retries='8191'/>
      <vendor_id state='on' value='1234567890ab'/>*
      <hidden state='on'/>*
    <vmport state='off'/>*
    <ioapic driver='kvm'/>*


Edited by RiDDiX
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.