Halo Infinite can't start


lusitopp

Recommended Posts

Hi, 

 

I'm running 6.9.2 with a Win11 VM, today I installed Halo Infinite Multiplayer, both via Steam and Xbox app. In both applications the game instantly crashes.
So since my Win11 is not compatible I installed a new Win10, installed Steam and then Halo, but same here, game crashes a few second after i click "start".

 

Have anyone successfully played this game in a VM?

Edited by lusitopp
  • Like 1
Link to comment

FIXED - worked for 2 different Servers. intel i7-6950X and amd 5950x

 

Edit the VM XML (XML VIEW)

 

STEP 1.

 

add

    <kvm>
      <hidden state='on'/>
    </kvm>

before </features>

 

Step 2.

 

add 

 <feature policy='disable' name='hypervisor'/>

before </cpu>

 

*do not delete or replace, only add*

 

Example

<features>
    <acpi/>
    <apic/>
    <hyperv>
      <relaxed state='on'/>
      <vapic state='on'/>
      <spinlocks state='on' retries='8191'/>
      <vendor_id state='on' value='none'/>
    </hyperv>
    <kvm>
      <hidden state='on'/>
    </kvm>
  </features>
  <cpu mode='host-passthrough' check='none' migratable='on'>
    <topology sockets='1' dies='1' cores='8' threads='2'/>
    <cache mode='passthrough'/>
    <feature policy='disable' name='hypervisor'/>
  </cpu>

 

  • Thanks 2
Link to comment
1 hour ago, LSDTripp said:

FIXED - worked for 2 different Servers. intel i7-6950X and amd 5950x

 

Edit the VM XML (XML VIEW)

 

STEP 1.

 

add

    <kvm>
      <hidden state='on'/>
    </kvm>

before </features>

 

Step 2.

 

add 

 <feature policy='disable' name='hypervisor'/>

before </cpu>

 

*do not delete or replace, only add*

 

Example

<features>
    <acpi/>
    <apic/>
    <hyperv>
      <relaxed state='on'/>
      <vapic state='on'/>
      <spinlocks state='on' retries='8191'/>
      <vendor_id state='on' value='none'/>
    </hyperv>
    <kvm>
      <hidden state='on'/>
    </kvm>
  </features>
  <cpu mode='host-passthrough' check='none' migratable='on'>
    <topology sockets='1' dies='1' cores='8' threads='2'/>
    <cache mode='passthrough'/>
    <feature policy='disable' name='hypervisor'/>
  </cpu>

 

I feel like I must be doing something wrong. I tried this on both my Windows 10 and Windows 11 VM and they both give me a BSOD when I log into windows. "Stop code: CLOCK_WATCHDOG_TIMEOUT"

 

Server is running a Intel i7-11700K and RTX 3090

My XML is identical to your example so I'm not sure what I'm missing. Is there something obvious I'm missing?
 

  <features>
    <acpi/>
    <apic/>
    <hyperv>
      <relaxed state='on'/>
      <vapic state='on'/>
      <spinlocks state='on' retries='8191'/>
      <vendor_id state='on' value='none'/>
    </hyperv>
    <kvm>
      <hidden state='on'/>
    </kvm>
  </features>
  <cpu mode='host-passthrough' check='none' migratable='on'>
    <topology sockets='1' dies='1' cores='8' threads='2'/>
    <cache mode='passthrough'/>
    <feature policy='disable' name='hypervisor'/>
  </cpu>

 

Edited by Kuchar09
Link to comment

I finally got it to work! Not sure why but I had to add a VNC as my first graphics card and my RTX 3090 as my second graphics card to the VM template. Not exactly sure how that stopped both my Windows 10 and 11 VM from crashing on login but it did.

Maybe it's because I'm on UnRAID 6.10.0-rc2?

Link to comment

I have fixed this even more and getting way better fps.

Add the following  just above </features>

    <kvm>
      <hidden state='on'/>
    </kvm>
    <ioapic driver='kvm'/>

do not disable hypervisor

Once booted into windows open Powershell as admin
Enter the following

Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V -All


It ask you to reboot

 

Once done launch and enjoy HALO

  • Like 1
Link to comment
15 hours ago, runamuk said:

I have fixed this even more and getting way better fps.

Add the following  just above </features>

    <kvm>
      <hidden state='on'/>
    </kvm>
    <ioapic driver='kvm'/>

do not disable hypervisor

Once booted into windows open Powershell as admin
Enter the following

Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V -All


It ask you to reboot

 

Once done launch and enjoy HALO

 

Just some feedback- This gave me 50-60 fps on average at 1440p with almost everything set to ultra in Windows 11. Unfortunately, enabling Hyper-V within windows broke display output to my second monitor. so it's not a feasible solution for me... but it did get the game going at least!

 

Keeping the XML adjustments but DISABLING Hyper-V within windows does not allow the game to launch.

 

My passed through VM hardware- 3950x (8 isolated cores), 6800xt, 32gb RAM, SSD (bare metal).

Edited by Kudagra
Link to comment
8 hours ago, Kudagra said:

 

Just some feedback- This gave me 50-60 fps on average at 1440p with almost everything set to ultra in Windows 11. Unfortunately, enabling Hyper-V within windows broke display output to my second monitor. so it's not a feasible solution for me... but it did get the game going at least!

 

Keeping the XML adjustments but DISABLING Hyper-V within windows does not allow the game to launch.

 

My passed through VM hardware- 3950x (8 isolated cores), 6800xt, 32gb RAM, SSD (bare metal).

I'm sorry to say butt I'm pretty sure that AMD GPU's will not work with the ioapic driver='kvm' ; thus creating the lag. I'm getting around 140 fps with my 2060 super (all on ultra) with an ultra wide monitor.

Windows 11 VM
10 dedicated cores from a 5950

16 gig ram

2060 Super

I know there is another workaround with AMD gpu but it is not easy.

 

Edited by runamuk
Link to comment
  • 3 weeks later...
On 11/23/2021 at 4:54 PM, runamuk said:

I'm sorry to say butt I'm pretty sure that AMD GPU's will not work with the ioapic driver='kvm' ; thus creating the lag. I'm getting around 140 fps with my 2060 super (all on ultra) with an ultra wide monitor.

Windows 11 VM
10 dedicated cores from a 5950

16 gig ram

2060 Super

I know there is another workaround with AMD gpu but it is not easy.

 

I tried these steps and my VM came to a standstill after logging in with Hyper-V enabled. I hade to stop the VM, safe boot, and disable. Any ideas?

Link to comment
  • 2 weeks later...
On 12/10/2021 at 11:13 PM, berta123 said:

I tried these steps and my VM came to a standstill after logging in with Hyper-V enabled. I hade to stop the VM, safe boot, and disable. Any ideas?

What kind of system are you running.

I do have a few lines  that can possible help the hyper-V run a little more smooth; try putting the following in under HyperV- Also I highly recommend you are running  the latest q35.

    <hyperv>
      <relaxed state='on'/>
      <vapic state='on'/>
      <spinlocks state='on' retries='8191'/>
      <vpindex state='on'/>
      <runtime state='on'/>
      <synic state='on'/>
      <stimer state='on'/>
      <reset state='on'/>
      <vendor_id state='on' value='putwhatyouwant'/>
    </hyperv>

.

Edited by runamuk
Link to comment
On 11/17/2021 at 8:50 PM, LSDTripp said:

FIXED - worked for 2 different Servers. intel i7-6950X and amd 5950x

 

Edit the VM XML (XML VIEW)

 

STEP 1.

 

add

    <kvm>
      <hidden state='on'/>
    </kvm>

before </features>

 

Step 2.

 

add 

 <feature policy='disable' name='hypervisor'/>

before </cpu>

 

*do not delete or replace, only add*

 

Example

<features>
    <acpi/>
    <apic/>
    <hyperv>
      <relaxed state='on'/>
      <vapic state='on'/>
      <spinlocks state='on' retries='8191'/>
      <vendor_id state='on' value='none'/>
    </hyperv>
    <kvm>
      <hidden state='on'/>
    </kvm>
  </features>
  <cpu mode='host-passthrough' check='none' migratable='on'>
    <topology sockets='1' dies='1' cores='8' threads='2'/>
    <cache mode='passthrough'/>
    <feature policy='disable' name='hypervisor'/>
  </cpu>

 

Thanks

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.