[SOLVED] Unraid emhttpd: error: get_key_info, 579: Invalid argument. help(已解决)


Recommended Posts

51 minutes ago, Luka said:

Hi,

I have Unraid basic subscription and I started to get this error (the log is full of them):

 

What does this error mean?

Please help

 

 

Corrupted/missing keyfile. I have re-sent the keyfile to your email. Please try reinstalling

Link to comment

I re-sent the keyfile. If you copy paste this into Tools-> Registration -> Install Key, does the issue persist?

 

安装密钥

要安装注册密钥,请将密钥文件 URL 粘贴在下面的框中,然后单击安装密钥.

密钥文件 URL:

Link to comment

First, ensure you have a recent backup of your USB (Main->Flash-> Flash Backup)

 

Another option to try is:

-Have your keyfile (.key file) handy on a different computer.

 

-Shutdown server, remove flash and install USB into the other computer.

-Open the USB folder and drag and drop the .key file into the /config folder.

-Then, safely eject/remove the flash and reinstall in your server and reboot.

 

If the issue still persists, your flash drive may be corrupted and you may need to transfer your license to a new USB. We can assist with this by contacting us at unraid.net/contact 

 

If you start a new Unraid trial on a new flash device, please send in your new USB GUID and we can transfer the license for you.

 

 

 

image.png

Link to comment

Hi,

I finally managed to do as You told me...

1.  Unraid server shutdown.

2. Unplug the USB flash drive from the Unraid server

3. Plug the USB flash drive onto my laptop

4. Downloaded the Basic.key from the mail link You've sent me yesterday

5. Copied the Basic.key into USB flash drive / config folder and overwrite the existing one

6. Safe eject/remove on windows

7. Unplug usb flash drive from laptop

8. Plug the usb flash drive into the server

9. Start the Unraid server

 

The errors still persist.

My NEW diagnostics in the attachment.

unraid-diagnostics-20211119-1852.zip

Link to comment
21 minutes ago, Luka said:

Hi,

I finally managed to do as You told me...

1.  Unraid server shutdown.

2. Unplug the USB flash drive from the Unraid server

3. Plug the USB flash drive onto my laptop

4. Downloaded the Basic.key from the mail link You've sent me yesterday

5. Copied the Basic.key into USB flash drive / config folder and overwrite the existing one

6. Safe eject/remove on windows

7. Unplug usb flash drive from laptop

8. Plug the usb flash drive into the server

9. Start the Unraid server

 

The errors still persist.

My NEW diagnostics in the attachment.

unraid-diagnostics-20211119-1852.zip 95.71 kB · 4 downloads


As @JorgeB mentioned, your key file is not valid. Where did you get it from? Did you purchase via a third party?

Link to comment

Ok, after I have deleted the BTRS.key, no more errors.

I don't know from where did I get this file.

I followed  an online guide one and a half year ago when I bought the basic license. On that guide there was a link to download unraid image to be written on the usb. I don't know what the guide was, I tried to look in my browsing history but with no success.

 

Anyway there are no more that errors.

 

Thanks

 

  • Like 1
Link to comment
  • JorgeB changed the title to [SOLVED] Unraid emhttpd: error: get_key_info, 579: Invalid argument. help
  • lyqalex changed the title to [SOLVED] Unraid emhttpd: error: get_key_info, 579: Invalid argument. help(已解决)

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.