[SOLVED] 1 CPU core stuck at 100% - How can I find out which service is triggering this?

Recommended Posts

14 minutes ago, tjb_altf4 said:

Might be some suggestions in the attached that help, for me it manifests as shfs @ 100% when array is running, but usb kworkers are the culprit when stopped.

Possibly moving usb connections around to different (ports) controllers helped.




That points me to the Inateck USB controller I added recently. 

Link to comment
  • doesntaffect changed the title to [SOLVED] 1 CPU core stuck at 100% - How can I find out which service is triggering this?

I swapped all PCIe cards in out and tried different slots. At the end I can reproduce the issue, 1 - 2 CPU cores get stuck at 100%, if I plug a PCIe card (tested with Fenvi T919, Inateck RedComets U26, Radeon RX560) into PCIe slot 6 (second from top) on the Asrock Rack RomeD8-2T board. Consequently, leaving that slot empty I can add following cards without issues:

  1. RX560
  2. GT710
  3. Asus Hyper.2 with 4x NVMEs
  4. Inateck RedComents U26
  5. Fenvi T919 

without issues and CPU cores going wild.

Passthrough of GT710, Inateck and T919 to Hackintosh VM works fine now with all CPU idling (unless I stress them). 


Power consumption of UnRaid host with all add-on cards, idling, dropped from 103/109w to 93/103w according to UnRaid Dashboard. CPU Epyc 8-core 7232P. 

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.