disk failling and going to emulated mode?


Recommended Posts

hi all,

 

I have 2 disks in my array that failed and went to emulated mode in the last 4 days, both disks are not even a year old yet. 

 

First one is a 4 tb wd red plus, hosting all my TV shows, went down, rebuild the array, all good.

 

Second one, 2 days later, is another wd red plus, 4tb, went down, rebuild it, all good for not even a day and went down again.

 

I know both disk are good as I tested them et the result showed no errors.

 

Any idea what's going on?

 

could it be because they're to full, almost at capacity now?

 

or because I am currently re-transcoding all my libraries? too much read and writed back to back ?

 

I am restoring the one that failed twice now.

 

any help would be appreciated as it is getting annoying to restore, taking a lot of time and it is close to impossible to use plex while doing it. Movies keep buffering......

 

thanx

jarvis-diagnostics-20211123-0725.zip

Link to comment

thanks I'll give this a try.

 

newbie questions here, how foI know which firmware to use?

 

how do I put the firmware on the flash drive, do I need to power down the server and put it on from à pc ?

 

any chance this is going to brick my HBA ?

 

just a little nervous about this has I never played around with this staff.

 

thank you

 

 

 

Link to comment
11 hours ago, Coco said:

how do I put the firmware on the flash drive,

You can share the flash drive over SMB.

 

11 hours ago, Coco said:

any chance this is going to brick my HBA ?

It's a fairly safe procedure, maybe a power failure during could cause issues.

Link to comment

ok, i have tried to flash it but here is the error i get:

 

LSI Corporation SAS2 Flash Utility
Version 20.00.00.00 (2014.09.18) 
Copyright (c) 2008-2014 LSI Corporation. All rights reserved 

        Advanced Mode Set

        Adapter Selected is a LSI SAS: SAS2008(B2)   

        Executing Operation: Flash Firmware Image

                Firmware Image has a Valid Checksum. 
                Firmware Version 20.00.07.00
                Firmware Image compatible with Controller. 

                Valid NVDATA Image found. 
                NVDATA Version 14.01.00.00 
                Checking for a compatible NVData image... 

                NVDATA Device ID and Chip Revision match verified.
                NVDATA Versions Compatible.
                Valid Initialization Image verified.
                Valid BootLoader Image verified.

                ERROR: Cannot Flash IT Firmware over IR Firmware!

                Firmware Image Validation Failed! 

        Due to error remaining commands will not be executed.
        Unable to Process Commands.
        Exiting SAS2Flash.

 

any idea ?

 

also here is the list all result

 

LSI Corporation SAS2 Flash Utility
Version 20.00.00.00 (2014.09.18) 
Copyright (c) 2008-2014 LSI Corporation. All rights reserved 

        Adapter Selected is a LSI SAS: SAS2008(B2)   

Num   Ctlr            FW Ver        NVDATA        x86-BIOS         PCI Addr
----------------------------------------------------------------------------

0  SAS2008(B2)     20.00.06.00    14.01.00.09    07.39.02.00     00:04:00:00

        Finished Processing Commands Successfully.
        Exiting SAS2Flash.

 

thanks

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.