downgraded from 6.9.2 to 6.8.3, no dockers, error saying could not start, missing shares (SOLVED)


Recommended Posts

Was on 6.8.3 with no issues.


Upgraded to 6.9.2, everything was working great except my drives would not spin down, so they remained up all the time.  Because that will take life off the drives, I decided to use the GUI to rollback to 6.8.3.


I now have the follow issues:


-Missing shares, some are there and some are missing.  Those missing are not accessible, "Share not published".  However, the conf files for shares on my flash drive look ok, nothing missing.


-Docker says it cannot start, most likely corrupt.  I did see an error for one of them saying my Automation path was invalid.  That's one of the shares missing.


I posted in a couple of threads and was told to start a new thread, so here we are.  I want advice before taking any further action.  I'm now worried that going back to 6.8.3 is the problem.  I have downloaded 6.9.1, but I'm not certain the process to manually upgrade.


Update : Marked as Solved.  The solution is to read the release notes, especially when upgrading or downgrading major releases, 6.8x to 6.9x


6.9.2 before downgrading after downgrading to 6.8.3

Edited by optiman
Link to comment
26 minutes ago, optiman said:

I have downloaded 6.9.1, but I'm not certain the process to manually upgrade

Generally, the process for manually upgrading/downgrading unRAID is to extract all the files for a particular version and then copy all of the bz* files to the flash drive.


This is not helpful as far as troubleshooting your issues but if you decide to change versions manually, this is how it is done.

Link to comment

FYI - its this page:

And this comment specifically from that link at the top (Bold and Red highlight I added):
Note: A pre-6.9.0 cache disk/pool is now simply a pool named "cache".  When you upgrade a server which has a cache disk/pool defined, a backup of config/disk.cfg will be saved to config/disk.cfg.bak, and then cache device assignment settings are moved out of config/disk.cfg and into a new file, config/pools/cache.cfg.  If later you revert back to a pre-6.9.0 Unraid OS release you will lose your cache device assignments and you will have to manually re-assign devices to cache.  As long as you reassign the correct devices, data should remain intact.


Link to comment

@klepel  Thank you!  I cannot believe that I saw nothing out of place, yet the issue was looking right at me, wow.  I didn't notice that the cache drives were no longer assigned. That explains my issues.  After assigning the drives, everything is back to normal on 6.8.3. 


Take away for me is to remember to review those release notes :)


Now that I emergency is over, what do you think about staying on 6.8.3 vs trying 6.9.1?  I have downloaded 6.9.1 zip, but should I just wait for 6.10 stable?


@Hoopster Oh thanks for the reminder about manually upgrading.  It's been so long since we had to do it that way, I forgot.


I thought we only copied a couple of files back then.  I see there are several bz* files now.  If I decide to try 6.9.1, I assume I can just copy the highlighted bz* files to my flash, and there is no need to update any other files on the flash, meaning no need to update files from the syslinux directory, as example.  Is that correct?



Link to comment
  • optiman changed the title to downgraded from 6.9.2 to 6.8.3, no dockers, error saying could not start, missing shares (SOLVED)

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.