SAS expander: misidentified by controller?


Recommended Posts

I am using an adaptec 6405E sas controller with an adaptec 82885t expander card (connected with a sff-8087 to sff-8643 cable), but the expander appears as "Adaptec Virtual SGPIO" both in the controller utility before boot and in arcconf command line utility (when I list slot configuration using the command arcconf slotconfig).

 

This is preventing me from performing a firmware update of the expander, giving the error "Expander upgrade is not supported on a Virtual SGPIO enclosure device" (using the cmd arcconfig utility).

 

The expander shows up as enclosure 0 in maxview storage manager but connected drive count is 0 even when I connect drives with a fanout sas cable, which is why I wanted to update the firmware in the first place. I tried connecting the fanout cable to all sas ports on the expander card, and I know the drives are compatible with both the expander and the controller. 

 

Has any had this problem or any suggestions to fix it?

AM-JKLVtXAmxDYCoSaNVIMxV5y2mWzplCuRzh-4w

Link to comment

Yes, seems expander have problem. I have two both can recognize under maxview storage manager.

 

Could be controller issue, but I am not sure, expander work with LSI and Micorsemi HBA.

Edited by Vr2Io
Link to comment
Posted (edited)

The expander shows in Maxview as enclosure 0, it's just that attached drives don't show up. Also if I connect the same drives directly to the controller they show and work, so I know the issue is not the controller. According to the expander manual, it should be compatible with my controller too.

 

Does the expander firmware have to be updated through the controller? What if I connect the expander to a pcie port (instead of powering with molex cable), disconnect from the controller and boot from a usb then use fw_tool in something like dos?

Edited by slowasmolasses
Link to comment

Different type cable to 8643 or 8644, all work in general.

 

Does your expander heatsink hot ?

 

Note : My firmware show B057, I can't remember does I got problem on B059 so stay in B057 or anything, I have update from Intel source in day one where microsemi haven't update in that time, I also update the CPLD chip ..... or you may try this

https://www.intel.com/content/www/us/en/download/18199/intel-raid-expander-res3fv288-res3tv360-firmware.html

 

image.png.efaae255196640150fdd5f23b57cc071.png

 

Edited by Vr2Io
Link to comment

Yes, my expander heatsink is hot.

 

When I do sg_inq, the firmware doesn't even show. Product identification is "Virtual SGPIO" instead of "AEC-82885T".

sg_inqresult.png.21a3a233a96b21fe46f68e8c701b99ad.png

 

I tried doing a clpd update but neither clpd update nor firmware update is "supported on virtual sgpio device"expander_upgradeissue.thumb.png.82292accd0daa03e5d3c27ce1dda5f09.png

 

I'm wondering if I need to do a manufacturing image update (the third update type in the first red box) but I don't think that will work either since the general command expanderupgrade is not working.

Link to comment

I suspect that as well. There is a pair of jumper pins on the expander that are documented as "reserved" in the manual. Do you know what they are for? I wonder if it's something like clearing the cmos or resetting the firmware, similar to the clear cmos jumpers on a motherboard.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.