[SOLVED] Unraid server (6.9.x 6.10.x) crash and is unreachable after WOL

Go to solution Solved by terox,

Recommended Posts

  • Solution

Fixed. Not a bug, but the "CPU pinning" panel could induce into confusions for "non-sys guys". By parts:


The solution:

My CPU has 12 cores (6/6). I had isolate the CPU with id 0 and 6. My VM has pinned the rest of cores (1,2,3,5,7...). This configuration is completely wrong. The isolated CPUs "are out" of the task scheduler. By this misunderstood configuration I was achiving a crash may be because teorically non-isolated CPUs was using for VM (and containers). After a change of pinned CPUs from 0,6 to 1-5,7-11 and pin the same isolated cores to VM, the issue was fixed. I reserved the CPU 0,6 for dockers and Unraid processes.


Why I think that CPU Pinning induce to confusions:

There is nothing that visual in the panel that alert you that you have (or could you have) a potential issue of performance or configuration. To know some of this problems, you need to install a "Fix common Problems" to have some clue. I think that It should be integrated into the panel.

Thank you for help and clues.

Link to comment
  • terox changed the title to [SOLVED] Unraid server (6.9.x 6.10.x) crash and is unreachable after WOL

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.