Split AppData


Recommended Posts

I added a 2nd Cache Drive several months ago following SI-1's cookbook. My original cache drive is Cache_SSD and my new one is Cache_NVME.

I modified my share settings so all folders that I want to cache point to Cache_SSD.  Docker, VM, and Appdata are set to Cache_NVME.

Everything checked out when I was done all Dockers and VM's were functioning.

Just looking around on Krusader and noticed that Cache_SSD still has an AppData folder with a folder for each Docker.

 

I changed the folder Name of Sonarr at this location to Sonarr1.  My Sonarr library is now empty(says no series found) even after I renamed it  back to Sonarr and restarted the app.

The container path for all of my dockers is still set to \Mnt\User\AppData\<Docker Name>, do I need to update these paths?

Is there any way to get back my Sonarr Library?  I do CA Appdata Backups Daily.

 

Sizes of Appdata:

Cache_SSD: 758MB

CACHE_NVME: 42GB

 

Thanks,

a12vman

 

 

Edited by a12vman
Link to comment

Did you take any action to move existing files to the new cache drive?   Simply changing the user share settings is not sufficient as that only applies to new files, not existing ones.    The existing ones for a user share will be found regardless of where they reside (array or any pool).

 

my suspicion is when you renamed the folder on the old cache pool that caused a new (empty) Sonarr folder to be created on the new cache pool which is why Sonarr list it’s data. You should be able to get the settings for Sonarr back by moving the contents of the Sonarr1 folder on the old cache Pool to the Sonarr folder on the new cache pool.

 

Link to comment

I did follow SI-1's process of migrating cache data using the cache settings.

 

Moved appdata from Old Cache to Array

Moved appdata from Array to New Cache

 

I think where I went wrong.  I didn't update the AppData Config path from /mnt/user/appdata/sonarr to /Cache_SSD/Appdata/sonarr

 

I repointed my containers.  Everything seems to be working now.

 

Thanks for your help, not sure how I missed that step!

Link to comment
9 minutes ago, a12vman said:

I did follow SI-1's process of migrating cache data using the cache settings.

 

Moved appdata from Old Cache to Array

Moved appdata from Array to New Cache

 

I think where I went wrong.  I didn't update the AppData Config path from /mnt/user/appdata/sonarr to /Cache_SSD/Appdata/sonarr

 

I repointed my containers.  Everything seems to be working now.

 

Thanks for your help, not sure how I missed that step!

There had to be something wrong in the steps you did as /mnt/user/appdata/sonarr will work regardless of the drives the ‘sonarr’ folder exists on.    You should not have had to update the container settings if it referenced a ‘mnt/user’ type path.

Link to comment

I don't know what I did wrong, but I completely lost my Sonarr Library and my Plex Library.

 

I could have restored, I had 7 days of CA Backups.

 

Instead I changed the AppData Config Path to explicitly use /Cache_NVME/Appdata/Sonarr and the same for Plex.

 

I rebuilt both libraries and all is well.

 

It's a housekeeping task I have been wanting to do for some time.  The only downside is I lost all of my viewing history.

 

 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.