"SimpleFeatures" Plugin - Version 1.0.11



2848 posts in this topic Last Reply

Recommended Posts

  • Replies 2.8k
  • Created
  • Last Reply

Top Posters In This Topic

Would it be possible to get a NOCORRECT option for the Scheduler parity check?  I know it isn't likely there will be a problem, but I'd prefer to control whether or not the correction is done. 

 

Thanks a lot for the awesome work.

Link to post

Hi please can you help I have tried to install the following by unrar each file into folders and copying the folders to the extra folder on root but cant get it to work in 5.0 beta14

 

Base Package:

Disk Health:

Email Notify:

S3 Sleep:

Stats Package:

Link to post

Man there you stop watching for updates here, and BOOM so many things have changed in such a short time.

 

Do i see it right that the S3 function is now ready built in into the Simple Features Plugin?

Does that mean i dont have to run the handcrafted script from the forum i use for nearly one year now?

Link to post

Hi all,

 

sorry to bring the discussion back down to noob level, but i'm really struggling with getting this to run. I started out with 4.7, have been running 5beta7 for ages and upgraded to b14 yesterday, with no apparent troubles, yet. I haven't used simple features before and tried to get it running for the first time, after upgrading to b14.

 

I followed the instructions on page one of this thread, to the point where i got confused, lol... The packages are in the the 'extras' folder (/boot/extra), however nothing happens after a reboot.

 

The instruction

If you're migrating from an earlier version, remember to remove the installpkg entry in your "Go" file before continuing.
confuses me, because i can't see anything in my go script that i can delete, there's the command to run the packages that have been installed via unmenu which are located /boot/packages, then the commands to start SAB/SB/CP and then a line to start PLEX MS?...

 

#!/bin/bash
# Start the Management Utility
/usr/local/sbin/emhttp &

/boot/unmenu/uu

sleep 10

cd /boot/packages && find . -name '*.auto_install' -type f -print | sort | xargs -n1 sh -c

sleep 10

# determine if cache drive online, retry upto 7 times
for i in 0 1 2 3 4 5 6 7
do
    if [ ! -d /mnt/cache ]
    then
      sleep 10
    fi
done

# If Cache drive is online, start SABnzbd, Sickbeard, and CouchPotato
if [ -d /mnt/cache ]; then
  cd /mnt/cache/.custom
  installpkg /boot/packages/SABnzbdDependencies-2.1-i486-unRAID.tgz
  python /mnt/cache/.usenet/sabnzbd/SABnzbd.py -d
  python /mnt/cache/.usenet/sickbeard/SickBeard.py --daemon
  python /mnt/cache/.usenet/couchpotato/CouchPotato.py -d
fi

sleep 10

/mnt/cache/.PLEX/0952/start.sh

 

Slightly confused!? Also, how does unRAID know to look for the 'extras' folder, shouldn't i have to edit that into the go script?

 

I'd really appreciate some help/advice,

 

Thanks,

 

Rich

Link to post

Hi

 

in the Stats package, could you edit the crontab script, end of doinst.sh so it does not log into the syslog file every 2 minute ?

 

the other entries in my crontab have a > /dev/null added ... think that will do the trick .. no ?

 

Logfile below.

 

Br tsatsa

 

Mar  8 11:26:01 Tower kernel: crond[17739]: segfault at b785e51c ip b785e51c sp bff49f94 error 15 in ld-2.11.1.so[b785e000+1000]

Mar  8 11:28:01 Tower crond[1099]: exit status 1 from user root /usr/lib/sa/sa1 1 1

Mar  8 11:28:01 Tower kernel: crond[18031]: segfault at b785e51c ip b785e51c sp bff49f94 error 15 in ld-2.11.1.so[b785e000+1000]

Mar  8 11:30:01 Tower crond[1099]: exit status 1 from user root /usr/lib/sa/sa1 1 1

Mar  8 11:30:01 Tower kernel: crond[18339]: segfault at b785e51c ip b785e51c sp bff49f94 error 15 in ld-2.11.1.so[b785e000+1000]

Mar  8 11:32:01 Tower crond[1099]: exit status 1 from user root /usr/lib/sa/sa1 1 1

Mar  8 11:32:01 Tower kernel: crond[18635]: segfault at b785e51c ip b785e51c sp bff49f94 error 15 in ld-2.11.1.so[b785e000+1000]

 

Link to post

Please post screenshot of your flash extra folder. It should just work, your go file is fine! Extra folder is an automated way of running and installing packages on boot.

 

Cheers!

 

Here's the requested pic, thanks  :)

Screen_Shot_2012-03-09_at_00_48_57.jpg.46b778f66361f9a96d41ff52fb47e3de.jpg

Link to post

Ah yep - looks like the original packages have been decompressed (might be automatic depending on your browser settings). They should be untouched from google code, and should have .tgz as the extension.

 

Cheers

 

Awesome, simplest solution ever, but i would have never have known unless told.

 

Thanks, a lot,

 

Rich

Link to post

Andrew,

 

I made an update to the S3 Sleep addon to add an option for setting WOL options prior to sleep.  My system will not maintain the WOL options through reboot and I thought adding this feature to your plugin would make it easier to deal with if necessary.

 

I also updated the s3_sleep script to add an option for passing the wol options and also an option to sleep now.  I added the sleep now option so I could use this script to sleep and it will set the wol option if necessary and also renew DHCP and force gigabit if those options are set.

I updated the base package to use the s3_sleep script for the main "Sleep" button if the S3 addon is installed and S3 sleep is enabled in the settings.  This keeps the sleep functionality consistant when sleeping using the Sleep button and when the system sleep automatically.

 

Here are links to the two modified packages:

http://walnuthead.com/unraid/simpleFeatures-v1.0b6-s3-sleep-addon-walnuthead.tgz

http://walnuthead.com/unraid/simpleFeatures-v1.0b6-base-walnuthead.tgz

 

Greg

 

Link to post

Hi, Speeding_Ant

 

I would like to thank you one more time for this marvelous piece of software.

 

There is a minor bug I have noticed with the latest version. Have a look on attached screen print. Check out network graph. You will see that after a file transfer (spike in processor usage) the network usage graph didn't go down to zero activity at a due time, but rather was spread linearly from the time of transfer termination till the current time. This happens both in IE9 and Chrome.

 

Regards,

Eugene

Screen.jpg.983a96f24e3b4e4b48f3c218fac2706c.jpg

Link to post

Hi I am looking for some help I would really like my server to use the s3 function.  My motherboard is an Asus M4A78LT-M LX the simple features function allows my server to auto S3 sleep but I have to awake by pressing the power button.  Have tried to wake it up with a WOL batch file but no succsess.  When I run a ethtool eth0 I get confermation of Auto-negotiation: on

      Supports Wake-on: pumbg

      Wake-on: g

Does this mean my mother board supports wol or would I need to add a network card that supports WOL

 

Motherboard bios settings

Suspend mode - Auto

 

ACPI 2.0 Support - Enabled

 

ACPI APCI Support - Enabled

 

APM  Config Menu

Restore on Power Loss - Last State

Power on From S5 by PME # - Enabled

Power on From S5 by Ring - Enable

Power on by PS/2 keyboard - Disabled

Power on From S5 by RTC Alarm - Disabled

 

 

Thanks

Link to post

Question about S3 sleep functionality, if I may.

 

My HP ProLiant MicroServer (N40) doesn't support S3 Sleep, but does support Hibernate.

 

Would it be possible to add support for switchable sleep/hibernate functionality so I can take advantage of this functionality?

 

hibernate saves memory state to a HDD.  Which HDD are you going to save to?  I would not suggest Flash.

Ah, I didn't think of that. No problem - leaving it on 24/7 is fine :)
Link to post

Hi Guys,

 

I'm sorry for being a total newb to this, but I don't really understand how I'm supposed to install simple-features, and I want them SO badly for my unRAID setup.

 

I browsed to my 'flash' drive via my network and created a directory called 'extra'.  I then copied all of the content from each of the packages into this 'extra' location and nothing happened.  I assumed that nothing would because it didn't touch any of the default files, and the instructions say something about /boot/extra/ but I'm not sure how to access /boot/.

 

Any help would be appreciated.  I've only just recently set up my server so it's all very new to me, I'm learning, and becoming used to a lot of the features fast, but this is the first more 'manual' install that I've attempted and I'm stumped.  I'm going to browse through the lime wiki's for some sort of help about this as well (the How To's) but I thought a quick explanation from someone here might be just as easy (hopefully).

 

Cheers for the help.  These forums are so awesomely supportive :D

 

Dave

Link to post

Install Instructions:

 

If you're migrating from an earlier version, remember to remove the installpkg entry in your "Go" file before continuing.

 

1. Download the packages you wish to install. The Base package is required for all other packages to run.

 

2. Create folder called Extra at the base of the flash drive - "/boot/extra"

 

3. Copy in the packages (must have .tgz extension) you wish to have installed on Boot.

 

4. Reboot. If it looks funny, please clear your browser cache!

Link to post

Install Instructions:

 

If you're migrating from an earlier version, remember to remove the installpkg entry in your "Go" file before continuing.

 

1. Download the packages you wish to install. The Base package is required for all other packages to run.

 

2. Create folder called Extra at the base of the flash drive - "/boot/extra"

 

3. Copy in the packages (must have .tgz extension) you wish to have installed on Boot.

 

4. Reboot. If it looks funny, please clear your browser cache!

 

I have been having trouble with those instructions.

 

I have followed those instructions to the letter and it's not working for me, therefore I am wondering what I am doing wrong.

Link to post
  • Squid locked this topic
Guest
This topic is now closed to further replies.