[Support] Fantucie App's


Recommended Posts

5 hours ago, kjames2001 said:

hi, i just installed the seafile app you uploaded, there's an extra ":" in "seafileltd:/seafile:latest" causing the docker pull to fail. just to bring it to your attention.

Little edit, after have talk with squid, this Error will be fix in the past hours when your CA will be update, everything should be fine :) 

  • Like 1
Link to comment

Thanks!

 

I noticed that this official docker points to version 6 of seafile, and there's a bug preventing intergration of onlyoffice. This bug is fixed in version 8.0.3, and the latest Community Edition version is 9+. is there anyway we can have a docker for the latest CE version?

Link to comment
8 minutes ago, kjames2001 said:

Thanks!

 

I noticed that this official docker points to version 6 of seafile, and there's a bug preventing intergration of onlyoffice. This bug is fixed in version 8.0.3, and the latest Community Edition version is 9+. is there anyway we can have a docker for the latest CE version?

 

Yes I can see to fix that for sure, if you want to see the update in direct or know when it will be release, join the discord server to dont miss anything ;) 

Link to comment
3 hours ago, learnin2walk said:

I did a large upload in filerun, and it's now filling up my docker.img file. The share where it's supposed to dump the files is empty. Is there a cron job that needs to be ran manually to move the files to the unraid share? 


I never get this, I have like 1T full on my FileRun with no problem with my docker.img this seem to be an error from you who change the path to a wrong one, maybe.

Link to comment

I'm trying to setup Filerun, and when trying to connect the Linux NextCloud client with the Filerun instance, I'm getting this error: "The polling URL does not start with HTTPS despite the login URL started with HTTPS. Login will not be possible because this might be a security issue. Please contact your administrator."

 

Anyone knows how I could fix this? I'm using SWAG as a reverse proxy with HTTP redirected to HTTPS.

 

Thanks!

Edited by touz
Link to comment
17 hours ago, touz said:

I'm trying to setup Filerun, and when trying to connect the Linux NextCloud client with the Filerun instance, I'm getting this error: "The polling URL does not start with HTTPS despite the login URL started with HTTPS. Login will not be possible because this might be a security issue. Please contact your administrator."

 

Anyone knows how I could fix this? I'm using SWAG as a reverse proxy with HTTP redirected to HTTPS.

 

Thanks!


Just to ask, if you have setup FileRun, did you register it with your https address in the admin panel ? 
And why do you want connect NextCloud with FileRun ?

Link to comment
17 hours ago, touz said:

I'm trying to setup Filerun, and when trying to connect the Linux NextCloud client with the Filerun instance, I'm getting this error: "The polling URL does not start with HTTPS despite the login URL started with HTTPS. Login will not be possible because this might be a security issue. Please contact your administrator."

 

Anyone knows how I could fix this? I'm using SWAG as a reverse proxy with HTTP redirected to HTTPS.

 

Thanks!

 

4 minutes ago, Fantucie said:


Just to ask, if you have setup FileRun, did you register it with your https address in the admin panel ? 
And why do you want connect NextCloud with FileRun ?

 
+ Your problem same to be with NextCloud, I don't know this docker that much, the FileRun at has been make to run lonely, I will not provide support for it, you must go to to [Support] Knex666 - NexCloud if you use this one, or the support of the one you use.

Link to comment
6 hours ago, Fantucie said:

 

 
+ Your problem same to be with NextCloud, I don't know this docker that much, the FileRun at has been make to run lonely, I will not provide support for it, you must go to to [Support] Knex666 - NexCloud if you use this one, or the support of the one you use.

 

Well Filerun recommends the NextCloud client to sync the desktop with the Filerun app. I was able to solve this by enabling the API in the control panel.

Thanks!

Link to comment
  • 1 month later...

Having a problem with setup of a new seafile instance. It works fine without SSL, but when I turn SEAFILE_SERVER_LETSENCRYPT on, I get the following in the log files:

 

[2022-05-19 20:05:45] Preparing for letsencrypt ...
[2022-05-19 20:05:45] Found existing cert file /shared/ssl/mydomain.com.crt
Certificate will expire
[2022-05-19 20:05:45] Starting letsencrypt verification
fatal: unable to connect to github.com:
github.com[0: 140.82.113.3]: errno=Connection timed out

Traceback (most recent call last):
File "/scripts/start.py", line 86, in <module>
main()
File "/scripts/start.py", line 51, in main
init_letsencrypt()
File "/scripts/bootstrap.py", line 67, in init_letsencrypt
call('/scripts/ssl.sh {0} {1}'.format(ssl_dir, domain))
File "/scripts/utils/__init__.py", line 68, in call
return subprocess.check_call(*a, **kw)
File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '/scripts/ssl.sh /shared/ssl mydomain.com' returned non-zero exit status 1
*** /scripts/start.py exited with status 1.
fatal: unable to connect to github.com:
github.com[0: 140.82.113.3]: errno=Connection timed out
 

 

Could this be the due to the problem found in https://github.com/haiwen/seafile-docker/issues/290, where the call to github is made with http instead of https? If so, how would I fix it? Is there a way for me to get into the docker image and edit the script there, or is this another problem entirely?

Link to comment
Posted (edited)

i am Having an issue with pterodactyl/wings after i copy over the yml file from the panel i get the issue below. Please can someone help. i have tried custom br0 network, i have tried my nginx reverse proxy network and they all keep coming up with the same error

 

__ [34m[1mPterodactyl[0m _____/___/_______ _______ ______
\_____\ \/\/ / / / __ / ___/
\___\ / / / / /_/ /___ /
\___/\___/___/___/___/___ /______/
/_______/ [1m1.6.1[0m

Copyright © 2018 - 2022 Dane Everitt & Contributors

Website: https://pterodactyl.io
Source: https://github.com/pterodactyl/wings
License: https://github.com/pterodactyl/wings/blob/develop/LICENSE

This software is made available under the terms of the MIT license.
The above copyright notice and this permission notice shall be included
in all copies or substantial portions of the Software.

INFO: [May 22 12:56:19.390] loading configuration from file config_file=/etc/pterodactyl/config.yml
INFO: [May 22 12:56:19.405] configured wings with system timezone timezone=America/Denver
INFO: [May 22 12:56:19.416] checking for pterodactyl system user username={0 0}
INFO: [May 22 12:56:19.425] configured system user successfully gid=988 uid=988 username=pterodactyl
INFO: [May 22 12:56:19.442] fetching list of servers from API
INFO: [May 22 12:56:19.615] processing servers returned by the API total_configs=0
INFO: [May 22 12:56:19.627] finished processing server configurations duration=11.051733ms
INFO: [May 22 12:56:19.639] creating missing pterodactyl0 interface, this could take a few seconds...
FATAL: [May 22 12:56:19.655] failed to configure docker environment error=Error response from daemon: Pool overlaps with other one on this address space

Stacktrace:
Error response from daemon: Pool overlaps with other one on this address space

 

Below is copied from my yml file

debug: false
uuid: ea5c988b-73b1-44d7-b9b0-41a96c5fd63b
token_id: OX2Iwv0DYKjZtGDc
token: i9V8zuprPvO4QTaJfqfXwmQEYuFdxYeKDL01goikZ1yDXBmzsKc0DY3b8onujOQM
api:
  host: 0.0.0.0
  port: 8484
  ssl:
    enabled: false
    cert: /etc/letsencrypt/live/10.0.0.200/fullchain.pem
    key: /etc/letsencrypt/live/10.0.0.200/privkey.pem
  upload_limit: 100
system:
  data: /var/lib/pterodactyl/volumes
  sftp:
    bind_port: 2022
allowed_mounts: []
remote: 'http://10.20.30.3:8585'

 

I Fixed this issue by making a new network but now my issue is below with any server i try to make

 

Stacktrace:
Error response from daemon: invalid mount config for type "bind": bind source path does not exist: /var/lib/pterodactyl/volumes/e4f61eca-838e-4101-88ab-8f31df8c9e58
environment/docker: failed to create container
github.com/pterodactyl/wings/environment/docker.(*Environment).Create
    github.com/pterodactyl/wings/environment/docker/container.go:238
github.com/pterodactyl/wings/server.(*Server).CreateEnvironment
    github.com/pterodactyl/wings/server/server.go:250
github.com/pterodactyl/wings/router.postCreateServer.func1
    github.com/pterodactyl/wings/router/router_system.go:73
runtime.goexit
    runtime/asm_amd64.s:1581

 

Edited by Jensenstation
Link to comment
On 5/23/2022 at 12:50 AM, Jensenstation said:

i am Having an issue with pterodactyl/wings after i copy over the yml file from the panel i get the issue below. Please can someone help. i have tried custom br0 network, i have tried my nginx reverse proxy network and they all keep coming up with the same error

 

__ [34m[1mPterodactyl[0m _____/___/_______ _______ ______
\_____\ \/\/ / / / __ / ___/
\___\ / / / / /_/ /___ /
\___/\___/___/___/___/___ /______/
/_______/ [1m1.6.1[0m

Copyright © 2018 - 2022 Dane Everitt & Contributors

Website: https://pterodactyl.io
Source: https://github.com/pterodactyl/wings
License: https://github.com/pterodactyl/wings/blob/develop/LICENSE

This software is made available under the terms of the MIT license.
The above copyright notice and this permission notice shall be included
in all copies or substantial portions of the Software.

INFO: [May 22 12:56:19.390] loading configuration from file config_file=/etc/pterodactyl/config.yml
INFO: [May 22 12:56:19.405] configured wings with system timezone timezone=America/Denver
INFO: [May 22 12:56:19.416] checking for pterodactyl system user username={0 0}
INFO: [May 22 12:56:19.425] configured system user successfully gid=988 uid=988 username=pterodactyl
INFO: [May 22 12:56:19.442] fetching list of servers from API
INFO: [May 22 12:56:19.615] processing servers returned by the API total_configs=0
INFO: [May 22 12:56:19.627] finished processing server configurations duration=11.051733ms
INFO: [May 22 12:56:19.639] creating missing pterodactyl0 interface, this could take a few seconds...
FATAL: [May 22 12:56:19.655] failed to configure docker environment error=Error response from daemon: Pool overlaps with other one on this address space

Stacktrace:
Error response from daemon: Pool overlaps with other one on this address space

 

Below is copied from my yml file

debug: false
uuid: ea5c988b-73b1-44d7-b9b0-41a96c5fd63b
token_id: OX2Iwv0DYKjZtGDc
token: i9V8zuprPvO4QTaJfqfXwmQEYuFdxYeKDL01goikZ1yDXBmzsKc0DY3b8onujOQM
api:
  host: 0.0.0.0
  port: 8484
  ssl:
    enabled: false
    cert: /etc/letsencrypt/live/10.0.0.200/fullchain.pem
    key: /etc/letsencrypt/live/10.0.0.200/privkey.pem
  upload_limit: 100
system:
  data: /var/lib/pterodactyl/volumes
  sftp:
    bind_port: 2022
allowed_mounts: []
remote: 'http://10.20.30.3:8585'

 

I Fixed this issue by making a new network but now my issue is below with any server i try to make

 

Stacktrace:
Error response from daemon: invalid mount config for type "bind": bind source path does not exist: /var/lib/pterodactyl/volumes/e4f61eca-838e-4101-88ab-8f31df8c9e58
environment/docker: failed to create container
github.com/pterodactyl/wings/environment/docker.(*Environment).Create
    github.com/pterodactyl/wings/environment/docker/container.go:238
github.com/pterodactyl/wings/server.(*Server).CreateEnvironment
    github.com/pterodactyl/wings/server/server.go:250
github.com/pterodactyl/wings/router.postCreateServer.func1
    github.com/pterodactyl/wings/router/router_system.go:73
runtime.goexit
    runtime/asm_amd64.s:1581

 

  data: /var/lib/pterodactyl/volumes isn't goooddd go read the install tuto that i made page 1

Link to comment
Posted (edited)

! PREVENTING MESSAGE !

 

In this night PterodactylPanel got an update if your panel is in error 500 that actually normal !

You need to have a Redis Docker on your server now !

The update of the patern for unraid has been make RN so wait a few hours to got the update and make everything work again ! 
If you dont wanna wait and do it yourself 

image.png.6d9a7308b761f0106bd1f22fab2df580.png
EDIT:
I have setup a version selector, who will let you choose between Latest or version v1.7.0 who is the before this update ! 

Edited by Fantucie
Check edit
Link to comment
  • 2 weeks later...
  • 1 month later...
  • 1 month later...

Hi! currently trying to setup FileRun, but when I get to the setup stage, to connect to the database, it gets stuck at setting up database. 

 

I know the database works since I'm using it for other apps. Where can i find logs etc to see what the issue is? Or do you maybe have some pointers for what to do?

Link to comment
On 9/23/2022 at 10:19 AM, jterpstra said:

Hi! currently trying to setup FileRun, but when I get to the setup stage, to connect to the database, it gets stuck at setting up database. 

 

I know the database works since I'm using it for other apps. Where can i find logs etc to see what the issue is? Or do you maybe have some pointers for what to do?


Hello there (sorry for late answer) ! 
I never got this error before ? 
I personnally use MariaDB with a special db create for FileRun.
Normally you can see all logs with the Log button of unraid, but if really needed go to 

/mnt/user/appdata/FilesRun/system/data/temp/system/data/temp/mysql_error.log

 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.