[SUPPORT] SmartPhoneLover - Remote Wake/Sleep-On-LAN Server


Recommended Posts

Posted (edited)

rwsol-server.png

 

This docker template was created based on an already available docker image

 

Website: https://www.jeremyblum.com/2013/07/14/rpi-wol-server/

GitHub: https://github.com/ex0nuss/Remote-Wake-Sleep-On-LAN-Docker

GitHub (original): https://github.com/sciguy14/Remote-Wake-Sleep-On-LAN-Server
DockerHub: https://hub.docker.com/r/ex0nuss/remote-wake-sleep-on-lan-docker
My Repository: https://github.com/SmartPhoneLover/unraid-docker-templates

 

DESCRIPTION
The Remote Wake/Sleep-On-LAN Server (RWSOLS) is a simple webapp to remotely power up (wake) and power down (sleep) any supported device via WOL/SOL protocol.

 

NOTES
• If you want to use the 'SLEEP' function, additional software will be needed on the client: 'Sleep-On-LAN (SOL)'. A button to sleep the device will be shown, instead of wake device, when corresponding variables are set accordingly. Both 'wake' and 'sleep' options will be shown in the web interface according to the current state of the device.
• The values of Name, MAC and IP variables (RWSOLS_COMPUTER) must be intered in the following format: "xxx","xxx".
• There are other variables that you can use, if needed. Check the GitHub repo to know more.
• When changing the webserver's port, be sure to set the same port number in all corresponding fields on this template.
• The default password for the wake/sleep function (button) is: 'unRAID', but you can set your own. Leave it blank (do not delete the variable) if you don't want to enter any.

 

VERSION
1.1 (2022-05-26)


If you are going to report a bug or request something to be added/modified, please, take into consideration that I will only be able to apply changes for the work I own only. For example, if I create a docker template for an already existing docker image (not created by me), I won't be able to do more for that image than forward your report or request to the owner of the project.

Edited by SmartPhoneLover
Link to comment

Hey Hello there i have this error message, maybe i dont see the obvious solution for that

 

search_and_replace REPLACE_RWSOLS_COMPUTER_IP with 192.168.178.x
search_and_replace REPLACE_RWSOLS_COMPUTER_MAC with xx:xx:x:xx:x:xx
search_and_replace REPLACE_RWSOLS_COMPUTER_NAME with Tower
search_and_replace REPLACE_RWSOLS_MAX_PINGS with 15
search_and_replace REPLACE_RWSOLS_SLEEP_CMD with suspend
search_and_replace REPLACE_RWSOLS_SLEEP_PORT with 7760
search_and_replace REPLACE_RWSOLS_SLEEP_TIME with 5
search_and_replace port 8080 with 8099
Starting Apache2: /usr/sbin/apache2ctl -D FOREGROUND
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 192.168.178.2. Set the 'ServerName' directive globally to suppress this message

 

where can i set that "directive globally" :D 

 

i tryed reaasonable changes and even unreasonable

 

i tryed the MAC of my PC i want to wake and its Local IP

i tryed the MAC of my Unraidserver and its Local IP

 

both variants result in not finding its qualified domain name.. 

 

 

 

 

Link to comment
Posted (edited)

@domrockt

If the container works as expected after setting all the fields, the 'AH00558: Could not reliably determine the server's fully qualified domain name' error can be ignored safely. It does not prevent the Apache from running. Anyway, I will try to find a solution for the containers where the corresponding config files are not correctly configured by their devs.

 

I have created a little guide about how to disable this warning. You can check it here.

Edited by SmartPhoneLover
Link to comment

UPDATE

v1.1 (2022-05-26)

- New: Added 'PASSPHRASE' variable to allow using a password for the WebGUI.

- New: Added 'RWSOLS_MAX_PINGS' variable (declared only in the docker image) to configure the max number of ping calls to send to a device to detect its state.

- Fix: The configured webserver's port didn't match with the one set in 'WebUI' port field, my fault sorry. (It worked when I created the template, maybe because it was cached from previous testings)

- Other: Changed the webserver's port to 9999, to prevent posible conflicts with the default one (8080).

Link to comment
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.