Unraid 6.10-rc4 no Network \ no UI \ no Services


Go to solution Solved by trurl,

Recommended Posts

Hi All

 

I just updated unraid to the latest RC and rebooted my server, it has not come back up at all.

 

After a while I connected a monitor to it, and logged into the GUI mode to try an troubleshoot it.

 

I am unable to open the UI while physically sitting in front of the server and am unable to browse the network \ internet at all - so I am leaning towards it being a NIC or network issue.

 

The symptoms I got were:

- Unraid taking forever to initialize SAMBA

- NIC lights flashing with no connection

- No UI started when logged into the server

- No network access of any kind

- Server not responding to ping

 

I have tried using the other network points on the server and rebooting to the same issue (there are 4 of them that are usually bonded together).

 

Any help here would be amazing, as I am a bit concerned about my data 

PXL_20220526_140728569.jpg

PXL_20220526_140738622.jpg

Link to comment

I did manage to pull down a previous backup of my flash drive through "My Servers" and this was the expected NIC configuration if that helps at all.

 

# Generated settings:
IFNAME[0]="br0"
BONDNAME[0]="bond0"
BONDING_MIIMON[0]="100"
BRNAME[0]="br0"
BRSTP[0]="no"
BRFD[0]="0"
BONDING_MODE[0]="1"
BONDNICS[0]="eth0 eth1 eth2 eth3"
BRNICS[0]="bond0"
PROTOCOL[0]="ipv4"
USE_DHCP[0]="no"
IPADDR[0]="192.168.0.60"
NETMASK[0]="255.255.255.0"
GATEWAY[0]="192.168.0.2"
DNS_SERVER1="1.1.1.1"
DNS_SERVER2="8.8.8.8"
USE_DHCP6[0]="yes"
DHCP6_KEEPRESOLV="no"
SYSNICS="1"

 

Link to comment

Yes it was, however I do not have any means of uploading it,

 

I have shut down the server, removed the flash drive and plugged it into this PC.

 

There is a drive mounted in Windows when I do that, however it won't allow access to it without me formatting it - I have checked on diskpart \ manager and the only volume exposed is the uncountable one.

 

Do I need to do something special to be able to browse the /boot directory locally?

PXL_20220526_145409981.jpg

Link to comment

After a couple of hours of fighting with it I just reinstalled Unraid  6.10.1 to a new USB and rebooted the server, migrated my key and am now trying to figure out how to import my disks again, at the moment I am stuck looking at the following screen

 

I did make a backup of the original drive before the reinstall, but I don't know how to import my disks correctly without messing things up.

 

Any suggestions?

2022-05-26 12_23_49-desktop-hqj8dst - TightVNC Viewer.png

Link to comment

I have managed to resolve the correct disks to slots on the array, however I wont start it as I am getting the warning that the disks will be overridden.

 

I cannot for the life of me find the correct guide for migrating servers

2022-05-26 12_46_59-NAS_Main.png

2022-05-26 12_47_07-NAS_Main.png

Link to comment
  • Solution

All of your configuration is in the config folder of your flash backup. Without that you are starting from scratch. As long as you don't assign a data drive to a parity slot your data should be fine. The screenshot is showing parity disks will be overwritten, not your data. 

Link to comment

Thanks all - just closing the loop here.

 

I managed to configure the appropriate settings for virtualization as suggested by @Squid along with creating a new flash drive with the latest stable version of Unraid.

 

In addition to that I did a manual sync of all configuration and shares to the new flash drive from the backup I had.

 

I made use of the vars diagnostics file to ensure that I mapped the correct drives when assigning drives and took a leap of faith when it came to starting the array based on @trurl which seemed to work.

 

My Docker images and shares are all back along with the array rebuilding.

 

Thank you everyone who helped, awesome community!

2022-05-26 13_53_46-NewNas_Main.png

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.