[GUIDE] INSTALL DSM 7.1 ON UNRAID 6.10.3 (2022)


Recommended Posts

Installing DSM 7.1.0.-42661 on UNRAID 6.10.3

 

I have been trying to install DSM 7.1 on my unraid server for the last night. After some problems and testing I have created this guide to install DSM 7.1 on unraid working perfectly.

 

This is my vm config:

 

983366734_dsmonunraid1.thumb.jpg.d41bb2d47124a5ac1e449297251e3895.jpg


STEP 1-Virtual machine creation: 
    

  •     Download tiny core from https://github.com/pocopico/tinycore-redpill
  •     Select CentOS VM Template and apply correct options from the attached image.
  •     Select Q35-6.2
  •     Select 3.0 (qemu XHCI)
  •     Load tiny red core as vdisk1 USB by selecting manually (you can create previously the name of the folder for the VM inside /domains and upload the tinycore img )
  •     Create secondary disk 50G or whatever you want (this is your data storage for synology) as vdisk2 SATA
  •     Select Network model: e1000
  •     Save.
  •     Uncheck "Start VM after creation"

  •     Edit again vdisk2 in the advanced xml template (top right corner) to controller='1' (if we don't do this tiny red core will not detect the disk properly when doing the satamap and will not install DSM correctly and will ask you to reinstall the *.pat infinitely)

 

STEP 2-Start VM and connect via SSH

 

  •     Start VM and load tiny red core
  •     Once the OS is loaded, open the terminal and enter ifconfig to find out the ip of the machine
  •     Connect via ssh (with Putty) to the obtained IP address.

        user: tc
        password: P@ssw0rd

 

STEP 3-Run the following commands:

 

  •     To update tiny red core with the latest data 

 

./rploader.sh update now
./rploader.sh fullupgrade now

 

  •     To generate random mac and serial numbers (copy mac address generated to set on unraid vm template later)

 

./rploader.sh serialgen DS918+ (or whatever version you want, you can see all versions available with command info ./rploader.sh)

 

  •     To map the connected disks

 

./rploader.sh satamap now

 

  •     To record the vid/pid from usb

 

./rploader.sh identifyusb now

 

 

  •     To install NIC drivers (sometimes it loads the e1000e module instead of the e1000 and it doesn't work, adding this command will make sure that the e1000 module for the NIC is loaded correctly)

 

For e1000 Network Card run:

 

./rploader.sh ext apollolake-7.1.0-42661 add https://raw.githubusercontent.com/pocopico/rp-ext/master/e1000/rpext-index.json

NOTE: change version according your selection for CPU and DSM version

 

For virtio-net Network Card run:

 

./rploader.sh ext apollolake-7.1.0-42661 add https://raw.githubusercontent.com/pocopico/rp-ext/master/v9fs/rpext-index.json

NOTE: change version according your selection for CPU and DSM version

 

  •     To build the image

 

./rploader.sh build apollolake-7.1.0-42661

 

STEP 4-Download your .pat for your correct cpu architecture from official repo or mega download for this version apollolake , we will need it to install DSM later.

 

https://global.download.synology.com/download/DSM/release/7.1/42661-1/DSM_DS918%2B_42661.pat - Offical repo

 

https://mega.nz/file/5YI2yCYL#oNR6Cq5FmIdySL1cdUm_8vm2A-BSuj2NqbP_7ywTe_A - DSM 7.1-42261 apollolake 

 

STEP 5-Edit VM settings on advanced xml mode and install *.pat

 

  • After doing all the above we shut down the machine.
  • Edit the virtual machine on xml advanced mode (if we change mac address in normal editing mode you will lose controller="1" option set for vdisk2 we did previously so you will have to set it again everytime you change and/or save a setting from normal mode, try to edit always in xml advanced mode), look for MAC address and set the MAC generated by tiny red core.
  • Save.
  • Start VM
  • Select the first option USB and leave it a few minutes like below image until we find it with synology assistant

redpill.thumb.jpg.e55369c5a460bc5449ea5d8dcfe72a23.jpg

 

  • Open WebGui and install *.pat

 

We now have DSM 7.1 working on unraid.

There is other method with SATA boot but I have to test it better.

 

Hope this guide help someone.

 

Regards.

Edited by viktortras
Link to comment
  • viktortras changed the title to [GUIDE] INSTALL DSM 7.1 ON UNRAID 6.10.3 (2022)
Posted (edited)
4 hours ago, ffhelllskjdje said:

can you give more details on STEP 5-Edit VM settings on advanced xml mode and install *.pat? I entered in the MAC but it just hangs when i try to boot from the usb option

Hi,

 

You have to edit vm template in XML advanced mode to put the MAC generated when you did ./rploader.sh serialgen DS918+ on STEP 2.

If you edit the MAC in normal mode, modifications done on XML will disappear (in this case the only modification in template we did is change controller="0" to "1" for VDISK2 so if you save MAC in normal mode controller, the modification will disappear and you will have to edit it again in XML advanced mode). 

After that, save template. 

 

When you start the vm and select the USB option, nothing appear except this.

 

redpill.thumb.jpg.40a720f83b14c1fe14df807e359534b8.jpg

 

This is the expected behaviour.

 

You have to find IP from Synology Assistant or find.synology.com and then install the *.pat.

Edited by viktortras
Link to comment
28 minutes ago, viktortras said:

Hi,

 

You have to edit vm template in XML advanced mode to put the MAC generated when you did ./rploader.sh serialgen DS918+ on STEP 2.

If you edit the MAC in normal mode, modifications done on XML will disappear (in this case the only modification in template we did is change controller="0" to "1" for VDISK2 so if you save MAC in normal mode controller modification will disappear and you will have to edit it again in XML advanced mode). 

After that, save template. 

 

When you start the vm and select the USB option, nothing appear except this.

 

redpill.thumb.jpg.40a720f83b14c1fe14df807e359534b8.jpg

 

This is the expected behaviour.

 

You have to find IP from Synology Assistant or find.synology.com and then install the *.pat.

Ah, thanks that worked! But now I'm getting a corrupted PAT error...hmmmm

is ./rploader.sh build apollolake-7.1.0-42661

using the processor that i want to DSM to have or what's installed on my unraid? My unraid has a 10th gen processor

Edited by ffhelllskjdje
Link to comment
Posted (edited)
1 hour ago, ffhelllskjdje said:

Ah, thanks that worked! But now I'm getting a corrupted PAT error...hmmmm

is ./rploader.sh build apollolake-7.1.0-42661

using the processor that i want to DSM to have or what's installed on my unraid? My unraid has a 10th gen processor

This problem "corrupted PAT error" often happen due to VDISK2 or corrupted pat file. You have to use the version according to your unraid processor, not whatever you want.

Did you change controller"0" to "1" in XML mode before start the VM first time? If you don't set this option when you do ./rploader.sh satamap now, command will not recognize second device VDISK2 and it will not write correctly the build so it will not works.

 

./rploader.sh satamap now result is this:

 

satamap.jpg.26d41ec148ca97857562e5c4de758c77.jpg

 

Also make sure you change the MAC address in VM template (always in XML advanced mode, I repeat if you save MAC address in normal mode, previously change on controller"1" will be removed) after create the build and stop the machine.

 

Which *.pat are you using?

 

Ok, I have just discover *.pat downloaded from /home/tc/redpill-load/cache/ is not working. Download official release. I used this.

 

https://mega.nz/file/5YI2yCYL#oNR6Cq5FmIdySL1cdUm_8vm2A-BSuj2NqbP_7ywTe_A

Edited by viktortras
Link to comment
2 hours ago, viktortras said:

This problem "corrupted PAT error" often happen due to VDISK2 or corrupted pat file. You have to use the version according to your unraid processor, not whatever you want.

Did you change controller"0" to "1" in XML mode before start the VM first time? If you don't set this option when you do ./rploader.sh satamap now, command will not recognize second device VDISK2 and it will not write correctly the build so it will not works.

 

./rploader.sh satamap now result is this:

 

satamap.jpg.26d41ec148ca97857562e5c4de758c77.jpg

 

Also make sure you change the MAC address in VM template (always in XML advanced mode, I repeat if you save MAC address in normal mode, previously change on controller"1" will be removed) after create the build and stop the machine.

 

Which *.pat are you using?

 

Ok, I have just discover *.pat downloaded from /home/tc/redpill-load/cache/ is not working. Download official release. I used this.

 

https://mega.nz/file/5YI2yCYL#oNR6Cq5FmIdySL1cdUm_8vm2A-BSuj2NqbP_7ywTe_A

You PAT worked! Thanks, I'm up and running now.

Link to comment
21 minutes ago, Luis Belo said:

Hi, 

Anyone with AMD cpu? 

I am having some difficulties to install it on my rizen 5.

 

When flash the pat file, give me corrupt file. 

Any help please? 

Thanks

I can't help you with AMD but it seems you have reached to find synology webgui so it should works...have you checked previously post?what .pat are you using?

Link to comment
4 hours ago, viktortras said:

I can't help you with AMD but it seems you have reached to find synology webgui so it should works...have you checked previously post?what .pat are you using?

Thanks for you reply 👍

I think that's the problem... I don't understand that part... 

I use the  pat that is shared on the first link... Should be another one? 

 

Thanks again 4 your help 

Link to comment
5 hours ago, Luis Belo said:

Thanks for you reply 👍

I think that's the problem... I don't understand that part... 

I use the  pat that is shared on the first link... Should be another one? 

 

Thanks again 4 your help 

No, you should download one of the .pat in the original post from official repo or my direct mega link.

 

It should works with this.

 

Also make sure to follow steps correctly, if you not set correctly VDISK2 with controller="1" option before start tiny red core first time when you make the build it will not recognize the second vdisk and it will make the build wrongly.

Link to comment
  • 3 weeks later...
3 minutes ago, casperse said:

Does anyone know how to set the serial in the configuration?
(I don't want to generate one, I want to use the serial I have for my old Synology NAS, replacing the one I have)

Hi,

 

You can edit your user_config.json and change the MAC here before make the build instead of generate it randomly.

Link to comment

Ok I think I got this but how to selct which platform? (Is it your native Unraid platform? or the HW used on the Synology?)
Version : 0.8.0.3
--------------------------------------------------------------------------------                                                                                             --------
Available platform versions:
--------------------------------------------------------------------------------                                                                                             --------
apollolake-7.0-41890
apollolake-7.0.1-42218
apollolake-7.0.1-42218-JUN
apollolake-7.1.0-42621
apollolake-7.1.0-42661
broadwell-7.0.1-42218
broadwell-7.0.1-42218-JUN
broadwell-7.1.0-42621
broadwell-7.1.0-42661
broadwellnk-7.0.1-42218
broadwellnk-7.0.1-42218-JUN
broadwellnk-7.1.0-42621
broadwellnk-7.1.0-42661
bromolow-7.0.1-42218
bromolow-7.0.1-42218-JUN
bromolow-7.1.0-42621
bromolow-7.1.0-42661
denverton-7.0.1-42218
denverton-7.0.1-42218-JUN
denverton-7.1.0-42621
denverton-7.1.0-42661
geminilake-7.0.1-42218
geminilake-7.0.1-42218-JUN
geminilake-7.1.0-42621
geminilake-7.1.0-42661
v1000-7.0.1-42218
v1000-7.0.1-42218-JUN
v1000-7.1.0-42621
v1000-7.1.0-42661
--------------------------------------------------------------------------------          

Sorry I have tried to google this but information is not that avaible on this topic 🙂

Link to comment
Posted (edited)
On 7/13/2022 at 2:37 PM, casperse said:

Ok I think I got this but how to selct which platform? (Is it your native Unraid platform? or the HW used on the Synology?)
Version : 0.8.0.3
--------------------------------------------------------------------------------                                                                                             --------
Available platform versions:
--------------------------------------------------------------------------------                                                                                             --------
apollolake-7.0-41890
apollolake-7.0.1-42218
apollolake-7.0.1-42218-JUN
apollolake-7.1.0-42621
apollolake-7.1.0-42661
broadwell-7.0.1-42218
broadwell-7.0.1-42218-JUN
broadwell-7.1.0-42621
broadwell-7.1.0-42661
broadwellnk-7.0.1-42218
broadwellnk-7.0.1-42218-JUN
broadwellnk-7.1.0-42621
broadwellnk-7.1.0-42661
bromolow-7.0.1-42218
bromolow-7.0.1-42218-JUN
bromolow-7.1.0-42621
bromolow-7.1.0-42661
denverton-7.0.1-42218
denverton-7.0.1-42218-JUN
denverton-7.1.0-42621
denverton-7.1.0-42661
geminilake-7.0.1-42218
geminilake-7.0.1-42218-JUN
geminilake-7.1.0-42621
geminilake-7.1.0-42661
v1000-7.0.1-42218
v1000-7.0.1-42218-JUN
v1000-7.1.0-42621
v1000-7.1.0-42661
--------------------------------------------------------------------------------          

Sorry I have tried to google this but information is not that avaible on this topic 🙂

Hi,

 

You have to select the hardware according to your pc (unraid hardware).

 

which processor do you have?

 

 

Edited by viktortras
Link to comment
On 6/25/2022 at 4:01 PM, Luis Belo said:

Problem solved with the DS3622xs+.
On surveilance stantion anyone have problems wit the sound? It ask to login on Synology account... but i dont have it :/

this is because of licencing and stuff from synology , and this does not work on xpenology so even if you have an account it wont login 

Link to comment
  • 4 weeks later...
Posted (edited)
1 hour ago, maxse said:

Help pleease.

I so I just go to Step 2. And I just see a black screen window doesn't seem to load.

Did I download the wrong redpill extension. I did not get the ueii file, and I have to remove the extension.gz which it came downlaoded from github. Do I need to get the uefi version? Everything else is the same and I even changedd controller=1

Screen Shot 2022-08-11 at 8.24.07 PM.png

Hi,

 

You have to download .img version for redpill.

 

Then follow steps.

 

Redpill OS have to be loaded, not the screenshot you attached.

 

Edited by viktortras
Link to comment
54 minutes ago, viktortras said:

Hi,

 

You have to download .img version for redpill.

 

Then follow steps.

 

Redpill OS have to be loaded, not the screenshot you attached.

 

wow, i didnt realize that it was actually a compressed file, I thought github just adds that extension. I'm doing this all remotely through VPN, but now got redpill loaded! On to the next step...

 

Can you tell me which version I should get for my processor? I saw you answered someone that some config has to be processor dependant...

 

Also, if I want to pass through entire individual drives, do I just keep adding, add virtual disk, and simply select the entire hard drive as vdisk? I noticed that drives that I don't have in the array don't even show up thouugh

Edited by maxse
Link to comment

oh boy, I'm on hour 4.

 

So I found a youtube video and tutorial on how to get it working on vmware, and tried to follow along

 

I did the following

Model DS3622xs+

./rploader.sh satamap broadwellnk-7.0.1-42218

 

I downlaoded the .pat DSM_DS3622xs+_42661.pat

 

 

synology finder, found it, I got the countdown from 10 minutes... Then it just goes all the way down to zero, and says something is wrong and I reconnect again, and it just does it again. Can you please help me with this step? I'm so close!

Link to comment
1 hour ago, maxse said:

oh boy, I'm on hour 4.

 

So I found a youtube video and tutorial on how to get it working on vmware, and tried to follow along

 

I did the following

Model DS3622xs+

./rploader.sh satamap broadwellnk-7.0.1-42218

 

I downlaoded the .pat DSM_DS3622xs+_42661.pat

 

 

synology finder, found it, I got the countdown from 10 minutes... Then it just goes all the way down to zero, and says something is wrong and I reconnect again, and it just does it again. Can you please help me with this step? I'm so close!

What error are you receiving?

 

It seems DSM not finding your disks.

 

Did you set controller to 1 before start redpill?? 

Link to comment
Posted (edited)
9 hours ago, maxse said:

that worked! I put them all on controller 1. Thanks!

 

 

Okay so weird. I closed the browser and forgot the ip. when in went to finds.synology.com, it wanted me to connect to it again and install everything again! But when i went to that direct IP with port 5000 it logged me right into DSM! Is this normal?

 

Now just the last two issues here:

 looks like I messed something up because I am on 7.0 only. DSM_DS3622xs+_42218.pat

Is this just a matter of me finding the correct PAT. Any suggestions on what to do? at this point?

No, I think this is not normal but look into url, maybe is going to yourip:5000/wizard or something to set up it again. Also try to use other browser and clean cache and/or cookies from your main browser.

 

When all setup is done find.synology.com must find your server and go directly to the login page. 

 

Yes you installed a .pat from 7.0 not from 7.1 but it is easy to update.

Edited by viktortras
Link to comment
  • 3 weeks later...
  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.