Error on file syslog about smb with Active Directory

Recommended Posts



I've get this error on file syslog and fill my partition /var/log at 100%:



smbd[30557]: [2022/06/24 10:58:08.966736,  0] ../../source3/smbd/smb2_server.c:656(smb2_validate_sequence_number)
smbd[30557]:   smb2_validate_sequence_number: smb2_validate_sequence_number: bad message_id 0 (sequence id 0) (granted = 1, low = 1, range = 1)

My config of samba is:


server min protocol = SMB3
client ipc min protocol = SMB3
client signing = mandatory
server signing = mandatory
client ipc signing = mandatory
client NTLMv2 auth = yes
smb encrypt = required
restrict anonymous = 2
null passwords = No
raw NTLMv2 auth = no

I've changed configuration samba to:


server min protocol = SMB3
client ipc min protocol = SMB3

But the problem persist.


Any idea about this problem and how resolve this?


Thank you for help

Edited by ricain59
Link to comment
5 hours ago, Frank1940 said:

Did you google these two error messages?


What clients are attempting to connect to this server?


Can you get a diagnostics file to post up in a new post?

Yes i have google it but without success.


The error is present with or without client, is very strange.


4 hours ago, trurl said:

How are you making this change?

Stop array - make changes about samba configuration on settings -> smb and then start array again.


On my samba, i use users login from AD maybe help.

Link to comment
On 6/24/2022 at 12:53 PM, ricain59 said:

On my samba, i use users login from AD maybe help


I assume you must be talking about Microsoft Active Directory.  If you really require the usage of this feature, you will probably have to get assistance from who is an expert in setting MS Domain Controllers and Active Domain.  (I suspect that there are not many Unraid users who fall into this category.  And those who are are probably not very active on this forum.) 


You might want to edit your first post and change the  subject/topic of this thread to indicate your use of AD to see if that brings some help. 


I would also be questioning why you are forcing the use of SMB3 but I assume that you would already know why you have to use only that protocol...

Link to comment
  • ricain59 changed the title to Error on file syslog about smb with Active Directory



Thank you for your link. I've tried but without success. After the changes, users from AD not login on folders, permission denied.


Now i've tried without configuration on samba via webui and the error stopped on log for samba. But the users on AD sometimes acess and sometimes not. 

I report on the thread of your link.


Thank you for your help.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.