about:blank#blocked for all WebUI links


Recommended Posts

Hi all,

 

Recently I've started noticing that all of my Docker WebUI links open a new window to about:blank#blocked rather than their destination. I've checked and the links themselves seem fine (e.g. http://[IP]:[PORT:14002]/) and I've also tested with no extensions and no AV other than Windows Defender. I'm wondering if this is perhaps an upcoming security change in Chrome Dev? (I'm running Chrome Dev Version 105.0.5148.2 (Official Build) dev (64-bit))

 

Has anyone else observed this behavior?

Link to comment
1 hour ago, jmztaylor said:

I just installed the same Chrome Dev version and I am not seeing this behavior.  Everything is working as intended.  See if the problem persists in incognito mode.

Hmm, that's so strange. I tried earlier in Incognito and I just tried as well in --disable-extensions mode (which completely disables extensions) and it still does the about:blank#blocked thing.

 

45 minutes ago, Squid said:

Does Chrome tell you that "popup blocked"?

It doesn't seem to, and I manually enabled popups as well because I heard that might be an issue.

 

image.png.e38086279407b32d7d23ff4507fcbf7b.png

Link to comment
Posted (edited)
1 hour ago, Squid said:

That's wrong.

 

Can you post the relevant xml from /config/plugins/dockerMan/templates-user on the flash drive

<?xml version="1.0"?>
<Container version="2">
  <Name>Storj</Name>
  <Repository>storjlabs/storagenode:beta</Repository>
  <Registry/>
  <Network>bridge</Network>
  <MyIP/>
  <Shell>sh</Shell>
  <Privileged>false</Privileged>
  <Support/>
  <Project>https://documentation.storj.io/</Project>
  <Overview>This is official Storj V3 node client. To participate you must first have to have an authorization token, to get the Authentication Token go to: https://storj.io/sign-up-farmer&#xD;
&#xD;
This template is for running the Docker application only, please follow Storj Lab directions to generate your Node Identity files  -  this is in https://documentation.storj.io/dependencies/identity&#xD;
&#xD;
&#xD;
&#xD;
!!! IMPORTANT !!!&#xD;
&#xD;
Two path need to be passed to the docker. Currently Storj requires that the path are mounted using --mount rather than -v. Please add the path for the storage and identity folders to the extra parameters in the following format (extra parameters can be accessed through the advanced view toggle):&#xD;
&#xD;
--mount type=bind,source="/mnt/user/appdata//storj/identity/storagenode/",destination=/app/identity  --mount type=bind,source="/mnt/user//",destination=/app/config&#xD;
&#xD;
During the first run the -e SETUP=true argument needs to be added to this string to create the required folders. After the first run when container is created restart it and delete the -e SETUP=true argument.&#xD;
&#xD;
For additional information please visit the support thread: https://forums.unraid.net/topic/88430-support-storj-v3-docker/&#xD;
</Overview>
  <Category>Cloud: Crypto: Other: Status:Stable</Category>
  <WebUI>http://[IP]:[PORT:14002]/</WebUI>
  <TemplateURL>https://raw.githubusercontent.com/dalekseevs/Unraid-Docker-Templates/master/stroragenode-v3.xml</TemplateURL>
  <Icon>https://raw.githubusercontent.com/dalekseevs/Unraid-Docker-Templates/master/logos/storj-logo-png-transparent.png</Icon>
  <ExtraParams/>
  <PostArgs/>
  <CPUset/>
  <DateInstalled>1654110094</DateInstalled>
  <DonateText/>
  <DonateLink/>
  <Requires/>
  <Config Name="TCP Port" Target="28967" Default="28967" Mode="tcp" Description="Default Storj V3 node port." Type="Port" Display="always" Required="true" Mask="false">57658</Config>
  <Config Name="Dashboard Port" Target="14002" Default="14002" Mode="tcp" Description="The port to access web dashboard" Type="Port" Display="always" Required="true" Mask="false">14002</Config>
  <Config Name="Email address" Target="EMAIL" Default="" Mode="" Description="Email address used to sign Storj V3 node. (recommended)" Type="Variable" Display="always" Required="true" Mask="false"></Config>
  <Config Name="Wallet Address" Target="WALLET" Default="" Mode="" Description="Your Payout address here." Type="Variable" Display="always" Required="true" Mask="false"></Config>
  <Config Name="Allocated Storage" Target="STORAGE" Default="2TB" Mode="" Description="A minimum of 500GB with no maximum of available space per node.  Preferred minimum of 8TB and maximum of 24TB of available space per node." Type="Variable" Display="always" Required="true" Mask="false">32TB</Config>
  <Config Name="Identity directory" Target="/app/identity" Default="" Mode="rw" Description="" Type="Path" Display="always" Required="false" Mask="false">/mnt/user/appdata/Storj/identity/storagenode/</Config>
  <Config Name="Storage location" Target="/app/config" Default="" Mode="rw" Description="Storj database location" Type="Path" Display="always" Required="false" Mask="false">/mnt/user/Storj/</Config>
  <Config Name="Internet Address" Target="ADDRESS" Default="domain.ddns.net:28967" Mode="" Description="Your ISP IP address:28967 (static IP) or dynamic DNS address here." Type="Variable" Display="always" Required="true" Mask="false"></Config>
  <Config Name="TCP Port" Target="28967" Default="28967" Mode="udp" Description="QUIC Port" Type="Port" Display="always" Required="true" Mask="false">57658</Config>
  <Config Name="Bandwidth" Target="BANDWIDTH" Default="" Mode="" Description="(OPTIONAL) Amount of  bandwidth used, per month, to Storj network.  According to Storj documentation, minimum is 2TB, recommended is 16+ TB, preferred is unlimited (e.g. 100000TB)." Type="Variable" Display="advanced" Required="false" Mask="false">45TB</Config>
</Container>

I removed two personal values

Edited by Alexstrasza
Link to comment
  • 2 weeks later...
  • 3 weeks later...

Also have this exact same issue - Doesn't happen with ALL containers, only some...

 

XML:
 

<?xml version="1.0"?>
<Container version="2">
  <Name>quizmaster</Name>
  <Repository>nymanjens/quizmaster</Repository>
  <Registry/>
  <Network>br0.10</Network>
  <MyIP>10.10.10.100</MyIP>
  <Shell>sh</Shell>
  <Privileged>true</Privileged>
  <Support/>
  <Project/>
  <Overview/>
  <Category/>
  <WebUI>http://[IP]:[PORT:9000]</WebUI>
  <TemplateURL/>
  <Icon>https://mensa.org.za/wp-content/uploads/2021/03/Quiz1.jpg</Icon>
  <ExtraParams/>
  <PostArgs>"bin/server"</PostArgs>
  <CPUset/>
  <DateInstalled>1659606132</DateInstalled>
  <DonateText/>
  <DonateLink/>
  <Requires/>
  <Config Name="Config" Target="/app/conf/quiz" Default="" Mode="rw" Description="" Type="Path" Display="always" Required="false" Mask="false">/mnt/user/appdata/quizmaster/quiz/</Config>
  <Config Name="application" Target="/app/conf/application.conf" Default="" Mode="rw" Description="" Type="Path" Display="always" Required="false" Mask="false">/mnt/user/appdata/quizmaster/application.conf</Config>
</Container>

  

image.png

Edited by valiente
Link to comment
  • 4 weeks later...
4 hours ago, DBJordan said:

Try explicitly specifying the WebUI.

 

Change

<WebUI>http://[IP]:[PORT:9000]</WebUI>

to

<WebUI>http://192.168.198.12:9000</WebUI>

 

I just tried explicitly specifying in docker edit settings and it works fine now. Not sure what caused it to start this behavior though.

Link to comment
7 hours ago, cNeCh said:

I have the same problem with my Plex container and only my plex container. How did you fix the problem?

 

Go to the Plex container, edit settings, switch to advanced view by cliking "basic view" on the top right.

Now find the "WebUI" entry and change it to the actual ip and port you use for Plex. Mine is below as an example:

image.png.85f9ed9bbfbab6e8bb929e40981781b8.png

Edited by TopherHax
Link to comment

I had the issue that the links were returning aboutblank#blocked after I had moved containers onto a VPN network and removed all port references.  It looks like it might be because the system is unable to populate one of the dynamic fields in the webui template, either IP or PORT and so just spits out a URL that doesn't work.  Look to see you have the ports allocated to the containers and there may be something about it being unable to find the IP address of the system?  

As other people have mentioned, the workaround seems to be to hardcode the web UI links, e.g http://192.168.1.100:8080, this setting can be accessed from teh conainter edit page under the "advanced" settings (activated by the advanced button in the top right of the page).

As an extra note, I had issues simply adding 192.168.1.100 or just a port number in the web UI field, it would always add a / between the IP address and whatever was put after.  It seems to resolve this you either need to use the default [IP]:[PORT] template or use a full http:// url

Edited by Dizzienoo
Link to comment
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.