Log: PAM unable to dlopen


Go to solution Solved by dlandon,

Recommended Posts

Jul 11 15:24:00 NASty atd[18576]: PAM unable to dlopen(/lib64/security/pam_unix.so): /lib64/libc.so.6: version `GLIBC_2.34' not found (required by /lib64/libresolv.so.2)
Jul 11 15:24:00 NASty atd[18576]: PAM adding faulty module: /lib64/security/pam_unix.so
Jul 11 15:24:00 NASty atd[18576]: Module is unknown

 

Ich erhalte im Log sehr oft den oben genannten Eintrag. Was hat das zu bedeuten und wie kann ich das beheben? Reboot hat nicht geholfen.

 

Gruß

Jan

Link to comment
3 minutes ago, Johnny4233 said:
Jul 11 15:24:00 NASty atd[18576]: PAM unable to dlopen(/lib64/security/pam_unix.so): /lib64/libc.so.6: version `GLIBC_2.34' not found (required by /lib64/libresolv.so.2)
Jul 11 15:24:00 NASty atd[18576]: PAM adding faulty module: /lib64/security/pam_unix.so
Jul 11 15:24:00 NASty atd[18576]: Module is unknown

 

Ich erhalte im Log sehr oft den oben genannten Eintrag. Was hat das zu bedeuten und wie kann ich das beheben? Reboot hat nicht geholfen.

 

Gruß

Jan

This is happening because the version og glibc is 2.33 in Unraid 6.10.  You can install UD Preclear that will update the glibc package or wait for 6.11-rc1.

Link to comment
Posted (edited)
5 minutes ago, dlandon said:

You can install UD Preclear that will update the glibc package

 

Did that allready.

 

Removed and installed the plugin again. the message apperas again.

 

So i think this message is not so terrible? i need to wait for Unraid 6.11-rc1?

Edited by Johnny4233
Link to comment

The problem is that a plugin you are using is depending on the glibc library installed in Unraid when it starts.  a Daemon?  When UD Preclear updates the glibc package, the daemon is losing access to the library it needs and then fails.

 

You have two options at this point:

  • Don't install the UD Preclear plugin.
  • Upgrde to Unraid 6.11-rc1 that will be available soon.
Link to comment
6 hours ago, Johnny4233 said:

So i deleted the UD Preclear plugin. Reboot... Error does not come up and my userscript runs fine. Thank you.

What is the user scrpt that is causing this issue?

 

6 hours ago, Johnny4233 said:

I hope Unraid 6.11-rc1 fixes this

I expect it will because it has glibc 2.35 already installed and UD Preclear won't upgrade it.

Link to comment
5 minutes ago, dlandon said:

What is the user scrpt that is causing this issue

No I mean, any userscript did not run in background… in log it shows that it will execute it, but then the error message above appears and the script does not run. It’s a simple mounting script for unassigned devices… look at my other thread here. 

Link to comment
15 minutes ago, Johnny4233 said:

No I mean, any userscript did not run in background… in log it shows that it will execute it, but then the error message above appears and the script does not run. It’s a simple mounting script for unassigned devices… look at my other thread here. 

OK.  I see it now.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.