6.9.2 - Wit's End Connecting to CA Server (Just Wanna Preclear)


Go to solution Solved by dlandon,

Recommended Posts

I've been a "set and forget" unraid user for years, so the "new" (I totally know it's not new, but still) method of running stuff on top of vanilla unraid through Community Applications is something I haven't messed with much at all... until this week, at which point I'm beating my head against the wall trying to get it to connect through the internet.

 

For some reason, my preclear option disappeared during an update between February or March of this year and now. I'd previously been using the gfjardim plugin, and clicking preclear through the main unraid array menu.

 

Now, I'm trying to "get preclear back" as an option (days are ticking away on purchase warranties), and it's looking like the only way to do that these days is through the Community Apps' Preclear for Unassigned Devices app. So far, so good.

 

I cannot for the life of me get Community Apps to connect. All the servers (github, amazonaws) listed in the main tech support page for Community Apps show zero issues, so it's definitely a problem on my end. I've configured network settings to include a pair of OpenDNS servers as suggested in these forums. Not using a proxy or PiHole. Diagnostics are attached.

 

Honestly, if there's just a backdoor way of me getting the ability to preclear my disks again without needing to connect to Community Apps, I'd actually just take that route, but if the only way to get preclearing again is to get Community Apps connecting, I'd greatly appreciate any help anyone can give me in making that happen before my preclear schedule starts bumping up against return deadlines!

 

Thanks in advance, beyond words!

tower3-diagnostics-20220722-0537.zip

Link to comment

I would suggest posting in the CA support thread.

 

Also, fairly sure the UD preclear plugin requires unRAID 6.10+. Just to be sure you’re aware, preclears are only really necessary for testing drives. UnRAID can clear a new drive while the array is online so there’s no penalty anymore for allowing the OS to clear the drive.

Link to comment
Posted (edited)

Thanks, wgstarks! I'll post in that thread (was posting here versus there following the instructions in the link on the CA connection error page, actually).

 

I'm 100% just using preclear for stress testing new drives, but timing-wise, I'm getting extremely close to just throwing these particular new drives at one of my windows machines and running badblocks or whatever the best-practice software these days is instead.  Spending like a decade using preclear as my "don't need to worry as much about RMA'ing this drive in the near future versus just returning it to a retailer in the returns window" insurance policy became a mental security blanket, though, so I'd love to get the functionality back in my unraid box if at all possible.

 

It's just nuts that I'm at an unraid version level that can't manually install the old plugin (just a hair too new), I can't connect through community applications to automatically install the new app, and I'm getting errors trying to install even the binhex-preclear docker container... seriously about to just walk away for a bit for sanity's sake.

 

Hopefully this post (and the one I'm about to make in the CA support thread) lead to some ideas out of this maze! Thank you again for the response.

Edited by wheel
forgot a word
Link to comment

Yeah, and vaguely remember it working for stuff when I did... but I want to say that was towards the beginning of the pandemic? I'm very much a vanilla-unraid user. I don't think I've clicked the Apps button at all since I first set it up way back when.

Link to comment

Nope; they'd get lost in my flood of emails. I run dual parity, check parity monthly, keep an eye on my dashboard(s) multiple times a day, and could easily replace almost everything I have in the event of a total catastrophic data loss from missing notifications.

 

I'm probably not the standard unraid user, but unraid has worked beautifully for my needs for about a decade now. "Easy Preclear" stress tests have absolutely been a part of that, for me.

Link to comment

Sorry, poor phrasing on my part - I haven't clicked on the Apps tab since I first set it up (I think back when I upgraded to the 6.9 series, a couple years back).

 

I definitely haven't tried installing anything (apps or otherwise) since the version bump, until now (trying to install this new "preclear for unassigned devices" service). There's a chance I've been having issues connecting to the Community Apps system for the entire couple of years I've had it set up - I just wouldn't know because I haven't been clicking on the tab to try using it for anything (no need on my part). I also don't see myself using it again for anything once I get preclear working again, based on my past decade or so of unraid use.

 

Again, apologies for not phrasing that more clearly! Rough morning.

Link to comment

I'm definitely not explaining my situation properly. I use my server daily, access it daily, and am constantly on top of drive-replacement-related issues. That's kind of all I use unraid for: a big, dumb-terminal NAS box for file storage and access. WORM stuff.

 

If the default was to keep those boxes completely "off the internet", I would probably never take extra steps to get them communicating with the outside world, if only for security purposes - I just get no personal benefit from (what absolutely seem like amazing and useful) extra features that unraid now offers which it didn't a decade or so ago when I started using it.

 

By no means am I trying to cast shade at any of these features, if anyone's taking my posts the wrong way; I'm just trying to get my stress test functionality back for new disks while changing as little of my comfortable-for-10ish-years setup as possible.

 

Seriously thankful for all the help so far!

Link to comment

Yep; screen gives the wiggly-line "loading" animation for a second, then always goes to "Download of appfeed failed. Community Applications requires your server to have internet access. The most common cause of this failure is a failure to resolve DNS addresses. You can try..."

 

...and then I've gone through all the things to try, using unraid Network Settings, router settings, changing one thing at a time in each as a troubleshooting method... nada. Checked forum posts for others getting this error message, and tried some of their workarounds. Still the same error message. All three servers listed in the forum as handling the appfeed are currently up and reporting no connection errors.

 

I'm totally at a loss and out of ideas (other than giving up and messing with Crystal Disk or whatever, which wouldn't be the end of the world... but damn, it'd be nice to have a preclear option back in my comfort zone, if possible).

Link to comment

Since there's nothing particularly obvious about what's going on, within Apps go to Settings, enable save debugging information.

 

Apply and Done then back in apps when the message appears again, hit "Debugging" a zip file gets downloaded.  Reply back with it here

Link to comment

Your system / ISP / whatever is blocking github downloads along with amazonaws (CA's backup server) 

 

Uninstalling NerdPack via plugins *might* help.  Otherwise, uninstall Statistics Sender from plugins and then from Plugins, Install Plugin paste this URL in for preclear.  However, I'd be surprised if it works

 

https://github.com/dlandon/unassigned.devices/raw/master/unassigned.devices.preclear.plg

 

Link to comment
Posted (edited)

Yeah, I tried everything listed above, and no luck. System still can't reach githubusercontent by ping (raw still OK), and the manual plugin installation attempt gives me an SSL verification failure error.

 

Any ideas for next steps to find the cause of the github / amazonaws blockage on my end? Or if it's ISP-based, does this mean I basically need to just accept unraid as a deprecated OS for my living situation, at least until I move to a new home with a new potential ISP?

 

Seriously, any ideas at all will be incredibly appreciated! Thanks to everyone for the help so far.

Edited by wheel
Removed defeatist paragraph. Got to be a way through this headache!
Link to comment
Posted (edited)

Nope; neither. ISP modem/wifi combo (wifi disabled) into a Netgear R6 series wifi router, both with vanilla default settings. Direct ethernet cable for this particular box. Haven't modified anything in that chain at any point in the better part of the past 5 years.

Edited by wheel
More details
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.