At random reboots or updates, drives given new serial numbers/names confusing Unraid


Recommended Posts

Howdy folks, this has happened to me a few times, never the cache drives though so now im a little more concerned and want to be careful. ive noticed on rare occasions, typically after an update of some kind i will boot up unraid and my disks will not be properly assigned to my array or my unassigned device will be missing, but in its place a new drive will display. it will share a common name but have what looks like a new serial number attached to its name. i managed to rename my plex SSD partition mount point to match what my docker was configured to use and that fixed that issue. i then pointed my VM to its "new device" to attached to its hard drive file and now its working but how do i recover the 2 cache disks? starting the array they become disabled and emulated.

 

image.png.f3af76e6e55ddc876e6677f1d803fa0d.png

image.thumb.png.f5b347bb29021308e3c62c07c11ad9b8.png

darktower-diagnostics-20220805-2026.zip

Link to comment
03:00.0 Serial Attached SCSI controller [0107]: Hewlett-Packard Company Smart Array Gen9 Controllers [103c:3239] (rev 01)
	Subsystem: Hewlett-Packard Company H240 [103c:21c7]
	Kernel driver in use: hpsa
	Kernel modules: hpsa
04:00.0 Serial Attached SCSI controller [0107]: Hewlett-Packard Company Smart Array Gen9 Controllers [103c:3239] (rev 01)
	Subsystem: Hewlett-Packard Company H240 [103c:21c7]
	Kernel driver in use: hpsa
	Kernel modules: hpsa

Are these RAID controllers? Inconsistent disk identification is one of many reasons RAID controllers are NOT recommended.

 

12 minutes ago, Clayton said:

starting the array they become disabled and emulated.

They are not emulated because the are not part of the parity array.

 

 

Link to comment

they might be raid controllers but i have them in JBOD mode. My LSI controller died on me a year or so ago and these were half the cost. they have worked great minus this issue which did seem to come up only after they were installed. you might be onto something about the cause being the controller card.

 

When i hover over the device, it states its disabled and contents emulated.

image.png.f5b9622debbea07aca5938fadb355c7d.png

 

would you have any suggestion on how i might be able to recover the cache drives?

Link to comment
20 minutes ago, trurl said:

Did the drive identifications fix themselves so that Unraid recognized them again?

in the past i was able to fix the unassigned or raid disk by moving on with the new identification but i haven't done anything for the cache drives this time around. im hoping there is something that can be done to re-initiate or something i can do to rebuild them. not sure i you have any suggestions? i dont have a way to change the drive identification that i know of. this happens at random or during an update of some kind. ive rebooted a few times since i started this thread. i confirmed the card is running in HBA mode. 

Link to comment
Posted (edited)
38 minutes ago, trurl said:

New Config?

For example it was an unassigned drive. I renamed a mount partition and or repointed my docker or vm references. The drive and it's data is intact, just need to repoint to it. Idk about cache drives. Since my dockers and vms are running right now, does that mean my cache drive can be restored to the pool?

Edited by Clayton
Link to comment
Posted (edited)
2 hours ago, JorgeB said:

Problem is still controller related.

its an HP H240 card running in HBA mode, a common card i see mentioned in the unraid forums but most mentions i have found is drives not being seen. I think its due to running older firmware. ill look into possibly replacing the card if that's the cause of my instability.

 

my main focus at this point is how i can recover the cache drives. they look to be in an emulation state so i would assume that means i can recover them. 

Edited by Clayton
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.