6.10.3 Unable to get GPU Passthrough to VMs

Recommended Posts



I have gone through many guides and many different versions of things with no luck. I am hoping that someone can help me figure out what is going on. I am able to get a VM to boot up and install the OS with VNC but I want to do an all-in-one setup where my gaming pc is the unraid server. I am able to get all of the usbs and disks that I need to show up but my 3080 is not displaying anything from the VMs. Any help is appreciated as I want to use unraid but I cannot get this to work.

Link to comment

This guide gives a general idea of all the stuff I have tried.


I am using a 3900x, MSI Gaming z Trio LHR 3080 (have also tried a 6800), Aorus B550 Master, 64 GB of ram, 2x 1TB nvme drives.


Quick summary.


Have tried both i440fx & Q35 every version from v4 to v6

Have dumped my vbios for my gpu so I can choose it within the VM config

Have tried both unbinding and binding my gpu to vfio

Have tried both PCI override off and downstream, multi, both

Have tried manually blocking unraid from using the gpu via "kernel /bzimage
append pcie_acs_override=downstream,multifunction isolcpus=1-11,13-23 vfio-pci.ids=10de:2216,10de:1aef initrd=/bzroot"


I am really at a loss with this. Any help is appreciated.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.