Unraid 6.10.3 restarts server

Recommended Posts

Hi there,


My name is Artur. I'm setting up a small business network and trying out the Unraid trial before buying an unlimited license.


The problem I ran into is that my server restarts under Unraid OS.
The server's stability was checked by running Windows 10 without any issues.

Unfortunately, it restarts or resets under Unraid.

How often? I didn't manage to have longer runtime windows than 2hrs without a restart/reset, except when was pairing or checking disks.
I was successful pairing two 4TB disks for the 3rd time. It took 8hrs.

Unraid 6.10.3 on a flash drive Kingston Data Traveller 3.0 32GB

AM4 Ryzen 5 1600 (3.2-3.6GHz 6 cores 12 threads)
Gigabyte USD B450 Aorus PRO Rev 1.0 Bios F63a (17/02/2022)
1x8GB Corsair LPX 2400MHz CL16 DDR4 1.2V
Corsair VS650 650W
NVM Samsung M.2 960 EVO 250GB - Unassigned in Unraid, holds Windows 10.

Parity disk: #1 HGST HDN724040ALE640 4TB
Pool disks:
paired: #2 HGST HDN724040ALE640 4TB
2x Samsung 870 EVO 1TB

The main problem is that computer restarts when running Unraid, which does not happen with Windows 10.
This is a real blocker for me.
There are a couple of other issues, perhaps related to WebGUI. This doesn't matter much since I'm using the suggested MyServers plugin. 
The main issue with WebGUI is that it doesn't even boot anymore.

Here is syslog. It doesn't capture all the activity, so I am not sure if anyone can read what causes restarts.

Video of booting;

Attached to this post you will find settings and booting records.

Any suggestion what can cause it, is appreciated.




Link to comment
On 8/17/2022 at 1:50 AM, prostuff1 said:

2 things to check since this is a Ryzen system:

1. Disable global c-states in BIOS

2. If you have sleep enabled for the system disable that.

Thank you!

I ensured that C-States are disabled (seems like resets defaulted BIOS and turned C-Stated back on) and no restarts since.
Fingers crossed.

However I ran into another issue and decided to start everything all over with a new pendrive.
Despite the computer having internet connection working. I couldn't get connection on my server (myserver worked) and start an array.
Also noticed that it takes a few minutes to establish internet connection in the first place. Which was instant before.

Here is captured what I saw;




Is there a limitation about how many Unraid instances on a pendrive is allowed, using myserver and an online account, when using trial version?
I can't get any connection with the Unraid now. Not even via myserver.

Edited by Digital Shamans
Adding more info.
Link to comment

On the new instance of Unraid things work well. I can't login to webGUI, so I don't use it and control it via myservers.

I try to figure out how should I configure my drives.
Having two 4TB HDDs, two 1TB SSDs (and another M.2 SSD for cache coming soon), one of each (HDD and SSD) I would be used for parity.
This may be called dual parity.
I wonder if I shouldn't use one of the 1TB SSDs as second parity drive, to effectively have 5TB and control what goes on which physical drive via shares.

How one can move a drive from disk to parity without having problem of missing drive?




Edited by Digital Shamans
Link to comment
2 hours ago, Digital Shamans said:

I wonder if I shouldn't use one of the 1TB SSDs as second parity drive, to effectively have 5TB and control what goes on which physical drive via shares.

This is not possible.    No parity drive can be smaller than the largest data drive.


it is normally recommended to NOT have SSDs in the main array as when configured there they cannot be trimmed which means their performance may degrade over time.  Depending on what you want to use the SSDs for you may be better having them in a (possibly redundant) pool external to the main array.   This is not atypical if they are going to be used with VMs or Docker containers.


it is probably worth getting to the bottom of why you cannot connect to your server locally.   Have you tried via it’s IP address?   Have you tried using http rather than https?

Link to comment

Thank You Itimpi for the reply.


It reassured me about putting 4TB HDD as the parity drive, the other 4TB HDD as a disk in array and remaining two SSDs in Raid1 in cache pool.


I dont know what caused connection issues.

Looked like possibly something on your side.

I could connect to the server in local network using myserver but there was no connection to the unraod server for my trial license to work.

It doesnt matter now as I have made a fresh Unraid on a new pendrive. The previous one stopped working.




Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.