Data disk disabled after parity swap


Recommended Posts

Disk 4 in my Unraid setup has a red cross and is disabled. According to the information in the Unraid dashboard, the disk is healthy although there were a lot of errors during parity rebuild.

Before doing anything I prefer to have input of the specialists in here :) 

 

In attachment the diagnostics report.

 

Optional question: My system is still in reiserfs. What are the steps to change it?

toschestation-diagnostics-20220824-1038.zip

Link to comment
Posted (edited)

I've shutdown the server and started it again. My guess is there are some problems with the sata cables and or sata connections on the motherboard as after starting the server another disk was also missing. Now I'm back with only disk 4 having a red cross. Unraid tells me now that disk 4 is unmountable. Do I run xfs_repair without -n first now?

 

 

toschestation-diagnostics-20220825-1049.zip

Edited by Starkiller
Link to comment

Emulated disk4 didn't mount because disk3 dropped offline:

 

Aug 25 01:41:22 ToscheStation kernel: ata10.00: failed to IDENTIFY (INIT_DEV_PARAMS failed, err_mask=0x80)
Aug 25 01:41:22 ToscheStation kernel: ata10.00: revalidation failed (errno=-5)
Aug 25 01:41:22 ToscheStation kernel: ata10.00: disabled

 

Check/replace cables, might also be a power related problem.

Link to comment
  • 3 weeks later...

After having checked the cables, the problem was still there and on top of all there was a power cut in our street. After that I rebooted the server but the problem with disk 4 being disabled was still there and on top of it disk 3 was missing.

As I've had problems in the past with SATA cables and SASLP controllers aren't recommended, I've replaced the motherboard, all sata cables and the controller card (I'm using an LSI 9207-8i now). The only thing that wasn't replaced is the PSU.

Right now I have disk 1 and 3 missing and disk 4 unassigned (disk 4 isn't even being detected as a device). What should I do now? I've read a lot about Tools -> New Config -> Retain current configuration: All -> Apply but I'm not sure if this is the way to go...

I also got the message stale configuration. Should I run a file check of the USB stick first?

I've also tried to run the diagnostics tool but this has been running for more than 30 minutes now without any luck to download the diagnostics. Is this caused by the stale configuration?

Link to comment
9 minutes ago, Starkiller said:

Right now I have disk 1 and 3 missing and disk 4 unassigned (disk 4 isn't even being detected as a device).

With so many missing disk there's not much you can do, are the disks being detected by the HBA BIOS? Assuming there's one, if not connect them to the onboard SATA and see if they are detect by the board BIOS.

 

Also see if you can get the syslog at least:

 

cp /var/log/syslog /boot/syslog.txt

 

then attache here.

Link to comment

Just now seeing this thread since it was weeks old before it was revived. Just a few comments that haven't been made.

 

On 8/24/2022 at 4:45 AM, Starkiller said:

system is still in reiserfs

On 8/25/2022 at 4:55 AM, Starkiller said:

run xfs_repair without -n

These 2 do not belong together.

 

1 hour ago, Starkiller said:

there was a power cut in our street.

Get an UPS

Link to comment

HBA has a BOS installed, so check if the disks are detected there, if not they also won't be detected by Unraid, swap cables with another one to see if it's really a disk problem, note that some disks won't power up if there's 3.3v SATA connected, in doubt use a Molex to SATA adapter to test.

Link to comment
4 hours ago, JorgeB said:

HBA has a BOS installed, so check if the disks are detected there, if not they also won't be detected by Unraid, swap cables with another one to see if it's really a disk problem, note that some disks won't power up if there's 3.3v SATA connected, in doubt use a Molex to SATA adapter to test.

 

1st try: New SAS > SATA cable -> detected only 1 disk (my parity disk)

2nd try: Old SAS > SATA cable + two 1 MOLEX > 2 SATA power cables -> detected 3 disks (parity disk, disk 1 and disk 3)

After the 2nd try, I rebooted the server to see what Unraid would tell me. Parity disk can be seen as well as disk 3. Disk 1 is missing according to Unraid. Disk 4 is unassigned (which is logic as the controller card couldn't detect it as well).

So what should I do next? 

syslog.txt

Link to comment
9 minutes ago, JorgeB said:

 

Disk1 is still missing, you need it since there's already a disabled disk.

The controller card sees the parity disk, disk 1 and disk 3 but not the disabled disk.
Unraid sees only the parity disk and disk 3 and tells me that disk 1 is missing. For the disabled disk it says unassigned.

What's the reason why the controller card sees 3 disks and Unraid only 2?

Link to comment

@Starkiller

  

22 hours ago, JorgeB said:

Replace cables on those and post new diags.

 

After replacing cables, post a screenshot of Main - Array Devices with the array started along with those new diagnostics

 

Disk1 isn't missing but it is unmountable. Emulated / missing disk4 is mounted but empty. All other disks are very full (not recommended).

 

Is it expected that disk4 is empty? Did you format it?

Link to comment
On 9/16/2022 at 4:08 PM, JorgeB said:

There are what look like power/connection problems on disk1 and another disk not being detected, maybe the disabled disk? Replace cables on those and post new diags.

Ok so after replacing a lot of cables I can see all my disks again, even the disabled one. I haven't started the array as Unraid tells me that the disabled disk is a new device. 

Do I continue by starting the array and putting the diagnostics here? Or should I do something else?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.