My Servers dropping support for older versions of Unraid


Recommended Posts

Hi folks, shortly after Unraid 6.11 stable is released we plan to drop support for some of the older versions of Unraid. My Servers is pushing the evolution of Unraid, and we can't maintain backward compatibility with these older versions long term.

 

We recommend that you update to 6.10.3 now, or 6.11.0 once it is released. To upgrade:

 

 

My Servers will continue to support these versions of Unraid for now:

  • 6.10.0  (although we recommend 6.10.3 or higher)
  • 6.10.1  (although we recommend 6.10.3 or higher)
  • 6.10.2  (although we recommend 6.10.3 or higher)
  • 6.10.3
  • 6.11.x-any

 

Note that RC releases are not meant to be run long-term, so if you are still on one of the 6.10.x-rc[x] versions, you'll want to update as well.

 

My Servers will specifically be dropping support for these versions of Unraid in the coming weeks, please update before that happens:

  • 6.9.0
  • 6.9.0-rc[x]
  • 6.9.1
  • 6.9.2
  • 6.10.0-rc[x]
  • 6.10.1-rc[x]
  • 6.10.2-rc[x]

 

If you are unable to upgrade, please point me to your forum thread discussing the issue. 

 

Thanks!

  • Like 3
Link to comment

I'm on 6.9.2 I tried to upgrade but most of my docker containers that rely on SQLite DB's (Plex, Tautulli, others) all got corrupted so i had to downgrade to 6.9.2. (No more corruptions since)

 

I'd hope that "My Servers" would have provided support for at least the last stable release "6.9.2" before the big leap to "6.10.x" ? 

 

My forum thread is here

Edited by BigDanT
Link to comment
4 hours ago, stefan.tomko said:

If you read through the thread, you will find out that it doesn't work. I am using USB manager right now with 6.9.2 without any issues. As soon as you upgrade to 6.10.3, device can no longer be passed to VM that way. there are some "obscure" steps

https://community.home-assistant.io/t/solved-conbee-2-fails-to-connect-to-zha-ha-in-unraid-vm/431276/2

 

Thanks for highlighting this. We need to write a feature request that explains what needs to change, I've started the conversation here:
  https://forums.unraid.net/topic/122358-upgrade-from-692-610rc4-usb-in-vm-problem/page/2/#comment-1169506

 

 

If we can quickly get a clear understanding of what is needed I'll do what I can to make it happen. Probably not for 6.11.0 but hopefully shortly after that.

 

In the meantime, it sounds like multiple people have had success manually setting up these devices, so I'd ask you to try manually editing the XML in 6.10.3 or 6.11.0 and see if you can get it working. That will probably help you understand better what is needed in the feature request too

Link to comment
2 hours ago, BigDanT said:

I'm on 6.9.2 I tried to upgrade but most of my docker containers that rely on SQLite DB's (Plex, Tautulli, others) all got corrupted so i had to downgrade to 6.9.2. (No more corruptions since)

 

I'd hope that "My Servers" would have provided support for at least the last stable release "6.9.2" before the big leap to "6.10.x" ? 

 

My forum thread is here

 

Thanks for letting me know. What I can assure you is that there isn't a widespread problem running Plex on Unraid 6.10.x. It sounds like you downgraded before grabbing diagnostics so it is very difficult to speculate what the issue might have been.

 

6.11.0 is very near to a stable release, you are welcome to wait for that if you like. Since you had trouble with SQLite, I'd recommend that you backup those databases before your next upgrade, and if you do have issues be sure to grab a diagnostics.zip file (from Tools -> Diagnostics) and post in a new thread (not this one please) where you talk about your experience, how you are detecting the problem, etc.  Actually, it might be helpful to grab a diagnostics.zip file from 6.9.2 right before the upgrade as well, just in case we need to compare things.

 

Continuing to run 6.9.2 is not a good idea, it is almost 1.5 years old and it is missing many security updates. We'll give you at least a few weeks after releasing 6.11.0 before we prevent 6.9.x from connecting to My Servers.

Link to comment
On 9/16/2022 at 2:35 AM, ljm42 said:

 

Thanks for highlighting this. We need to write a feature request that explains what needs to change, I've started the conversation here:
  https://forums.unraid.net/topic/122358-upgrade-from-692-610rc4-usb-in-vm-problem/page/2/#comment-1169506

 

 

If we can quickly get a clear understanding of what is needed I'll do what I can to make it happen. Probably not for 6.11.0 but hopefully shortly after that.

 

In the meantime, it sounds like multiple people have had success manually setting up these devices, so I'd ask you to try manually editing the XML in 6.10.3 or 6.11.0 and see if you can get it working. That will probably help you understand better what is needed in the feature request too

I followed advice given by SimonF and (since I already use USB manager) used serial mode for the device, and changed the path in configuration accordingly. Now things work. I will attempt upgrade to 6.10.3 again soon.

I can't say what is needed to fix this. I believe this is impacting only this particular USB device. For the time being, as long as it works and nothing changes, I don't care if the name of the device is A or B :)

 

Update: I did upgrade to 6.10.3 successfully

Edited by stefan.tomko
Link to comment

Really happy someone brought up the above issue with the Conbee II. I'll have to circle back and attempt to make this correction as well, as this was the immediate hang-up I thought of when seeing that I needed to upgrade in the upcoming weeks. Hopefully that goes smoothly. 

 

As someone who's new to UnRaid and running 6.9.2, is there a recommended guide (maybe from SpaceInvaderOne?) which details how to go about the upgrade process? 

Link to comment
7 hours ago, ThatTallGuy21 said:

As someone who's new to UnRaid and running 6.9.2, is there a recommended guide (maybe from SpaceInvaderOne?) which details how to go about the upgrade process? 

 

There really isn't much to it. I updated the OP with more details.

Link to comment