Open Docker WebUI links in current URL, not IP

Recommended Posts

When connecting via a VPN, the IP is different than that of the local network. However, the Docker WebUI button uses the local network IP, which means it won't work.


To fix this problem, take the HTTP_HOST header of the current session and append the port to it to open the WebUI instead.


Some considerations:

- Maybe the connection should be downgraded from HTTPS to HTTP in case the port does not support HTTPS traffic?

- For the people who do not want this behavior, maybe a configuration option in Docker settings to open WebUI with the "original way"?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.