SAS Controller mode check, NMI error


Wibbling

Recommended Posts


Hello all,

Apologies as this might get a bit windy:

 

I have a Gen8 Microserver on which I am running unraid 6.10.3.

During a copy I saw poor disk performance (8-14MB/s).

I thought to try out a SAS controller, so I bought two from ebay. A pair of Fujitsu D2607-A21 GS 2s. These are recognised in the MegaRAID application as  LSI9211-8i

BIOS version 7.39.02

Firmware 20.00.07.00

 

However, when trying them out in the Microserver all my drives listed as unavailable and trying to Control C into the controller returned "NMI Detected please consult the integrated Management Log for more details".

 

Thus began my attempt to work out which mode (aiming for IT) the controllers are in:

 

I didn't want to flash the cards, just list info about them. I set about creating a bootable USB and ran smack into the "Failed to initialize PAL. Exiting program." error.

 

Thus I am trying to create a UEFI boot disk which is very tricky as my main PC is an iMac, I've a Linux box and my only windows machine is a Work laptop. It's an interesting life.

 

I did test the controllers out by plugging it into a different Linux box and using a sas to 4 sata 8087 cable attaching two disks which were seen as independent drives and I could make a software raid 0 from them (I pretend no competence here - I followed a guide from Jeff Geerling).

 

On this same Linux Mint 21 box running lspci | grep LSI returns "02:00.0 RAID bus controller: Broadcom / LSI SAS2008 PCI-Express Fusion-MPT SAS-2 [Falcon] (rev 03)."

 

Annoyingly the MegaRAID storage manager doesn't tell me the mode the card is in and (so far) I've not been able to boot by USB to get sas2flsh to list the drive, and the controller isn't presenting the Control C option at boot up (I've changed the slot it's in hoping this'd help).

 

The controller isn't currently in the Unraid Microserver box as

1. my Unraid box is offline awaiting a replacement drive 

2. it's a pain to get the card in and out and I wanted to try it in a more accessible environment that boots quicker - thus no diagnostics.

 

I am asking:
Have I missed an obvious way of checking the controller status? A built in command, a different tool? I've tried LSIutils, that just returned 0 MPT ports found.
Is it already *in* IT mode? If so, how can I confirm?

Is there a jumper/toggle to force the control+C to enter card bios?

Is the NMI error coming from a hardware mis-match?

 

 

All help gratefully received and may thanks.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.