After 6.11 No longer can access SMB via Network


Uplinkpro

Recommended Posts

Not sure what happened but I had everything setup with an MS user logging in to the network shares just fine. After 6.11 when I click tower it asks for user credentials and tells me my credentials are wrong. In the WebUI I have reset the password, and in windows i have cleared all saved credentials and still nothing. I (Accidently) ran New Permissions to try to help (and destroyed all of my dockers yay) and still nothing. diagnostics below, not sure where to start.

tower-diagnostics-20220924-1254.zip

Edited by Uplinkpro
Link to comment

[email protected]:~# ls -la /mnt/user
total 0
drwxrwxrwx  1 nobody users  61 Sep 24 09:53 ./
drwxr-xr-x 11 root   root  220 Sep 24 09:42 ../
drwxrwxrwx  1 nobody users  43 Sep 18 03:32 .Trash-0/
drwxrwxrwx  1 nobody users 360 Sep 21 15:25 appdata/
drwxrwxrwx  1 nobody users   6 Jul 20 19:26 backups/
drwxrwxrwx  1 nobody users  27 Jul  6 00:08 data/
drwxrwxrwx  1 nobody users 254 Sep 24 09:43 docker/
drwxrwxrwx  1 nobody users   6 Sep 15 05:58 roms/

Link to comment

The log shows a lot of master browser elections to Unraid:

Sep 24 10:38:40 Tower  nmbd[7511]: [2022/09/24 10:38:40.683165,  0] ../../source3/nmbd/nmbd_become_lmb.c:398(become_local_master_stage2)
Sep 24 10:38:40 Tower  nmbd[7511]:   *****
Sep 24 10:38:40 Tower  nmbd[7511]:   
Sep 24 10:38:40 Tower  nmbd[7511]:   Samba name server TOWER is now a local master browser for workgroup WORKGROUP on subnet 172.17.0.1
Sep 24 10:38:40 Tower  nmbd[7511]:   
Sep 24 10:38:40 Tower  nmbd[7511]:   *****
Sep 24 10:38:40 Tower  nmbd[7511]: [2022/09/24 10:38:40.683231,  0] ../../source3/nmbd/nmbd_become_lmb.c:398(become_local_master_stage2)
Sep 24 10:38:40 Tower  nmbd[7511]:   *****
Sep 24 10:38:40 Tower  nmbd[7511]:   
Sep 24 10:38:40 Tower  nmbd[7511]:   Samba name server TOWER is now a local master browser for workgroup WORKGROUP on subnet 172.18.0.1
Sep 24 10:38:40 Tower  nmbd[7511]:   
Sep 24 10:38:40 Tower  nmbd[7511]:   *****
Sep 24 10:43:33 Tower  nmbd[7511]: [2022/09/24 10:43:33.862075,  0] ../../source3/nmbd/nmbd_become_lmb.c:398(become_local_master_stage2)
Sep 24 10:43:33 Tower  nmbd[7511]:   *****
Sep 24 10:43:33 Tower  nmbd[7511]:   
Sep 24 10:43:33 Tower  nmbd[7511]:   Samba name server TOWER is now a local master browser for workgroup WORKGROUP on subnet 192.168.1.50
Sep 24 10:43:33 Tower  nmbd[7511]:   
Sep 24 10:43:33 Tower  nmbd[7511]:   *****

 

I think you may have a conflict in the Master Browser election.  This might cause SMB server lookup issues.  Remove the Master Browser plugin and see if it makes a difference.

 

Edit: Your router may also be trying to be the Master Browser.

Link to comment
3 minutes ago, dlandon said:

Show the output of the following command:

cat /etc/samba/smb-shares.conf

 

It will show how the shares are set up for user access.



here is the output ( i also removed the addon and yea still nothing new) 

 

[email protected]:~# cat /etc/samba/smb-shares.conf
[flash]
        path = /boot
        comment = Unraid OS boot device
        browseable = yes
        # Secure
        public = yes
        writeable = no
        write list = 
        case sensitive = auto
        preserve case = yes
        short preserve case = yes
        map archive = no
        map system = no
        map hidden = no
        map readonly = yes
        force user = root
[appdata]
        path = /mnt/user/appdata
        comment = 
        browseable = yes
        # Secure
        public = yes
        writeable = no
        write list = uplinkpro
        case sensitive = auto
        preserve case = yes
        short preserve case = yes
[backups]
        path = /mnt/user/backups
        comment = 
        browseable = yes
        # Secure
        public = yes
        writeable = no
        write list = uplinkpro
        case sensitive = auto
        preserve case = yes
        short preserve case = yes
[data]
        path = /mnt/user/data
        comment = 
        browseable = yes
        # Public
        public = yes
        writeable = yes
        case sensitive = auto
        preserve case = yes
        short preserve case = yes
[roms]
        path = /mnt/user/roms
        comment = 
        browseable = yes
        # Public
        public = yes
        writeable = yes
        case sensitive = auto
        preserve case = yes
        short preserve case = yes

 

Link to comment

Review your SMB share settings for each share.  Alll your shares are set for Public access.  Your flash device should not be set to Public.  Set it to Private and then set desired user access.

 

Did you intend for all your shares to be Public?  If you did, you should set up users in Unraid and the set user access for each share you want them to access.  Only set Public access for things that make sense for Public access.

 

I'm wondering if your flash has some issues.  I'm seeing some strange entries in your smb-shares.conf.

Link to comment
4 minutes ago, dlandon said:

Review your SMB share settings for each share.  Alll your shares are set for Public access.  Your flash device should not be set to Public.  Set it to Private and then set desired user access.

 

Did you intend for all your shares to be Public?  If you did, you should set up users in Unraid and the set user access for each share you want them to access.  Only set Public access for things that make sense for Public access.

 

I'm wondering if your flash has some issues.  I'm seeing some strange entries in your smb-shares.conf.

 

The flash drive is pretty new as well thats kinda crappy, but what you say makes since about the public access, i dont have it set for that if you see in the gui, this is how they are set
 

 

setting.png

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.