SMB access logs

Go to solution Solved by JorgeB,

Recommended Posts

hmmm not working :(


this is my smb extras

store dos attributes = yes
ea support = yes
map archive = yes
map hidden = yes
map system = yes
map readonly = yes

log level = 3
logging = syslog

server min protocol = SMB3_11
client ipc min protocol = SMB3_11
client signing = mandatory
server signing = mandatory
client ipc signing = mandatory
client NTLMv2 auth = yes
smb encrypt = required
restrict anonymous = 2
null passwords = No
raw NTLMv2 auth = no

#Unassigned devices share includes
   include = /tmp/unassigned.devices/smb-settings.conf
#Recycle bin configuration
   syslog only = No
   syslog = 0
   logging = 0
   log level = 0 vfs:0
Link to comment
On 10/2/2022 at 2:44 PM, JorgeB said:

Go to Settings -> SMB -> SMB Extras and add:


log level = 3
logging = syslog

Then check the syslog, note that Samba will get very chatty so it can fill it up after a few hours.


i found this instead

log level = 1 auth_json_audit:3


less chatty and only shows access logs, works with fail2ban so far

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.