Unmountable: Unsupported partition layout

Go to solution Solved by ChatNoir,

Recommended Posts


I am trying to add some more storage to my server, this is my first time and I've been encountering some issues.


I bought some 3TB SAS drives and are trying to replace my old 1TB SATA drives with them. My parity drive is a different 3TB drive from months back but it is also SAS, so I wouldn't think there are any issues with my server detecting SAS drives.


My Dell T610 with the PERC H700 detects the drives and they appear in unraid. I do a preclear on them, but when I put the drive into the array to replace an existing one I get the 'Unmountable: Unsupported partition layout' appear. The filesystem is XFS but then partition layout appears as 'factory-erased'. I have tried an xfs_repair and there are no issues but it still happens. I also cannot format the drive, it says formatting and then stops and nothing changes.


I have tried everything and have scoured the internet to find a fix but nothing works. Is anyone able to help?




My diags are below


Edited by DizzieNight
Added extra info
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.