Jump to content

nvme ssd cache drive missing after unraid update from 6.10.3 onwards


Go to solution Solved by JorgeB,

Recommended Posts

Hi All,

 

After some assistance please, when I update from 6.10.3 to any newer version my cache drive shows as missing.

When I restore back to 6.10.3 everything works as normal.

 

I am wondering whether a quirk needs to be added to the next version of Unraid for my particular nvme ssd model so it is recognised properly?

 

Attached are diagnostics on both versions.

 

Thank you

good nvme.JPG

missing nvme.JPG

tower-diagnostics-20221126-1316 6.10.3.zip tower-diagnostics-20221126-1257 6.11.5.zip

Link to comment
  • Solution

It's not a quirk issue, also quirks are only needed for some devices when there are two of the same model:

 

Nov 26 12:50:40 Tower kernel: nvme nvme0: controller is down; will reset: CSTS=0xffffffff, PCI_STATUS=0x10
Nov 26 12:50:40 Tower kernel: nvme nvme0: Does your device have a faulty power saving mode enabled?

 

Try this, on the main GUI page click on the flash drive, scroll down to "Syslinux Configuration", make sure it's set to "menu view" (top right) and add this to your default boot option, after "append initrd=/bzroot"

nvme_core.default_ps_max_latency_us=0 pcie_aspm=off

e.g.:

append initrd=/bzroot nvme_core.default_ps_max_latency_us=0 pcie_aspm=off


Reboot and see if it makes a difference.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...