Jump to content

Is this a bad ssd?


Go to solution Solved by thatotherguy321,

Recommended Posts

I've been having lots of problems with my docker apps. Configs mysteriously become read-only, docker apps not starting up at all, database issues, possible corrupt docker image.

 

After some digging, i see the following warning in syslogs repeating several times every 30sec.

Tower kernel: program smartctl is using a deprecated SCSI ioctl, please convert it to SG_IO

 

Since smartctl is used to read disks' SMART info, I suspected my drives, and found the attached disk log on one of my two cache SSDs. The two SSDs are identical brand new drives I recently bought. Previously was not using cache pools.

 

Also using smartctl to read that drive returned:

Short INQUIRY response, skip product id
A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.

 

Is this indication of a bad SSD?

 

Also, possibly related info, whenever I've rebooted the server, I'd lose one of the cache SSDs. I have to manually unplug and replug the power to that drive for it to be detected. I don't reboot often, so didn't think much of it.

 

Diag also attached.

 

 

ssd disk log.png

tower-diagnostics-20221205-1044.zip

Edited by thatotherguy321
Link to comment
9 hours ago, JorgeB said:

Device dropped offline, this is usually a power/connection problem.

Thanks! I will investigate the cabling.

 

For my own knowledge and future ability to diagnose problems on my own, what were the message(s) that lead to that conclusion? Is it intermittently going offline-online like a loose cable might cause?

I am still seeing sdg listed under /dev/, and the unraid UI shows a green dot on that drive. Should that happen on a drive that's dropped off?

Link to comment
  • 2 weeks later...
  • Solution

Conclusion: It was a bad SSD afterall.

 

After lots of hardware swapping: several new sets of sata cables, swapping the positions of the working HHD with the non-working SSD, even moving all drives to a whole new computer (motherboard/ram/cpu) with new install of unRAID. I was still getting the same error.

 

I had two Team Group SSDs in cache pool, so I tried reformatting both and using each as a single cache drive. In both configurations, I would still get the same error. Sometimes not right away, but 5-10min after bootup. So it's either both SSDs are bad, or they're incompatible with unRAID somehow.

 

Anyhow, I didn't want to waste any more time on the cheap SSD. I bought an SSD of another better known brand, and everything is working fine now. Never buying Team Group SSDs again...

Edited by thatotherguy321
  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...