Cannot modify files in SAMBA Share (Files created from Docker Containers)

Go to solution Solved by Squid,

Recommended Posts

Hi i recently made all my shares private and afterwards any new folders / files cannot be modified from my samba share that are created by docker containers.


This is occurring for all my docker containers which create files on my unraid server. I checked and all my

 PGID=100, PUID=99 , UMASK=000

seem to be correct for the dockers in question.


This is the permissions that the files / folders get created as 

drwxr-xr-x 1 nobody users 


If i run a chmod -R 0777 on the directory i can then modify my files from the samba share. Any one have any ideas ive been reading and searching the forums for a couple of hours now and cant figure out how to fix it


The correct permissions needed seem to be 

drwxrwxrwx 1 nobody users


Edited by Tbtf
Link to comment
On 12/30/2022 at 5:30 PM, Squid said:

Many containers (eg: 'arrs) also have additional options within their own settings to set the permissions on the particular files which they create.  Set the UMASK etc within their settings, or use permissions of 0777 in the settings.


That was it now just need to ask the authors of my other container to add a UMASK option in the environmental variables

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.