[PANIC] runtime error - Docker container refuses to start

Recommended Posts



I'm having troubles getting two containers to start. They flat out refuse. :)  It's two separate instances of Unpackerr that has worked flawlessly for a long time.


Log output:

2023/01/18 01:07:11 Unpackerr v0.11.1 Starting! PID: 1, UID: 0, GID: 0, Now: 2023-01-18 01:07:11 +0100 CET
2023/01/18 01:07:11 Missing Lidarr URL in one of your configurations, skipped and ignored.
2023/01/18 01:07:11 Missing Sonarr URL in one of your configurations, skipped and ignored.
2023/01/18 01:07:11 ==> GoLift Discord: https://golift.io/discord <==
2023/01/18 01:07:11 ==> Startup Settings <==
2023/01/18 01:07:11  => Sonarr Config: 0 servers
2023/01/18 01:07:11 [PANIC] runtime error: index out of range [0] with length 0


I've tried restarting the server and starting in Safe Mode. No difference unfortunately.

Any thoughts?


I've recently had problems with getting "Error: filesystem layer verification failed for digest sha256" intermittently when installing or updating containers. That problem isn't really solved, but I can't recall ever getting that problem with these two containers. Don't know if this is relevant in any way but I though I'd mention it.


Link to comment
On 1/20/2023 at 8:58 PM, kim_sv said:

With Unpackerr or some other container? I have other instances of it still running though..

Ive got a version of golift/unpackerr which is running my radarr and sonarr. 

then i have installed a version of hotio's unpackerr which is used for my version of radarr which is handling my 4K movies.


The version of hotio's unpackerr is giving me the same error as you got. I have tryed reinstall the docker, tryed to see if i could go back to an older version or anything but i cant get it to work again.


Ive also tryed to install a 2. version of the golift/unpackerr but that version wont even start.

Link to comment

To add to my report, I'm using hotio unpackerr for readarr.  Same error as others have reported.  I also tried deleting the container and rebuilding it from the template with no luck.  I have a friend who also uses the same distro and confirmed that when he applied the unpackerr update it quit working immediately with the same error.

Link to comment

OK, seems like Unpackerr is the problem and not my setup. I didn't think it was Unpackerr at first because I have three more instances that is running :latest just fine. Perhaps that's because they have Sonarr connections and the non working ones haven't..

I downgraded to version 0.10.1 for those with "[PANIC] runtime error" and that worked. 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.