Downloadspeed slow, uploadspeed good

Go to solution Solved by JorgeB,

Recommended Posts



I am quiet new to unraid. So far everything works fine or I cloud solve it by googling and reading the forum. 

But with this problem I haven't found a solution yet so I ask you.


I run Unraid 6.11.5 on an Mini-PC with i5-7500T and 16 GB RAM. Only drive is a WD blue nvme SSD with 2 TB (WD_Blue_SN570_2TB)

Array is using xfs with encryption. Installed plugins are: "CA Backup / Restore Appdata" + "Dynamix File Manager"


Problem is, download seems to be limited to around 500 MBit/s in a GBit network

Initial Test done by copying a large file via smb


Upload seems fine



output of iperf shows the same picture

unraid -> PC (download)

[ ID] Interval           Transfer     Bandwidth       Retr
[  4]   0.00-10.00  sec   558 MBytes   468 Mbits/sec    0             sender
[  4]   0.00-10.00  sec   556 MBytes   466 Mbits/sec                  receiver

PC -> unraid (upload)

[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-20.00  sec  2.20 GBytes   947 Mbits/sec                  sender
[  4]   0.00-20.00  sec  2.20 GBytes   947 Mbits/sec                  receiver


same if i am using the OpenSpeedTest Docker 



I also tried downloading directly using the Dynamix File Manager. Same picture

so i think it is not a smb problem.


the drive itselfe seems fine 

hdparm -tT /dev/nvme0n1

 Timing cached reads:   21352 MB in  1.98 seconds = 10766.71 MB/sec
 Timing buffered disk reads: 6286 MB in  3.00 seconds = 2094.71 MB/sec


I can see this behavior with two PCs. One Windows 10, one Windows 11.


See attached the server diagnostics package. 


Can someone point me in the right direction? 





Edited by NilsonNeo4
typos, clarifications
Link to comment
Posted (edited)

Hi thanks for the reply 


setting of eth0 is: 1000 Mbps, full duplex, mtu 1500


I tried connecting my laptop directly to the server (using a different/new cable): no change

I tried booting a live-Linux on my PC to rule out windows/driver issues: no change

I tried a Linux VM directly on the server, connected to br0: here is everything ok.


So it seems that something is wrong with the NIC. Hardware oder setting.

I will try to boot the server with a live-Linux to test once I have time for that. 


It cloud be a coincidence but it is suspicions that the download is limited to 500 MBit/s, so half of GBit. Is there maybe some QoS etc. in the system I am not aware of?


Edit: Tried booting a live-Linux on my server an did an iperf to my PC. Up- and Download are fine. So it must be a setting in unraid. 

Edited by NilsonNeo4
live-Linux on Server
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.